MozillaZine


Firefox 66.0.4 released - fixes the non-working add-ons

User Help for Mozilla Firefox
Diane Vigil
 
Posts: 283
Joined: October 6th, 2010, 3:55 am

Post Posted May 4th, 2019, 5:22 am

Mozilla has released Firefox 66.0.4, which fixes the non-working add-ons issue.

As alarming as the non-working add-ons issue was, they sure did a fast job in turning it all around. IIRC, they said they'd roll it out in the next few hours. I downloaded it via this link:

https ftp.mozilla.org/pub/firefox/candidates/66.0.4-candidates/build1/win64/en-CA/Firefox%20Setup%2066.0.4.exe

(Sorry if I'm not supposed to post links.)
Last edited by LIMPET235 on May 4th, 2019, 6:07 am, edited 1 time in total.
Reason: 64 bit version posted.

LIMPET235
Moderator

User avatar
 
Posts: 39432
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted May 4th, 2019, 6:09 am

If you are running a 32 bit system then go here...
> https://ftp.mozilla.org/pub/firefox/can ... n32/en-US/
& select the 66.0.4 Setup.exe.
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0-79.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

bookmarkimport
 
Posts: 51
Joined: February 3rd, 2014, 6:27 pm

Post Posted May 4th, 2019, 8:17 am


John Liebson
 
Posts: 6605
Joined: July 29th, 2003, 1:09 pm

Post Posted May 4th, 2019, 8:28 am

Install of 66.04, 64-bit successful, up to a point: So far, Kee and Feedbro extensions not only not restored, but cannot be downloaded. I get an error message when trying these two, "Download failed. Please check your connection." There may well be other extensions suffering from this; I may be missing others that I'm not yet aware of.

bookmarkimport
 
Posts: 51
Joined: February 3rd, 2014, 6:27 pm

Post Posted May 4th, 2019, 9:44 am

Actually, I still have two extension that don't work: Open Tabs Next to Current and Load Background Tabs Lazily.

LIMPET235
Moderator

User avatar
 
Posts: 39432
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted May 4th, 2019, 9:47 am

I think that you/we will just have to wait till "they" decide to fix it.
Some of the extensions that I just re-installed had a message at the top, stating the following...
"We rolled out a hotfix that re-enables affected add-ons. The fix will be automatically applied in the background within the next few hours. For more details, please check out the update at https://support.mozilla.org/en-US/kb/ad ... ll-firefox.

So...sit tight.
:)
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0-79.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

John Liebson
 
Posts: 6605
Joined: July 29th, 2003, 1:09 pm

Post Posted May 4th, 2019, 9:54 am

To add to the problems, I have now tried four times to download the 64-bit version, from the link above, on my wife's computer; all four attempts failed. ( had deleted the download on my computer after running it, forgetting that I needed it for her machine.)

I turned on the Studies option for her.

RobertJ
Moderator

User avatar
 
Posts: 10875
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted May 4th, 2019, 12:20 pm

.
Studies option worked for me. The ftp downloads site for FF is currently disabled.

.
FF 84.0.1 - TB 78.6 - Mac OSX 10.13.6

rothers
 
Posts: 49
Joined: September 29th, 2003, 11:51 am

Post Posted May 4th, 2019, 12:36 pm

And nothing for 52.9 ESR, complete amateurish shambles.

therube

User avatar
 
Posts: 20632
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 4th, 2019, 12:48 pm

And nothing for 52.9 ESR, complete amateurish shambles.

If anyone is running a pre-Quantum, version of Firefox [that requires signing] (so like FF 52 or 56) you will also be affected.
As there will be no fix for "Firefox", you will need to set the xpinstall.signatures.required Pref to 'false'.
(That should automatically re-enable your missing extensions. xpinstall.signatures.required will need to remain, false.)

https://forums.informaction.com/viewtop ... 82#p100082
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

mozurkewich
 
Posts: 230
Joined: April 7th, 2008, 9:58 am

Post Posted May 4th, 2019, 12:59 pm

therube wrote:
And nothing for 52.9 ESR, complete amateurish shambles.

If anyone is running a pre-Quantum, version of Firefox [that requires signing] (so like FF 52 or 56) you will also be affected.
As there will be no fix for "Firefox", you will need to set the xpinstall.signatures.required Pref to 'false'.
(That should automatically re-enable your missing extensions. xpinstall.signatures.required will need to remain, false.)

https://forums.informaction.com/viewtop ... 82#p100082


How do I do that? Via my Firefox account?

kerft
 
Posts: 585
Joined: January 30th, 2019, 9:38 am

Post Posted May 4th, 2019, 1:08 pm

That post is about old versions. That fix will work on Firefox 45.9.0ESR. I don't think it will work on most other versions.
For your version 66, if you enable studies in Firefox options, and restart Firefox a few times, you should be fixed.

videobruce
 
Posts: 284
Joined: March 25th, 2006, 11:38 am
Location: New York State

Post Posted May 4th, 2019, 1:09 pm

If anyone is running a pre-Quantum, version of Firefox [that requires signing] (so like FF 52 or 56) you will also be affected.
As there will be no fix for "Firefox", you will need to set the xpinstall.signatures.required Pref to 'false'.
(That should automatically re-enable your missing extensions. xpinstall.signatures.required will need to remain, false.)?


I'm running v56, I looked at "xpinstall.signatures.required" and it was already set to false! Now what?
Browsers that don't have a Menu bar and don't place the tab bar below the content (where it's been for 25 years) are poorly designed. Period. Don't 'fix' something that isn't broke!

martinlest
 
Posts: 45
Joined: August 8th, 2004, 3:16 am

Post Posted May 4th, 2019, 1:11 pm

videobruce wrote:
If anyone is running a pre-Quantum, version of Firefox [that requires signing] (so like FF 52 or 56) you will also be affected.
As there will be no fix for "Firefox", you will need to set the xpinstall.signatures.required Pref to 'false'.
(That should automatically re-enable your missing extensions. xpinstall.signatures.required will need to remain, false.)?


I'm running v56, I looked at "xpinstall.signatures.required" and it was already set to false! Now what?
I set mine to false, but no change - the addons are still unusable.

kerft
 
Posts: 585
Joined: January 30th, 2019, 9:38 am

Post Posted May 4th, 2019, 1:16 pm

For versions less than 66 and higher than 45 there isn't as easy a fix. Perhaps there will be a study or hotfix on Monday, perhaps not. Perhaps you can find a nightly version you like or an old developer version. This would be a good weekend to install a portable version of Firefox 66, Firefox 45.9.0ESR, or some other browser.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 4 guests