MozillaZine

Linux Firefox 67 conflit with compatibllity.ini on safe mode

User Help for Mozilla Firefox
Markco
 
Posts: 28
Joined: June 22nd, 2011, 4:07 am

Post Posted June 10th, 2019, 1:03 am

Bug the compatibility.ini file to safe mode is changed of :

Code: Select all
[Compatibility]
lastVersion=67.0.1_20190529130856/20190529130856


to:

Code: Select all
[Compatibility]
LastVersion=Safe Mode

Changing to "Safe Mode", this makes the:
Code: Select all
Using an older version of Firefox can corrupt bookmarks and browsing history already saved to an existing Firefox profile. To protect your information, create a new profile for this installation of Firefox.

Image
dialog appear by restarting in normal mode and loop the bug, even creating a new profile.

Delete the compatibility.ini file before restarting in normal mode or edit the compatibility.ini file empty it and save it and put the file readonly
Sorry, I use an online translator French / English
---
OS: Linux Mint 19.1 - kernel : 5.0.0.16-64Bits /---/ Profil Firefox : 67.0.1 /---/ Profil Waterfox : 56.2.10 /---/Profil TB : 60.7.0

therube

User avatar
 
Posts: 19757
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 10th, 2019, 5:55 am

(I'm on 69.)


Is what you posted for compatibility.in complete?

I see more, like:

Code: Select all
[Compatibility]
LastVersion=69.0a1_20190607220156/20190607220156
LastOSABI=WINNT_x86_64-msvc
LastPlatformDir=C:\WLIB\FIREFOX\FIREFOX
LastAppDir=C:\WLIB\FIREFOX\FIREFOX\browser


Restarting in Safe Mode, I'm not seeing any change to LastVersion= ?

So not quite sure what you're doing, how you're doing, to get the results you're seeing?

-------

Profiles, profiles.ini, compatibility.ini, & all associated, are a cesspool of bugs, that no one understands what is expected or what is to be expected.

So what you are seeing is expected.
You might say, this is the new norm :-).

-------

Also note the, --allow-downgrade command-line switch.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Markco
 
Posts: 28
Joined: June 22nd, 2011, 4:07 am

Post Posted June 10th, 2019, 6:36 am

Beta and Nightly are not affected by this bug, it's only on the stable version 67.0.1
Sorry, I use an online translator French / English
---
OS: Linux Mint 19.1 - kernel : 5.0.0.16-64Bits /---/ Profil Firefox : 67.0.1 /---/ Profil Waterfox : 56.2.10 /---/Profil TB : 60.7.0

Markco
 
Posts: 28
Joined: June 22nd, 2011, 4:07 am

Post Posted June 12th, 2019, 4:14 am

The problem does not appear in version 67.0.2.
Sorry, I use an online translator French / English
---
OS: Linux Mint 19.1 - kernel : 5.0.0.16-64Bits /---/ Profil Firefox : 67.0.1 /---/ Profil Waterfox : 56.2.10 /---/Profil TB : 60.7.0

dickvl

User avatar
 
Posts: 52688
Joined: July 18th, 2005, 3:25 am

Post Posted June 12th, 2019, 7:14 am

You aren't sharing this profile between other Firefox versions or even a different OS (Windows) ?

therube

User avatar
 
Posts: 19757
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 12th, 2019, 10:11 am

There was a bug (go figure) on the Linux end, now fixed in 67.0.2.

"Starting in safe mode on Linux or macOS causes Firefox to think on the subsequent launch that the profile is too recent to be used with this version of Firefox (Bug 1556612)"

https://www.mozilla.org/en-US/firefox/6 ... easenotes/
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 14 guests