MozillaZine

Extremely slow type/form rendering in Firefox 67&68 [Linux]

User Help for Mozilla Firefox
flberger
 
Posts: 5
Joined: November 30th, 2018, 2:24 am

Post Posted August 5th, 2019, 8:31 am

In all versions of the Firefox browser above 66.x I am experiencing extreme slowdowns handling the browser on a Gentoo Linux system. Apparently this is related to type rendering in forms, text areas, and the URI bar.

After typing the string "1234567890" as fast as I can, it takes around 5 to 7 seconds for the typed numbers to appear. They appear one by one, often with a second or more delay. Again, pretty much in every web form and in the URI bar.

I have tried the usual recommendations, using a fresh profile, a private window, disabling addons. Same effect.

I have had similar problems with the Qt based text editor "TeXStudio". All other applications, including GUI and input heavy ones like Mozilla Thunderbird and LibreOffice, work and render just fine.

Using top, I see that Firefox ramps up to ~50 % CPU when typing, along with X which also goes to 50-60 %.

I use a rather minimal XFCE4 desktop environment.

Currently I am staying on FF 66, which does not exhibit this behaviour.

Apparently
  • Mozilla changed something in font / form rendering starting in FF 67
  • It's something other applications are not affected by
  • As it only happens in forms, it might also be related to spell checking (which I disabled) or some weird search in the background (which I tried to disable, too)
  • It's a rare bug / condition, as apparently no one is reporting this. Might be some weird outdated library on my part?
I have little experience in tracking such a thing down. Where should I start? Any help would be greatly appreciated.
Last edited by LIMPET235 on August 5th, 2019, 8:55 am, edited 1 time in total.
Reason: Added [Linux] to the title.

therube

User avatar
 
Posts: 19906
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 5th, 2019, 9:16 am

Test in Safe Mode.

Have a different windows manager that you can test under?

If ? Hardware Acceleration is disabled, by default, in Linux, you might see if manually enabling it helps?
(Backup first.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

flberger
 
Posts: 5
Joined: November 30th, 2018, 2:24 am

Post Posted August 5th, 2019, 9:40 am

therube wrote:Test in Safe Mode.

I have tested in Safe Mode - same behaviour.

therube wrote:Have a different windows manager that you can test under?

I unfortunately can not. However, since it used to work up to 66.x, and all other applications are doing fine, I suspect changing the window manager is not going to change behaviour.

therube wrote:If ? Hardware Acceleration is disabled, by default, in Linux, you might see if manually enabling it helps?
(Backup first.)

It is disabled in my usual setup, but was enabled in Safe Mode. Results are the same.

I'd love to dig down into Firefox and see what it is doing when typing into text areas and forms. As CPU goes up visibly, it must be something computationally expensive, and it apparently has been introduced in v67.

jscher2000

User avatar
 
Posts: 10674
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted August 5th, 2019, 11:13 am


Grumpus

User avatar
 
Posts: 12185
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 5th, 2019, 11:17 am

Try disabling the Accessibility Services access on the /edit/preferences//privacy and security tab.
Also, are you depending on text from your own system or from offline, character sets offline may be slower than local (on your system)
Also are you having to convert from a pictogram alphabet to and standard character set.
You might want to review your settings in /edit/preferences/general/fonts & colors/ which "fonts for:" setting and alternate text encoding
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

Grumpus

User avatar
 
Posts: 12185
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 6th, 2019, 6:18 am

One more thought - try and allow sites to use their own fonts instead of ones you call out in /edit/preferences/general/fonts & colors/
If using your own fonts it may also slow the process.
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 4 guests