MozillaZine

Unwanted search suggestions

User Help for Mozilla Firefox
Odin2
 
Posts: 666
Joined: March 10th, 2012, 8:08 pm

Post Posted November 9th, 2019, 10:30 am

Although using the options menu I'm signed up to use the locbar only for URLs and to have no suggestions, the latest Fx version pops up search suggestions [for "next time" or "this time"] and a new bar below the locbar reiterating the URL I want followed by "--visit," whenever I use the locbar. How can I stop these pop-ups?

LIMPET235
Moderator

User avatar
 
Posts: 39303
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted November 10th, 2019, 2:29 am

Hi,
Open a new, blank tab & type in "about:config" (No quotes.)
In the search bar at the top, enter url & scroll to > browser.urlbar.maxRichResults
Right click > Modify & set to zero.
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

greybeard2012
 
Posts: 89
Joined: October 21st, 2012, 8:27 pm

Post Posted November 10th, 2019, 9:30 am

Strangely enough I've just updated to FF v57 to the most recent v70 after much debate with myself and I've just been through the hoops trying to get it to do as and display exactly as I want. I eventually discovered that most of the problems I had were simply because the FF Profile userChrome.css is now disabled by default and has to be re-enabled.

But I've been researching how to get rid of that pointless search suggestion bar annoyance for the last half-hour. The main FF Options settings not to offer search suggestions do not fix that but I finally found, on another site, and applied that about:config edit value solution LIMPET235 has just posted here.

I can confirm it works perfectly to remove the blue (colour depends on theme) primary search engine bar which otherwise appears underneath the URL address box.

However what it does not resolve is the equally pointless: "This time, search with: ..........." your secondary search engines in an even wider bar underneath that. With the primary search engine bar disabled it moves up underneath the URL address and is just as annoying.

What I can not find is a solution for disabling this.

On that other forum the poster suggested it was one of the "browser.urlbar........" about:config entries that needed to be changed from True to False or visa versa. Problem is there are more than a dozen of those and nothing obviously connected with the secondary search engine suggestion bar.

I'm wary of messing with any of them without some more knowledgeable advice about this matter.
Last edited by greybeard2012 on November 11th, 2019, 6:01 am, edited 1 time in total.

jscher2000

User avatar
 
Posts: 11091
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted November 10th, 2019, 3:31 pm

greybeard2012 wrote:"This time, search with: ..........." your secondary search engines in an even wider bar underneath that.

Those are the "one off" search buttons, so:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.oneOffSearches preference to switch the value from true to false

greybeard2012
 
Posts: 89
Joined: October 21st, 2012, 8:27 pm

Post Posted November 11th, 2019, 6:00 am

That was genuinely the about:config entry I was looking at yesterday thinking it was the most likely culprit but, as said, I did not want to change it without advice. I never mess with the about:config settings Unless I'm certain what I'm doing.

So thanks for that. I'll give it a try.

Odin2
 
Posts: 666
Joined: March 10th, 2012, 8:08 pm

Post Posted November 11th, 2019, 12:15 pm

Thanks, limpet and jscher. (For whatever reason, I've seen your responses only now.) I've implemented both suggestions and the problem seems completely gone. Not sure if limpet's suggestion alone would have worked, perhaps partially, but I'm okay for now with making both changes.

MicheleBS
 
Posts: 85
Joined: May 11th, 2012, 11:14 am

Post Posted November 14th, 2019, 5:21 pm

I encounter this behavior, too, and luckily I found here someone with the same problems.
But my situation is slightly different from yours, and these solutions aren't enough to me yet.

In fact, I do make use of the suggestions feature, but only with entries belonging to the History and the Bookmarks:
Options -> Privacy & Security -> Address Bar -> History / Bookmarks

But I want to keep my imagination in good health, that's why I have always turned the "suggestions" feature from the search engine off:
Options -> Search -> Default Search Engine -> Provide search suggestions



Some days ago, though, I saw this annoying new bar you are talking about, and in two cases, unfortunately, I clicked Next time search.... This was, suppose, for the words: "yyy" and "zzz".

Now, so, every time I write for example yyy in the search bar, the option http://yyy/ yyy — Visit is shown at the top, and if I press Return, Firefox brings me to a supposed http://yyy/, with sort of a "Browse By Name" behavior, because I see that it tries to open yyy.com.

What I can't do now is to make Firefox to forget about these two entries. I can't find where to delete the "yyy" and "zzz" search options. But still I want to see suggestions from my History and Bookmarks. Setting browser.urlbar.maxRichResults to 0 can't be a solution to me.

What to do?

Thank you for your help!

jscher2000

User avatar
 
Posts: 11091
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted November 14th, 2019, 11:44 pm

MicheleBS wrote:Some days ago, though, I saw this annoying new bar you are talking about, and in two cases, unfortunately, I clicked Next time search.... This was, suppose, for the words: "yyy" and "zzz".


(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste fixup.dom and pause while the list is filtered

(3) For each word you want to go to search instead of a web request, right-click > Reset its corresponding preference

Success?

MicheleBS
 
Posts: 85
Joined: May 11th, 2012, 11:14 am

Post Posted November 15th, 2019, 12:58 am

jscher2000 wrote:
(1) about:config
(2) "fixup.dom"
(3) For each word, right-click > Reset

Success?


SUCCESS!!

:banana:

GatesIsAntiChrist

User avatar
 
Posts: 72
Joined: May 23rd, 2007, 12:03 pm

Post Posted November 12th, 2020, 3:26 am

I believe I have a slightly different issue with the URL bar.

1. I never want any search engine navigation from the URL bar, with one "exception", to go to Google itself, so I go alt-D G {ENTER} and then type and autocomplete inside Google's search box (the MRU or whatever logic desirably always has Google on the very top line). IOW I don't want a search engine in URL bar except as a MRU(most recently used) choice - no offense for the kind feature offering :) And thank someone a zillion for the autocomplete making me able to reach google in 3 clicks as just described! (Actually for me a single click alt-home. So I don't even need the URL bar for that at all really ;) ) *(footnote)

2. Even if 1. is mandatory, the real nuisance is the suggested website. I type alt-D H I S T {down arrow}{ENTER} many times every day, as there is a frequently used URL that has "hist" in it and this works spectacularly. The choices in the dropdown from line 2 onward are awesomely intelligent, and since jsher taught me of % and * and such, even MORE awesome. The problem is that on the sequence I just described, I sometimes hit the enter key an instant before I hit the down arrow. [Yeah, yeah, this is idiot User Error 001, mistyping, but it happens more than rarely, rapidly moving my right hand from the letter I key way over to the arrow key right before hitting the enter key.] And here it is: I get sent to the nuisance top dropdown choice, history.nasa.gov/, which is always on the top line of the dropdown - which I never ever want. In fact, if that choice was removed entirely, I wouldn't even have to hit down arrow at all (well 99% of the time, depending on MRU), right?

[Provide search suggestions is UNchecked in about:preferences#search
about:preferences#privacy / Address bar / Top Sites unchecked
browser.urlbar.suggest.topsites false
services.sync.prefs.sync.browser.urlbar.suggest.topsites true (I flipped it to false, but still see nasa)]

My key wish is to rid the nasa suggestion; and ridding google would be a bonus. Thanks. Thank you each for all of your brilliant and generous efforts. Maybe I'm just being a baby. I *heavily* benefit from autocomplete. But not to suggest popular sites. Or search engines for that matter. I'm fine with google doing that; but I just want the URL bar to only fill the dropdown with recently used and favorites. Alas, the answer was not browser.urlbar.suggest.topsites false.

EDIT: Sometimes hitting the delete key helps to pare the URL "rich" suggestions dropdown. Tried that. But history.nasa.gov always returns. Can't kill it.
----------------
*(footnote) [I did investigate in https://support.mozilla.org/en-US/questions/1283913 (a closed question)
Wesley's One-Click Search Engines idea but it's already down to Google only, and 'remove' is grayed out. Also FYI .oneOffSearches is not a config option here on 82.0.2. Partial search for oneo only presents:
browser.search.hiddenOneOffs Google
browser.urlbar.update2.disableOneOffsHorizontalKeyNavigation false
browser.urlbar.update2.localOneOffs false
browser.urlbar.update2.oneOffsRefresh false
Actually I don't know what oneOffs means, but I'm just sharing what I see, in case useful]

jscher2000

User avatar
 
Posts: 11091
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted November 12th, 2020, 11:09 am

If you open the Library window to history (Ctrl+Shift+h), enter nasa in the tiny search box upper right to filter the results (this avoids misclick errors), you could try: right-click an entry on history.nasa.gov and choose Forget About This Site. This does a deeper cleaning than simply deleting history entries or hiding suggestions. Often works. Not always for some reason.

GatesIsAntiChrist

User avatar
 
Posts: 72
Joined: May 23rd, 2007, 12:03 pm

Post Posted November 12th, 2020, 2:15 pm

Thank you for that tip and your kind and impressively clear and accurate help once again. Yes, it was on the list, and I removed it, but it didn't affect it, at least yet (though I haven't restarted.) Unkillable site, huh. I don't think I ever went there, except by accident since it's been irritatingly begging to be clicked.

(I may not restart for a while. And I as a rule sleep or hibernate so I normally avoid restarting for days. I keep a ton of windows (not tabs) going, maybe over 100 sometimes, and it takes maybe 7 minutes to load them all. And worse, every time I do, all except the "active" window are in essentially backwards order for alt-tabbing, so I have to start FX, close it, and start it to get the same window order as before - so a 15 minute chore. It's done that reversal now for many months, perhaps starting with Quantum.)

LIMPET235
Moderator

User avatar
 
Posts: 39303
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted November 13th, 2020, 3:16 am

Hi,
Just a little suggestion here...
I've seen numerous reports re; the "Hibernate" option & using it causes problems at times.
SLEEP is a much better option.

Stay safe.
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

GatesIsAntiChrist

User avatar
 
Posts: 72
Joined: May 23rd, 2007, 12:03 pm

Post Posted November 13th, 2020, 4:49 am

Thanks for that advice. That would be awful if your reports are true. Hibernate has an inherent advantage in that it insulates memory contents from power loss. It also uses less power from both wall and battery. Sleep has the [IINM sole] advantage of a faster resumption; I had never heard it called the better option. But if hibernation wins from any technical or practical standpoint that of course goes out the window if problems have arisen. Do you recall what devices and platforms they said, or what manufacturing period? I'm going to guess, Windows 10 on some recently built laptops. That are non-Dells :)

Edit: I remember an additional subtle benefit to "sleep" beyond the quicker resumption - you don't have to push the power button to resume. I had a P.C. with a beginning-to-fail power button so I chose sleep instead of hibernate, unless I was transporting the device(unplugged), or a thunderstorm threatened(unplugged), or was expecting non-use for some time period. But everytime I went "sleep" I crossed my fingers for no power interruption, which can be moderately gruesome :(

P.S. I'm so glad the board remains. supp.m.org is not on the same planet as the quality and the usefulness here, nor in any sense reddit. And of course the "community" here. (Group hug, now)

LIMPET235
Moderator

User avatar
 
Posts: 39303
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted November 13th, 2020, 4:58 am

Hi GIAC,
Sorry, but I do not remember the sites or any of the details.
Just know that it caused a few errors/probs

Perhaps it was somewhere on the Window's Fora...either WIN 7 or Ten?
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 10 guests