MozillaZine

Firefox-esr 60.8.0 NOT updating in Linux Mint 19.2??

User Help for Mozilla Firefox
ken0069
 
Posts: 10
Joined: March 3rd, 2012, 1:28 pm

Post Posted November 18th, 2019, 2:26 pm

I'm running the ESR 60.8.0 version on Linux Mint-Mate 19.2 and it's not updating to the latest ESR version, which is 68?? I've got the Mozilla PPA loaded which is how I got version 60.8 to begin with but it seems that that PPA is no longer supported and not automatically updating?

Any help on this as I really don't want to have to load FF70!

Thanks

kerft
 
Posts: 578
Joined: January 30th, 2019, 9:38 am

Post Posted November 19th, 2019, 7:44 am

The PPA for ESR looks like it may be abandoned/delayed?. https://launchpad.net/~mozillateam/+archive/ubuntu/ppa Contact "mozilla team" to verify. https://launchpad.net/~mozillateam
The security flaws in 60 may be acceptable, depending on your risk tolerance and the websites you visit. If not, you may be able to install ESR 68 as a snap https://www.linuxuprising.com/2018/11/h ... tu-or.html or install it manually by extracting https://support.mozilla.org/en-US/kb/in ... efox-linux
This file will give you the filename / link for latest esr https://ftp.mozilla.org/pub/firefox/rel ... README.txt or click through https://www.mozilla.org/en-US/firefox/enterprise/

ken0069
 
Posts: 10
Joined: March 3rd, 2012, 1:28 pm

Post Posted November 19th, 2019, 8:51 am

Kerft thanks for you reply, but, I've been to every one of those links before and in fact used one of them to install the PPA for the install of FF-esr v60 but there's nothing mentioned on any of them about how to correct the problem with the PPA not updating the software.

Can you give me a link to where I could ask this question in the mozilla firefox support forum? I've been on that site but it's a bit overwhelming for my 74 year old mind.

Oh, and security is a major issue for me as I do almost everything online any more to try to keep from having to run all over town. Banking, Social Security, Medicare, Medigap Insurance..............etc.

I'll wait and check in here over the next few days to see if anyone else has any ideas but it's looking more and more like I'm just going to have to bite the bullet and install v70 whether I want or not. [/rolleyes]

kerft
 
Posts: 578
Joined: January 30th, 2019, 9:38 am

Post Posted November 19th, 2019, 9:04 am

IMO the simplest fix is remove PPA Firefox and install Snap Firefox 68 ESR. *BACKUP* your profile / bookmarks / passwords first, snap uses a new profile. Official Firefox support is here https://support.mozilla.org/en-US/ and there is an icon for "Firefox for Enterprise" which may include ESR, or there is a Firefox icon. At the bottom of those pages is ask the community / ask a question .

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 7 guests

cron