MozillaZine

How update FFox with enterprise policy to new(er) version

User Help for Mozilla Firefox
phickspc
 
Posts: 71
Joined: April 7th, 2016, 8:32 am

Post Posted December 5th, 2019, 3:15 pm

I have a firefox portable whose updates I restricted via enterprise policy.json, which shows "updates are disabled by your administrator".
I did it because I don't want to automatically update to the latest version.
I know that I can download the firefox portable version of my choice and copy over the profile folder.
But, when I do that, it doesn't copy any changes made in about:config nor the distribution folder and policies.json.
How do I selectively update my current installation to a specific version
Alternatively, how do I copy over ALL settings (as mentioned above) to a new installation?

phickspc
 
Posts: 71
Joined: April 7th, 2016, 8:32 am

Post Posted December 12th, 2019, 9:19 am

Anyone?

dickvl

User avatar
 
Posts: 53004
Joined: July 18th, 2005, 3:25 am

Post Posted December 12th, 2019, 12:38 pm

Why not disable this policy temporarily (e.g. rename policies.json) if you are ready to update?

That way you should keep your profile folder with the modifications.

jscher2000

User avatar
 
Posts: 10786
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted December 13th, 2019, 12:36 am

Check on the Portable forum whether it is safe to install the new version over the old one.

phickspc
 
Posts: 71
Joined: April 7th, 2016, 8:32 am

Post Posted December 14th, 2019, 5:49 pm

dickvl wrote:Why not disable this policy temporarily (e.g. rename policies.json) if you are ready to update?

That way you should keep your profile folder with the modifications.


I'd love to but when I disable the policy, firefox will instantly try to update me to the latest version 71.0, but I only want to update to 69, not 71.0, so how can I do that?

dickvl

User avatar
 
Posts: 53004
Joined: July 18th, 2005, 3:25 am

Post Posted December 14th, 2019, 6:16 pm

Note that 69 isn't safe to use.
Why do you want to use this specific Fx 69 version ?
If you use Firefox 68 ESR (68.3.0) then you have an up to date version.

If you really want to update to Firefox 69 then you will have to install this specific version.

phickspc
 
Posts: 71
Joined: April 7th, 2016, 8:32 am

Post Posted December 16th, 2019, 2:27 pm

Solution: I installed Portable version of my choice into same directory as the firefox browser which had all the settings and profiles. After installing, all the settings and policies and profile were there. But the software had indeed updated. Success! Thanks!

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 5 guests