MozillaZine

CTRL-F search doesn't make a sound,if search cannot be found

User Help for Mozilla Firefox
TBUser12345
 
Posts: 37
Joined: September 24th, 2014, 1:45 pm

Post Posted December 15th, 2019, 11:21 am

I've noticed that when I do a CTRL-F, to find/search for some text, and if that text cannot be found, I now no longer hear a sound that tells me that the search text is not present on the screen. I found this sound useful, as it alerted me instantly if the search could not be found. Is there a way to switch this feature back on? Thanks a lot.

the-edmeister

User avatar
 
Posts: 32253
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted December 15th, 2019, 11:00 pm

In about:config see if this preference is set to true which is the default value.

accessibility.typeaheadfind.enablesound;true

Also, there is accessibility.typeaheadfind.soundURL which is a beep by default.


.
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

morat
 
Posts: 3832
Joined: February 3rd, 2009, 6:29 pm

Post Posted December 16th, 2019, 8:46 am

No sound alert when using Find in page
http://bugzilla.mozilla.org/show_bug.cgi?id=1601886

For reading only as Bugzilla is not a forum.

TBUser12345
 
Posts: 37
Joined: September 24th, 2014, 1:45 pm

Post Posted December 16th, 2019, 9:38 am

Thanks a lot for both replies.
Regarding:
accessibility.typeaheadfind.enablesound;true
Sorry, I'm pretty new to this, please can you tell me where to look, just to see if this is true, although I understand from the bug report, that even if it is, there is a problem.
I'm just curious about checking this. Thanks!

morat
 
Posts: 3832
Joined: February 3rd, 2009, 6:29 pm

Post Posted December 16th, 2019, 9:51 am

Open the about:config page. Search for the preferences.

Configuration Editor for Firefox
http://support.mozilla.org/en-US/kb/about-config-editor-firefox

P.S.

Here is how to open the about:config page in Thunderbird.

Tools > Options > Advanced > General > Config Editor

TBUser12345
 
Posts: 37
Joined: September 24th, 2014, 1:45 pm

Post Posted December 16th, 2019, 9:55 am

Thanks! It is set to true, so I guess it's a bug that has occured with a fairly recent upgrade.
I definiteiy remember that working in the past.

dickvl

User avatar
 
Posts: 53135
Joined: July 18th, 2005, 3:25 am

Post Posted December 16th, 2019, 1:48 pm

Maybe related to moving from XUL to HTML for various components.

TheVisitor
 
Posts: 5092
Joined: May 13th, 2012, 10:43 am

Post Posted December 16th, 2019, 2:34 pm

Does not seem to work in latest Nightly either....

TheVisitor
 
Posts: 5092
Joined: May 13th, 2012, 10:43 am

Post Posted December 16th, 2019, 3:42 pm

After a bunch of 'regression' testing Mozregression tool came up with :

Bug 1553384, fix intermittent orange caused by fission changes, by waiting for page and findbar to be ready

as being the patch that broke the sound. That patch seems to be mostly a 'test build' patch but I will add it to bug report above and mark it new and see where it goes.

EDIT: Looks like the bug above is a 'duplicate' of https://bugzilla.mozilla.org/show_bug.cgi?id=1602033

22Green
 
Posts: 11
Joined: December 26th, 2019, 7:38 pm

Post Posted December 26th, 2019, 7:42 pm

I recently had this issue happen this evening. It worked fine yesterday I believe. Its a nice feature.

I figured it was a Windows 10 thing and went down that path to no avail and then Googled the issue and included Firefox and low and behold I found this forum and another thread with users have the same issue with v.71.0

Ugh I wasted an hour on this. #-o I see the last post was the 16th. Has there been any updates or patches yet?

Thanks

22Green
 
Posts: 11
Joined: December 26th, 2019, 7:38 pm

Post Posted December 29th, 2019, 8:09 pm

Any updates? My work PC has same issue. Is there a fix with new version or a correction to get this feature back?

morat
 
Posts: 3832
Joined: February 3rd, 2009, 6:29 pm

Post Posted December 29th, 2019, 8:22 pm

Have some patience. Someone has been assigned to take a look at the issue.

The developers won't fix the bug in Firefox 71. They may fix it in Firefox 72.

22Green
 
Posts: 11
Joined: December 26th, 2019, 7:38 pm

Post Posted December 31st, 2019, 7:20 am

I have plenty of patience... There were no new replies. This must effecting every user so I asked again. I don't how it breaks in the middle of a version.

Thanks for the update.

morat
 
Posts: 3832
Joined: February 3rd, 2009, 6:29 pm

Post Posted December 31st, 2019, 8:51 am

You can follow the issue by reading the bug thread.

http://bugzilla.mozilla.org/show_bug.cgi?id=1602033

For reading only as Bugzilla is not a forum.

Firefox 72 release date is 1/7/2020.

http://wiki.mozilla.org/Release_Management/Calendar

22Green
 
Posts: 11
Joined: December 26th, 2019, 7:38 pm

Post Posted January 8th, 2020, 7:59 pm

Installed FF 72 the issue is still there. We'll have to wait to the next release I guess.

I've been following this link but can't really make heads or tails what this comment means ... firefox74:fixed - version 71 branch

"Status: RESOLVED → VERIFIED
status-firefox74: fixed → verified
Version: 71 Branch → Trunk"

https://bugzilla.mozilla.org/show_bug.cgi?id=1602033


Clara Guerrero

Comment 16 • 6 hours ago

Hi,
I just checked the last nightly build and I was able to verify the fix, now when searching a term that is not present in the page using the find bar , the sound will be triggered.
Thanks, I've updated the flags for 74.0a1 (2020-01-08) (64-bit) version.
Best,
Clara.
Status: RESOLVED → VERIFIED
status-firefox74: fixed → verified
Version: 71 Branch → Trunk
Clara Guerrero

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 7 guests