MozillaZine

Saving an email as eml vs. html

User Help for Mozilla Firefox
sludge7071-g
 
Posts: 78
Joined: May 9th, 2016, 10:18 am

Post Posted February 10th, 2020, 9:14 am

I have been saving emails I need as html, because I thought eml is an outdated format - and reached EOL, a while back.

Then with an html email I just saved, I see this, with U+2019

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


https://www.babelstone.co.uk/Unicode/whatisit.html
U+2019 : RIGHT SINGLE QUOTATION MARK {single comma quotation mark}

If you save the email as an:
1.) eml . . . this character is as expected
2.) html . . . it changes this character to . . . ’

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Any idea what's going on here, with this character:

eml vs html, ’ vs ’

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Can I do something like this?

https://askleo.com/why_does_my_email_so ... _0d_in_it/

[from the comments] . . . I solved the problem of weird characters in email I receive in Outlook Express by unchecking the box labeled “Use default encoding for all incoming messages” in the International Settings section of the Fonts box on the Read tab under the Tools / Options menus. I proved it by toggling that setting off and on and off again. Don’t know if it works for anything other than Outlook Express.

TB / View / Text Encoding / Western

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Or, should I just save emails I need as .eml's, and not worry about not being able to view them in the future?

But, if it is an outdated, EOL format, why does TB default to saving emails as eml's?

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

sludge7071-g
 
Posts: 78
Joined: May 9th, 2016, 10:18 am

Post Posted February 10th, 2020, 9:17 am

Wait, I put this under Firefox - no way to delete

LIMPET235
Moderator

User avatar
 
Posts: 39001
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 10th, 2020, 9:34 am

Hi,
No probs.

Locking.
Continue here...> viewtopic.php?f=39&t=3059195
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
(Always choose the "Custom" Install.)

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 7 guests