MozillaZine

Login to 2020 census fails ...

User Help for Mozilla Firefox
sean97
 
Posts: 40
Joined: December 24th, 2007, 2:45 pm

Post Posted March 24th, 2020, 12:05 pm

Login to 2020 census fails ...

With FF 74.0 (64 bit) & Win 7 ...
when I go to my2020census.gov and click on "Start Questionnaire,"
it takes me to https://my2020census.gov/login .
When I enter my Census ID, and click "Login" it simply takes me back to the login page.
Never able to login.
Clicking "If you do not have a Census ID, click here." takes me back to the login page also.
Have tried IE 11 and the same thing happens.
Have talked to a census rep and she was able to login using my ID.
Best she could suggest was reboot my PC.

Grumpus

User avatar
 
Posts: 12346
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted March 24th, 2020, 12:53 pm

You can wait for the printed forms to come in the mail.
Or possibly try opening forms in Safe Mode.
I have my doubts it's set up properly because I've gotten 4 different mailings in the last week, two each day and for the same address.
Best guess the system has some bugs.

Just to clarify: Four mailings to suggest using the on line form. Four different keys provided. all same address.
Last edited by Grumpus on March 25th, 2020, 11:36 am, edited 1 time in total.
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

LewS
 
Posts: 155
Joined: January 28th, 2014, 2:18 pm

Post Posted March 24th, 2020, 1:03 pm

When I had this problem allowing cookies for the site fixed it.

malliz
Folder@Home

User avatar
 
Posts: 43964
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted March 24th, 2020, 3:06 pm

Usually caused by overzealous Anti Virus or Add blocker.
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

sean97
 
Posts: 40
Joined: December 24th, 2007, 2:45 pm

Post Posted March 24th, 2020, 6:09 pm

FF "Enhanced Tracking Protection" is set to Standard.
This PC does not have any Anti Virus or Add blocker.
It does have ZoneAlarm and FaceBook Container.
Tried with Add-ons Disabled. Still fails.

WaltS48

User avatar
 
Posts: 4194
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted March 25th, 2020, 6:45 am

sean97 wrote:FF "Enhanced Tracking Protection" is set to Standard.
This PC does not have any Anti Virus or Add blocker.
It does have ZoneAlarm and FaceBook Container.
Tried with Add-ons Disabled. Still fails.


Type about:profiles into the address bar.
Click the "Create a New Profile" button to open the "Create Profile Wizard" dialog window.
Click the "Next" button.
Give the profile a name.
Scroll down to the new profile.
Click the "Launch profile in new browser" button.

Try completing the census in that profile.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

therube

User avatar
 
Posts: 20266
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 25th, 2020, 8:02 am

In my case, pretty sure the login was case sensitive, so needed CAPS.
(At least it did not work in all lower case.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

sean97
 
Posts: 40
Joined: December 24th, 2007, 2:45 pm

Post Posted March 25th, 2020, 10:22 am

Created new profile per WaltS48 suggestion.
Login still fails in FF.
Note login also fails in IE 11 in exactly the same way.
Have tried entering ID in upper & lower case many times
and still fails.

therube

User avatar
 
Posts: 20266
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 25th, 2020, 10:24 am

Only other thing to note is to note things like O & 0.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

sean97
 
Posts: 40
Joined: December 24th, 2007, 2:45 pm

Post Posted March 25th, 2020, 10:51 am

My ID has letters and numbers, but no "O" or "0"
I read my ID to the census rep, and she was able to login with it.
So my ID seems to be valid.
Am beginning to think the census website itself has a problem.
Or maybe it is just overloaded.
Will try again over the next few days.

MarkRH

User avatar
 
Posts: 1291
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted March 25th, 2020, 2:16 pm

I logged into the Census site without issue. Ublock Origin and all the tracking options where checked. So, it *should* work.

TheVisitor
 
Posts: 5054
Joined: May 13th, 2012, 10:43 am

Post Posted March 25th, 2020, 2:19 pm

I suspect that something or setting in Zonealarm is blocking your access since IE and FF are both affected in the same way.

malliz
Folder@Home

User avatar
 
Posts: 43964
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted March 25th, 2020, 3:00 pm

TheVisitor wrote:I suspect that something or setting in Zonealarm is blocking your access since IE and FF are both affected in the same way.

Yep good old Zone Alarm strikes again
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

sean97
 
Posts: 40
Joined: December 24th, 2007, 2:45 pm

Post Posted March 25th, 2020, 6:03 pm

This is becoming increasingly weird.
I shut down ZA on the PC described in my original post, but login still fails.
I have a 2nd system WinXP & FF 52.9.0esr & an older ZA and login still fails.
No difference if ZA is running or shut down.
I have a 3rd system, Win7 (32 bit) FF 73.0.1 & no ZA and login fails on it.
Meanwhile, I'm able to login to various banks / utilities no problem.

malliz
Folder@Home

User avatar
 
Posts: 43964
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted March 25th, 2020, 7:41 pm

How are you connected to the internet?
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 13 guests