MozillaZine

Hide icons in bookmark bar and in new tabs

User Help for Mozilla Firefox
francik
 
Posts: 35
Joined: October 9th, 2006, 12:24 pm

Post Posted May 11th, 2020, 10:12 am

Hello,

I found several old threads for my questions but most of them don't seem to work anymore:

Is there currently a way to hide the default symbols for bookmarks and folders in the Firefox bookmark bar? So that Firefox doesn't show any icons (neither for links nor for folders) at all!

Furthermore, I deactivated the icons for tabs. When I open a new tab, this new tab has the Firefox logo as icon. Is there a way to deactivate this as well?

Thanks a lot!

Francik

jcostello
 
Posts: 9
Joined: February 21st, 2017, 11:54 am

Post Posted May 11th, 2020, 11:44 am

This works in my userChrome.css-file

.bookmark-item .toolbarbutton-icon, .bookmark-item[type="menu"]
.toolbarbutton-icon {display: none ! important; }

morat
 
Posts: 3843
Joined: February 3rd, 2009, 6:29 pm

Post Posted May 11th, 2020, 12:13 pm

Try this:

Code: Select all
/* Bookmarks Menu */

menu.bookmark-item > hbox > image.menu-iconic-icon,
menuitem.bookmark-item > hbox > image.menu-iconic-icon {
  display: none !important;
}

Code: Select all
/* Bookmarks Toolbar */

toolbarbutton.bookmark-item > image.toolbarbutton-icon {
  display: none !important;
}

Code: Select all
/* Tabs */

image.tab-icon-image {
  width: 0 !important;
  padding-right: 16px !important;
}

francik
 
Posts: 35
Joined: October 9th, 2006, 12:24 pm

Post Posted May 12th, 2020, 12:01 am

Unfortunately, both ways don't work. Links and folders in the bookmarks toolbar still have default symbols, a new tab still has the Firefox symbol.
I also set the following entries in about:config:
browser.chrome.image_icons.max_size = 0
browser.chrome.site_icons = false
browser.shell.shortcutFavicons = false

Does anybody have another hint or knows what to do?

morat
 
Posts: 3843
Joined: February 3rd, 2009, 6:29 pm

Post Posted May 12th, 2020, 7:13 am

Try setting the toolkit.legacyUserProfileCustomizations.stylesheets preference to true, then restart.

Firefox Changes Breaking userChrome.css
http://www.userchrome.org/firefox-changes-userchrome-css.html

The styles work here.

Firefox 76.0.1
Windows 7 SP1 32-bit

jscher2000

User avatar
 
Posts: 11009
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted May 12th, 2020, 9:12 am

francik wrote:Furthermore, I deactivated the icons for tabs.

How did you do that?

----

If you think TextEdit might be betraying you by inserting formatting into the file -- which will break it -- you can paste your rules into the following online editor and download the userChrome.css file from there:

https://www.userchrome.org/download-userchrome-css.html

francik
 
Posts: 35
Joined: October 9th, 2006, 12:24 pm

Post Posted May 12th, 2020, 1:21 pm

jscher2000 wrote:
francik wrote:Furthermore, I deactivated the icons for tabs.

How did you do that?


I guess it's a combination of the mentioned entries in about:config

francik
 
Posts: 35
Joined: October 9th, 2006, 12:24 pm

Post Posted May 12th, 2020, 1:23 pm

morat wrote:Try setting the toolkit.legacyUserProfileCustomizations.stylesheets preference to true, then restart.

Firefox Changes Breaking userChrome.css
http://www.userchrome.org/firefox-changes-userchrome-css.html

The styles work here.


Great, that helped! Thanks a lot!
There's just one weird thing: When I open a new tab, there's a blank space instead of the Firefox logo (before the text New Tab begins). Is there a way to avoid this blank space?

morat
 
Posts: 3843
Joined: February 3rd, 2009, 6:29 pm

Post Posted May 12th, 2020, 6:46 pm

francik wrote:Is there a way to avoid this blank space?

Try this:

Code: Select all
/* Tabs */

image.tab-icon-image {
  width: 0 !important;
}

francik
 
Posts: 35
Joined: October 9th, 2006, 12:24 pm

Post Posted May 12th, 2020, 11:45 pm

Perfect, thanks a lot! I simply removed the padding-right line, now it works fine!

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 14 guests