Fx won't set itself as my default browser

User Help for Mozilla Firefox
Posts: 643
Joined: March 10th, 2012, 8:08 pm

Post Posted May 17th, 2020, 4:12 pm

I've recently had to reinstall Win10 and Fx. Since then, whenever I restart Fx, it presents me with the dialog beginning:

Firefox is not currently set as your default browser. Would you like to make it your default browser?

I answer Yes each time, but to no avail: After the next restart, the dialog again appears, again demanding the answer I've already given. How can I stop this?


User avatar
Posts: 44074
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted May 17th, 2020, 4:23 pm

In windows - Start - Settings - Apps - Default Apps - Web Browser
Windows can sometimes be really stupid about this. You can try setting the default to IE/Edge and then back to Firefox. It sometimes fixes the problem another question is what does it keep resetting to?
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

Posts: 643
Joined: March 10th, 2012, 8:08 pm

Post Posted May 19th, 2020, 12:21 pm

Thanks, malliz. Going to my Windows settings, I saw that Windows had set Edge as my default browser, and after correcting that, the problem is gone.


User avatar
Posts: 11009
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted May 19th, 2020, 12:51 pm

With Windows 10, when you tell Firefox to make itself the default browser, it should open the Windows dialog for you. If that wasn't happening, that would explain the repetitive requests.

Return to Firefox Support

Who is online

Users browsing this forum: Bing [Bot] and 12 guests