MozillaZine

Unwanted search suggestions have returned

User Help for Mozilla Firefox
Odin2
 
Posts: 659
Joined: March 10th, 2012, 8:08 pm

Post Posted May 27th, 2020, 7:21 pm

In about:config I have browser.urlbar.maxRichResults set to 0 and browser.urlbar.oneOffSearches set to false; and in my search preferences I have "Provide search suggestions" unchecked--yet I'm getting suggestions every time I use the search bar. Is there any way to stop them? (I don't want to use private browsing.)

therube

User avatar
 
Posts: 20519
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 31st, 2020, 7:08 am

This was noted (in Builds), History bar dropdown is showing suggestions which I havent used in the last several years.

Not sure if that's the issue you're running into... ?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Odin2
 
Posts: 659
Joined: March 10th, 2012, 8:08 pm

Post Posted May 31st, 2020, 8:40 am

Thanks, therube. No, that's not my issue. My issue is about my use of the search bar, not the address bar.

jscher2000

User avatar
 
Posts: 11039
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted May 31st, 2020, 9:48 am

Dynamic search suggestions or history search suggestions? The latter have a little clock icon next to them.

* Dynamic (disable search suggestions): browser.search.suggest.enabled => false
* History (disable Search and Form History): browser.formfill.enable => false

Odin2
 
Posts: 659
Joined: March 10th, 2012, 8:08 pm

Post Posted May 31st, 2020, 9:58 am

Thanks, jscher. Changing the second preference to false seems to have done the trick.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 7 guests