MozillaZine

FF69 port: Extension icons missing from toolbar

User Help for Mozilla Firefox
Mr David

User avatar
 
Posts: 286
Joined: March 31st, 2004, 3:50 am
Location: RJLH--2.5 pints of beer in 11sec, University College, Oxford, 1955

Post Posted July 29th, 2020, 7:46 pm

I run a dual boot system - Ubuntu and Win10. Most of my time is spent in Ubuntu so my skills for transferring FF profile data into portable FF are a bit rusty.

Today I made new FF portable app "installations" on the Win10 system. I copied active profiles from the Ubuntu system and pasted them into the Win10 FF portable app folders.

After making the new portable app "installations" I opened each portable FF so it would populate folder structure with necessary FF files. Then I pasted contents of the active profile into the Data > Profile folder of each respective portable FF. Contents of each freshly populated Profile folder was over-written with data from transferred profile.

When testing the portable FF iterations they launched successfully, ran normally, all my settings were there. So far so good.

But.

Although all extensions installed to the profiles taken from the Ubuntu system were still installed in the copied portable profiles their icons were missing from the toolbar of each portable FF iteration. I tried right clicking on a vacant part of the toolbar > Customise but didn't see a way to get the icons back.

Suggestions on how to get icons for installed extensions to reappear on the toolbar would be appreciated.
I have learned from my mistakes and I am sure I can repeat them exactly.

Mr David

User avatar
 
Posts: 286
Joined: March 31st, 2004, 3:50 am
Location: RJLH--2.5 pints of beer in 11sec, University College, Oxford, 1955

Post Posted July 30th, 2020, 4:43 am

Elsewhere I was advised to disable and re-enable extensions. That was supposed to fix the paths in the relevant settings files.

Tonight I dived back into Win10 to apply the advice. After launching the FF portable iterations into which I'd transferred FF profiles from Ubuntu the extension icons were all lined up in their rightful places on the toolbar. It only needed a browser restart.

Easiest FF repair I've ever had to do.
I have learned from my mistakes and I am sure I can repeat them exactly.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 12 guests