MozillaZine

Firefox 81.0.2 (64-bit), Linux ignores my PDF settings

User Help for Mozilla Firefox
j4nd3r53n
 
Posts: 49
Joined: August 19th, 2003, 2:12 am

Post Posted October 24th, 2020, 10:01 am

When I open PDF files, I prefer to see them in okular, so I have set my firefox preferences to open them in okular. This has always worked, but now, suddenly, they always open in the browser, and I hate that. In fact, there seems to be nothing I can do to change it - when I try to change the setting to 'always ask', it still ignores it. ](*,)

What do I need to do to fix this? Choose another browser?

Tushman
 
Posts: 197
Joined: May 4th, 2005, 7:50 pm

Post Posted October 25th, 2020, 10:56 am

Sounds like to me your file association settings for PDF files has been hijacked by Firefox. I had the same exact problem happen to me with Windows and Firefox version 78.

viewtopic.php?f=7&t=3062753

In your case, you need to change the file association settings within the operating system rather than trying to tell Firefox how to handle it.

1) Locate a PDF file on your computer. Just pick one, it doesn't matter what it is.
2) In the file manager, right-click on the PDF file.
3) Click on the "Open With" tab.
4) Select Okular from the list.

If Okular is not listed, you need to click on the 'Add' button and point it to where it's been installed.

Here are some screenshots to help you.
https://www.howtogeek.com/117709/how-to ... tu-4-ways/

j4nd3r53n
 
Posts: 49
Joined: August 19th, 2003, 2:12 am

Post Posted October 26th, 2020, 3:35 am

Hi Tushman - thank you for taking the time to reply. Unfortunately, okular is already the default PDF handler in my system. I spent some more time searching for this, and I found the solution (excerpt from https://www.cyberciti.biz/faq/firefox-d ... df-viewer/):

1) Open about:config in the browser
2) Find pdfjs.disabled
3) Change its value to TRUE by double-clicking on it

I can't imagine it isn't an error in firefox, that it ignores the option you set in 'Settings', but this works for me.

Tushman
 
Posts: 197
Joined: May 4th, 2005, 7:50 pm

Post Posted October 26th, 2020, 9:59 am

I'm glad you were able to find the right solution.

On a side note, I think this is a total mistake for Mozilla to take this direction. I love using Firefox but for f*cks sakes, I do not understand why Firefox developers keep on insisting this is a good change. It is the year 2020 for crying out loud, I don't need Firefox to tell me how to handle my PDF files. Maybe that was a cool thing to do back in 2000, but not anymore!

Not only that, but it also causes unnecessary headaches for experienced users like yourself and I.

WaltS48

User avatar
 
Posts: 4516
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted October 26th, 2020, 3:22 pm

I think the Action in the Applications setting was changed from Preview to Open in FIrefox starting with version 81.0.

Firefox supports AcroForm, which will soon allow you to fill in, print, and save supported PDF forms and the PDF viewer also has a new fresh look.


REF: 81.0 Release Notes.

I still have the:
    Always Ask
    Save File
    Use system default application
    Use other
items to choose from in the drop down.

When I switched the preference to "Always ask", I was asked using Firefox 82.0 from Ubuntu.

I suppose safe mode or a test profile with the preference changed wasn't tested?
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

j4nd3r53n
 
Posts: 49
Joined: August 19th, 2003, 2:12 am

Post Posted October 27th, 2020, 12:55 am

Not only that, but it also causes unnecessary headaches for experienced users like yourself and I.


Yeah - I hate it when "helpful" gets in your way. To be fair, it isn't just Firefox; one of my first hates was the ubiquitous and mindless spellcheck that started creeping in everywhere, marking as "wrong" British English spelling and technical terms. *sigh*

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 11 guests