MozillaZine

How to disable FFx Video viewer -- REDUX

User Help for Mozilla Firefox
nohissyfit
 
Posts: 19
Joined: February 4th, 2020, 11:51 am

Post Posted November 10th, 2020, 11:11 am

I need to request help again { viewtopic.php?f=38&t=3067025 } as we are deaf and need Sub-Titles on movies.
My previous request only gave methods to prevent Auto-Start and it is apparent I need to remove or disable the HTML5 video viewer.

Last night Firefox grabbed the Amazon movie viewer AGAIN. I clicked on the "Sound" icon next to the Padlock in the address bar and got a message roughly like this.
This site uses DRM and Firefox may not be able to control very much.


Well, for something that might not be able to control much, taking over the display is pretty good. I need to DISABLE it.

My guess is most people probably do not notice it as the HTML5 video looks the same as Amazon's. That is, UNTIL you need to back-up to re-read a longish Sub-Title. Then there are no screen tools to scoot back 10-seconds.

Can someone PLEASE tell me how to disable that HTML5 viewer?

jscher2000

User avatar
 
Posts: 11095
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted November 10th, 2020, 1:32 pm

How would you play video without using the built-in player, which is based on HTML5 standards + Google Widevine for DRM? If you compare with another browser, what is the difference you're seeing -- others show more of the sub-title/caption?

nohissyfit
 
Posts: 19
Joined: February 4th, 2020, 11:51 am

Post Posted November 11th, 2020, 6:19 am

jscher2000 wrote:How would you play video without using the built-in player, which is based on HTML5 standards + Google Widevine for DRM? If you compare with another browser, what is the difference you're seeing -- others show more of the sub-title/caption?


Did you read the explanation of the problem in the earlier post?

This problem began after updating from 68-esr to 74-esr.

I am not an expert on HTML so assumed that Amazon has their own video player.
I also assumed that ffx has it's own HTML5 video player.

When watching a movie on Amazon we get the Amazon player that has on-screen options for 10+ and 10- seconds as well as Sub-Title selection, color size and style.

When watching with our very slow DSL (AT&T Country-DSL, supposed to be 6M, but mostly around 2-3) the Amazon black-screen + spinner starts to buffer and normally returns to the Amazon player. This is buffering "normal" for here and happens about every 15 to 20 minutes.

But, sometimes if the buffering is taking a longer time, around 15+seconds when the video continues it is in the NON-Amazon player. This is useless to us as there are no Sub-Titles and even if there were, not obvious way to scoot back a few seconds.

Whatever ffx is doing I need to disable it so the only option is for to return to the Amazon-player after the buffering and NOT force it's way in.

I do not have nor want to install another browser. The Amazon list is very short for approved browsers in Linux and if not on the list, the videos will NOT run.

We have an option of ONE ISP other than Hughes Satellite which costs $100/month and that ain't happening.

So, back to the original question, how do I disable the ffx player or whatever it is that ffx is doing?

WaltS48

User avatar
 
Posts: 4526
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted November 11th, 2020, 8:58 am

Do you have “Block Audio and Video” set in the “Autoplay” settings?

Do you have a script blocking extension installed?

Have you tried the Strict or Custom tracking protection settings?

Sorry, but I don't do Amazon. I'll presume my test with trailers opened in the Firefox viewer even with it set to block audio and video. Perhaps I need to restart Firefox to update the change I made from just blocking audio. Audio wasn't blocked either.

Maybe this site will help? Control audio or video playback with your keyboard.

Sometimes you just have to live with some things you can't control.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

nohissyfit
 
Posts: 19
Joined: February 4th, 2020, 11:51 am

Post Posted November 11th, 2020, 3:16 pm

WaltS48 wrote:Do you have “Block Audio and Video” set in the “Autoplay” settings?
Sometimes you just have to live with some things you can't control.


:) Next time you watch a Movie, try sticking your fingers in your ears for the entire thing, let me know how you enjoyed it. ;).

Yes to the above questions.

Good to hear that you too had problems with the "Block audio and video" not working too, was beginning to wonder if it was just me. Sometimes it shows the Icon next to the Address-bar padlock and sometimes it does not for the same webpages. Badly broken by the looks of it.

I will install an older backup that has 68-esr. I don't recall that take-over of the video happening back then.

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 21 guests