MozillaZine


How to really disable expanding URL Bar in newest FF?

User Help for Mozilla Firefox
thoste
 
Posts: 181
Joined: June 7th, 2003, 12:45 am

Post Posted February 12th, 2021, 5:27 am

As a lot of other people I am annoyed about the newly introduced expanding URL bar.

I wanted to disable this "feature" and read some suggestions like settings

browser.urlbar.openViewOnFocus=false

or

browser.urlbar.update1=false
browser.urlbar.update1.interventions=false
browser.urlbar.update1.searchTips=false

But these recommendations do not work (at least) in the newest FF version v85.02. (64 bit) on Windows.

How do I really, really get rid of this mess?
Last edited by thoste on February 12th, 2021, 9:32 pm, edited 1 time in total.

dickvl

User avatar
 
Posts: 53276
Joined: July 18th, 2005, 3:25 am

Post Posted February 12th, 2021, 8:36 am

You can create a new Number pref named ui.prefersReducedMotion on the about:config page to show (0) or block (1) some animations.
about:config => ui.prefersReducedMotion = 1

This includes the location bar breakout in Firefox 78 and later.
This replaces the tab loading indicator with an hourglass in Firefox 80 and later

See also:
https://developer.mozilla.org/en-US/doc ... ced-motion

If you want to hide the drop down completely then you can set browser.urlbar.maxRichResults = 0 on about:config.
https://support.mozilla.org/en-US/kb/ab ... or-firefox

Ashleyj

User avatar
 
Posts: 144
Joined: September 9th, 2004, 12:10 pm

Post Posted February 12th, 2021, 10:18 am

I think you will find there are now the following entries that need to be set to false -

browser.urlbar.update2 = false
browser.urlbar.update2.disableOneOffsHorizontalKeyNavigation = false
browser.urlbar.update2.oneOffsRefresh = false
browser.urlbar.update2.restyleBrowsingHistoryAsSearch = false

and

browser.urlbar.update2.emptySearchBehavior = 0

I was having the same problem but setting the above and browser.urlbar.openViewOnFocus = false fixed the issue.
I am on 85.0.2 by the way.

jscher2000

User avatar
 
Posts: 11154
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted February 12th, 2021, 11:00 am

thoste wrote:browser.urlbar.update1=false

That preference was removed in Firefox 77.

Current options: https://www.userchrome.org/megabar-styling-firefox-address-bar.html#enlargement

thoste
 
Posts: 181
Joined: June 7th, 2003, 12:45 am

Post Posted February 12th, 2021, 9:39 pm

ui.prefersReducedMotion trick works
Thank you

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 6 guests