Unable to use extension shortcuts when textbox focused.[Mac]

User Help for Mozilla Firefox
New Member
Posts: 1
Joined: July 18th, 2021, 3:11 pm

Post Posted July 18th, 2021, 3:39 pm

Hi, I just switched to FF from Chrome and I noticed some weird behaviors for shortcuts. For example, I have shift + alt + e binds to an extension shortcut. It works fine. But when I'm focused on a textbox (e.g., when typing this post). The shortcut doesn't work, it types a literal back-tick "ยด" instead. This behavior is not seen in Chrome or any other browsers I used before.

I'm wondering how can I get my shortcuts to work while typing?

Thanks in advance!
Last edited by LIMPET235 on July 19th, 2021, 5:48 am, edited 1 time in total.
Reason: Added [Mac] to the Title.

Posts: 4697
Joined: February 3rd, 2009, 6:29 pm

Post Posted July 18th, 2021, 4:35 pm

What's the addon name with the issue?

Firefox addons

Try using the Command+Alt+E shortcut.

Firefox shortcuts ... ks-quickly

I had a problem with uBlock Origin and the Shift+Alt+E shortcut opening the uBO dashboard. The shortcut opens the menu bar "Edit" menu popup instead.

Test page

I can workaround the issue by setting the ui.key.menuAccessKey pref to 0 in about:config to disable the menu access shortcuts. Remember to restart.


User avatar
Posts: 11396
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted July 18th, 2021, 5:39 pm

Hmm, it's different on Windows. This is more a note to myself and doesn't solve your issue.

For us, Shift+Alt+E opens the following link because Shift+Alt is the way we trigger access keys (on Mac, you use Ctrl+Alt for that):

Code: Select all
<a href="./ucp.php" title="User Control Panel" accesskey="e" class="icon-ucp">User Control Panel</a>

So I don't know what Shift+Alt does on Mac. ??

Return to Firefox Support

Who is online

Users browsing this forum: Bing [Bot] and 7 guests