MozillaZine


(Resolved) F 90 Tooltips Not displaying

User Help for Mozilla Firefox
kukla
 
Posts: 908
Joined: December 30th, 2008, 3:59 pm

Post Posted August 3rd, 2021, 8:39 am

But do display in Safe Mode. Have gone through each of my extensions and disabled them one by one, but tooltips still don't display.

Seeing this when I hover over entry in Safe Mode, from calls and messages at Verizon.

https://i.postimg.cc/hjsvjKZ9/VZ-tooltip.png

This tooltip does display in the 78.12 with the exact same extensions. Have disabled Hardware Acceleration and am using the same theme in the 90 as in the 78.12

No idea what else to try.
Last edited by kukla on August 3rd, 2021, 8:49 am, edited 1 time in total.

morat
 
Posts: 4755
Joined: February 3rd, 2009, 6:29 pm

Post Posted August 3rd, 2021, 8:49 am

Maybe your userChrome.css and userContent.css files are causing the issue.

More info on Safe Mode
http://support.mozilla.org/kb/diagnose- ... nced-users

Safe Mode disables userChrome.js hacks as well.

More info on userChrome.js hacks: viewtopic.php?p=14854175#p14854175
Last edited by morat on August 3rd, 2021, 8:56 am, edited 1 time in total.

kukla
 
Posts: 908
Joined: December 30th, 2008, 3:59 pm

Post Posted August 3rd, 2021, 8:51 am

morat wrote:Maybe your userChrome.css and userContent.css files are causing the issue.

About Safe Mode
http://support.mozilla.org/kb/diagnose- ... nced-users


Lots of customizations present in the 90 but not in the 78.12. Will temporarily remove the entire Chrome folder and test.

kukla
 
Posts: 908
Joined: December 30th, 2008, 3:59 pm

Post Posted August 3rd, 2021, 8:57 am

EDIT: Yep, shows with Chrome folder removed. That's going to be the devil to track down. Besides a putting a reasonably uncomplicated CSS in the userChrome.css, to bring the tabs bar back below, and anticipating the removal of the ability to disable Proton in the upcoming 91, copied over a bunch of stuff that works with Proton fully enabled, but which I don't really understand. Trial and error would probably take me weeks.

morat
 
Posts: 4755
Joined: February 3rd, 2009, 6:29 pm

Post Posted August 3rd, 2021, 9:16 am

Try using @-moz-document to further restrict the scope.

Code: Select all
/* Firefox userChrome.css */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
@namespace html url("http://www.w3.org/1999/xhtml");

@-moz-document url-prefix("chrome://browser/content/browser.xhtml") {
  ...
}

Code: Select all
/* Firefox userContent.css */

@-moz-document url-prefix("about:addons") {
  ...
}

CSS customizations leak to dialogs and websites
http://forums.mozillazine.org/viewtopic.php?f=38&t=3077528

kukla
 
Posts: 908
Joined: December 30th, 2008, 3:59 pm

Post Posted August 3rd, 2021, 10:53 am

In fact, staring me right in the face, was

Code: Select all
/*** Remove all tooltips ***/
tooltip {
  display: none !important;
}


I have absolutely no idea why I put that in, or where I got that from, but after removing it - no-brainer - tooltips started displaying in the 90. Took less than a minute, not weeks.

And thanks very much morat for the idea to look in the userChrome.css. Without that, I never would have tried looking there, and been struggling with this forever.

kukla
 
Posts: 908
Joined: December 30th, 2008, 3:59 pm

Post Posted August 3rd, 2021, 11:26 am

Discovered why I was using that tooltips css: that was to remove the tooltip on the tab close button. Wondering what the CSS would be to just disable that particular item without disabling all tooltips?

https://i.postimg.cc/bJR4KQQp/Screen-Sh ... -16-PM.png

kukla
 
Posts: 908
Joined: December 30th, 2008, 3:59 pm

Post Posted August 3rd, 2021, 2:14 pm

Solved:

about:config -> browser.chrome.toolbar_tips -> set to false

Only appears to affect the annoying and unnecessary tab close button, not the tooltip on hover as shown in my first post.

Found here, from 2013

https://www.ghacks.net/2013/10/09/disab ... s-firefox/

DanRaisch
Moderator

User avatar
 
Posts: 125281
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 3rd, 2021, 4:50 pm

Thread marked "Resolved" per OP's post.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 3 guests