MozillaZine


PR_CONNECT_RESET_ERROR

User Help for Mozilla Firefox
MojoMan713
 
Posts: 52
Joined: December 15th, 2005, 10:34 am

Post Posted May 24th, 2022, 8:00 am

I am getting the following error on YouTube and a lot of other less popular websites, but most of the big ones are working fine:

Secure Connection Failed

An error occurred during a connection to www.youtube.com. PR_CONNECT_RESET_ERROR

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

Learn more…


I evaluated the issues on the Learn More page, and researched help articles on this problem on a number of websites, trying to implement their recommended solutions as well. It still is not working.

Can you guys please help?

jscher2000

User avatar
 
Posts: 11639
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted May 24th, 2022, 11:00 am

This code occurs when the web server, or a proxy server upstream of your computer, or a filter on your router, or a software-based filter on your computer -- such as security software or parental control software -- cancels a request.

If you are on a managed system or network whether you're not supposed to go to YouTube, that could explain it. Otherwise, try setting Firefox to "No Proxy" (on the Settings page, type proxy in the tiny search box to focus that button/dialog).

redwolfe_98
 
Posts: 327
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted May 24th, 2022, 1:28 pm

if you use a third-party antivirus program, that can cause the problem. so, you could try uninstalling it.

if you use a VPN, that can cause the problem. you could try uninstalling it.

one person said that a browser-extension that they were using caused the problem. for testing, you could try running firefox in "safe mode" where no browser extensions are loaded.

you could try disabling firefox's "enhanced tracking protection" to see if it is causing a problem.

do a google-search for "firefox PR_CONNECT_RESET_ERROR" and look at some of the articles that come up:

https://www.google.com/search?q=firefox ... ESET_ERROR
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

MojoMan713
 
Posts: 52
Joined: December 15th, 2005, 10:34 am

Post Posted May 24th, 2022, 2:02 pm

jscher2000 wrote:This code occurs when the web server, or a proxy server upstream of your computer, or a filter on your router, or a software-based filter on your computer -- such as security software or parental control software -- cancels a request.

If you are on a managed system or network whether you're not supposed to go to YouTube, that could explain it. Otherwise, try setting Firefox to "No Proxy" (on the Settings page, type proxy in the tiny search box to focus that button/dialog).


Thanks for the proxy suggestion. I tried it, but it did not work.

Just FYI, I am on a managed network. However, I can access YouTube using the MIcrosoft Edge browser on this network, just not with Firefox. It seems to me that if I can access the site with one browser, I should be able to access it with the other also.

MojoMan713
 
Posts: 52
Joined: December 15th, 2005, 10:34 am

Post Posted May 24th, 2022, 2:13 pm

redwolfe_98 wrote:if you use a third-party antivirus program, that can cause the problem. so, you could try uninstalling it.

if you use a VPN, that can cause the problem. you could try uninstalling it.

one person said that a browser-extension that they were using caused the problem. for testing, you could try running firefox in "safe mode" where no browser extensions are loaded.

you could try disabling firefox's "enhanced tracking protection" to see if it is causing a problem.

do a google-search for "firefox PR_CONNECT_RESET_ERROR" and look at some of the articles that come up:

https://www.google.com/search?q=firefox ... ESET_ERROR


Thanks. I did try it in safe mode, and I also "refreshed" the browser. Neither worked.

I am not using a VPN and the antivirus is managed across the network. As I stated above, YouTube and these other sites are accessible using the Microsoft Edge browser on the same computer, so it does not appear to be a network related blockage.

I did the google search and that is where I found the previous recommendations, several of which you suggested in your post quoted above. I do not see how to disable the "enhanced tracking protection". There are different levels of protection in the settings, but I do not see an off or disable option.

redwolfe_98
 
Posts: 327
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted May 24th, 2022, 6:09 pm

MojoMan713 wrote:I do not see how to disable the "enhanced tracking protection"

use the option for "custom" settings, there, and untick everything except for "cookies." see the image, below.

have "cookies" set to block all third-party cookies.

that is the way that i have the settings for "enhanced tracking protection" set, with everything disabled except for the blocking of third-party cookies.

i use the "ublock origin" browser-extension and i figure that it blocks everything that needs to be blocked, that i don't need firefox's "enhanced tracking protection" in addition to "ublock origin."

Image
Last edited by redwolfe_98 on May 25th, 2022, 1:20 am, edited 1 time in total.
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

xanthon

User avatar
 
Posts: 320
Joined: December 17th, 2005, 11:55 pm

Post Posted May 24th, 2022, 11:38 pm

To disabled Enhanced Tracking Protection on the site, click on the shield icon at the far left of the address bar (on that site) and switch it off.

redwolfe_98
 
Posts: 327
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted May 25th, 2022, 2:54 am

xanthon made a good point, you can disable "tracking protection" for individual websites. as he said, click the shield-icon, at the front of the address bar, and adjust the settings, there.
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

MojoMan713
 
Posts: 52
Joined: December 15th, 2005, 10:34 am

Post Posted May 25th, 2022, 7:35 am

redwolfe_98 wrote:
MojoMan713 wrote:I do not see how to disable the "enhanced tracking protection"

use the option for "custom" settings, there, and untick everything except for "cookies." see the image, below.

have "cookies" set to block all third-party cookies.

that is the way that i have the settings for "enhanced tracking protection" set, with everything disabled except for the blocking of third-party cookies.

i use the "ublock origin" browser-extension and i figure that it blocks everything that needs to be blocked, that i don't need firefox's "enhanced tracking protection" in addition to "ublock origin."

Image


That is good advise. I also use ublock origin. I have set the enhanced tracking protection as you have suggested.

However, this website and quite a few others are still being recognized as not secure, despite having an https prefix to the url.

MojoMan713
 
Posts: 52
Joined: December 15th, 2005, 10:34 am

Post Posted May 25th, 2022, 8:04 am

xanthon wrote:To disabled Enhanced Tracking Protection on the site, click on the shield icon at the far left of the address bar (on that site) and switch it off.


The shield is not available on these blocked websites in Firefox. I would insert screencap showing you what I am seeing, but based on the options above, I do not see a way to insert an image into this post.

MojoMan713
 
Posts: 52
Joined: December 15th, 2005, 10:34 am

Post Posted May 25th, 2022, 8:16 am

I am even getting this error on the following website (PBS.org):

https://www.pbs.org/

redwolfe_98
 
Posts: 327
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted May 25th, 2022, 11:01 am

one other thing that you could try would be to disable "DNS over HTTPS."

to do that, go to firefox's "settings" and, on the "general" tab, go to "network settings." the setting for "enable DNS over HTTPS" is there, at the bottom of the page.

with "enable DNS over HTTPS" disabled, your computer will use its "normal," default DNS servers. however you can configure your computer to use whichever DNS servers you want to use. i use "openDNS" DNS servers.
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

MojoMan713
 
Posts: 52
Joined: December 15th, 2005, 10:34 am

Post Posted May 25th, 2022, 11:37 am

redwolfe_98 wrote:one other thing that you could try would be to disable "DNS over HTTPS."

to do that, go to firefox's "settings" and, on the "general" tab, go to "network settings." the setting for "enable DNS over HTTPS" is there, at the bottom of the page.

with "enable DNS over HTTPS" disabled, your computer will use its "normal," default DNS servers. however you can configure your computer to use whichever DNS servers you want to use. i use "openDNS" DNS servers.


Thanks. I did it. Still, no dice.

redwolfe_98
 
Posts: 327
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted May 25th, 2022, 2:29 pm

for testing, use firefox's "profile manager" to create a new, clean firefox profile and see if it works properly.

to run firefox's profile manager, right-click on "start" and click "run" and, in the "run" dialog-box, type "firefox.exe -p" (minus quotations) and then click "OK." then follow the prompts to create a new, clean firefox profile.

you can use firefox's "profile manager" to switch back and forth between profiles, or to delete a profile.
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

redwolfe_98
 
Posts: 327
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted May 26th, 2022, 6:51 pm

redwolfe_98 wrote:for testing, use firefox's "profile manager" to create a new, clean firefox profile and see if it works properly.

to run firefox's profile manager, right-click on "start" and click "run" and, in the "run" dialog-box, type "firefox.exe -p" (minus quotations) and then click "OK." then follow the prompts to create a new, clean firefox profile.

you can use firefox's "profile manager" to switch back and forth between profiles, or to delete a profile.

it wouldn't hurt to try it. it is easy enough to delete the new firefox profile, if desired.

since you said that you weren't having any similar issues with the edge-chromium browser, i would think that you likewise shouldn't have any problems with firefox, unless it is being caused by the "enhanced tracking protection," or by a tweak that has been applied, like maybe by importing a "prefs.js" file?
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 3 guests