MozillaZine

How to disable search from location bar?

User Help for Mozilla Firefox
pagan
 
Posts: 5
Joined: October 27th, 2003, 9:32 pm

Post Posted October 27th, 2003, 10:20 pm

I looked through user.js but only found how to stop "i'm feeling lucky", not how to stop searching from location box altogether.

A truly unfortunate conincidence is using FB as a web app development tool, forgetting to start the local web server, then getting redirected based on http://localhost to a very slimy outfit at localhost.net.au.

formnull
 
Posts: 125
Joined: May 7th, 2003, 9:34 pm

Post Posted October 27th, 2003, 10:31 pm

pagan wrote:I looked through user.js but only found how to stop "i'm feeling lucky", not how to stop searching from location box altogether.

A truly unfortunate conincidence is using FB as a web app development tool, forgetting to start the local web server, then getting redirected based on http://localhost to a very slimy outfit at localhost.net.au.


I agree, that is so obnoxious! I just turned it off the other day, it's called "keyword.enabled".

Type "about:config" in your URL bar, filter for "keyword", set keyword.enabled to false.
Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted October 27th, 2003, 10:55 pm

You could make sure that your computer knows that localhost is 127.0.0.1
You could go into about:config and just remove the URLbar search URL completely. I don't know what it would do, but probably not go anywhere.
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

pagan
 
Posts: 5
Joined: October 27th, 2003, 9:32 pm

Post Posted October 28th, 2003, 5:13 pm

formnull wrote:
pagan wrote:I looked through user.js but only found how to stop "i'm feeling lucky", not how to stop searching from location box altogether.

A truly unfortunate conincidence is using FB as a web app development tool, forgetting to start the local web server, then getting redirected based on http://localhost to a very slimy outfit at localhost.net.au.


I agree, that is so obnoxious! I just turned it off the other day, it's called "keyword.enabled".

Type "about:config" in your URL bar, filter for "keyword", set keyword.enabled to false.


Thanks. That worked perfectly. It correctly responds with an alert saying "the connection was refused". Simply changing the keyword.URL does stop the "i'm feeling lucky" but doesn't give the alert message.

I don't know where the about:config feature is mentioned anywhere in Tools > Options or any other menu item.

Roger

Guest
Guest
 

Post Posted October 28th, 2003, 5:41 pm

pagan wrote:
formnull wrote:
pagan wrote:I looked through user.js but only found how to stop "i'm feeling lucky", not how to stop searching from location box altogether.

A truly unfortunate conincidence is using FB as a web app development tool, forgetting to start the local web server, then getting redirected based on http://localhost to a very slimy outfit at localhost.net.au.


I agree, that is so obnoxious! I just turned it off the other day, it's called "keyword.enabled".

Type "about:config" in your URL bar, filter for "keyword", set keyword.enabled to false.


Thanks. That worked perfectly. It correctly responds with an alert saying "the connection was refused". Simply changing the keyword.URL does stop the "i'm feeling lucky" but doesn't give the alert message.

I don't know where the about:config feature is mentioned anywhere in Tools > Options or any other menu item.

Roger


Glad it worked for you.

about:config is an advanced feature, like editing the user.js
It's not really intended for end-users, which is why it isn't documented in the end-user docs.. :)

The idea is to expose as many of these options as is reasonable through the Options menu.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 14 guests