MozillaZine

gtk2 problem with Linux builds since 0.7

User Help for Mozilla Firefox
kc2kth
 
Posts: 14
Joined: June 22nd, 2003, 9:34 pm

Post Posted December 4th, 2003, 11:07 pm

So far any post-0.7 build I've tried (gtk2/xft) has failed to start with this message:

jlemay@gambit:~/MozillaFirebird> ./MozillaFirebird

(Gecko:8144): Gtk-WARNING **: Unable to locate theme engine in module_path: "mist",

I found a reference to a similar problem with Bluefish on Google that indicated a more recent gtk2 version was needed. I've updated to 2.2.4 - the latest available for my platform - and I am still getting the error.

Any ideas?

thanks!

kc2kth
 
Posts: 14
Joined: June 22nd, 2003, 9:34 pm

Post Posted December 10th, 2003, 10:56 pm

Newer releases seem to have one other issue now. This may be a local config issue looking at it, but I need the advice of a pro! Here's the message I'm getting with 12-03's build:

jlemay@gambit:~/MozillaFirebird-1203> ./MozillaFirebird

(Gecko:23442): Gtk-WARNING **: Unable to locate theme engine in module_path: "mist",
/home/jlemay/MozillaFirebird-1203/run-mozilla.sh: line 454: 23442 Segmentation fault "$prog" ${1+"$@"}

I'm guessing the "real" issue maybe in that segfault message.

kc2kth
 
Posts: 14
Joined: June 22nd, 2003, 9:34 pm

Post Posted December 10th, 2003, 11:00 pm

Resolved - should have tried an *even newer* build before I reposted. Using 10-Dec's nightly and it's running now.

Guest
Guest
 

Post Posted July 18th, 2004, 7:58 am

Resolved - create a symbolic link to wher your theme engine is located from /usr/lib/gtk-2.0 to the actual location. My location was /usr/local/lib/gtk-2.0, but firefox expects it in /usr/lib/gtk-2.0.

Guest
Guest
 

Post Posted July 19th, 2004, 6:06 pm

how do you find the location?
i actually get

mozilla
/usr/lib/mozilla-1.7/run-mozilla.sh: line 451: 19668 Segmentation fault "$prog" ${1+"$@"}

Return to Firefox Support


Who is online

Users browsing this forum: skuddle and 7 guests