MozillaZine

can't download EXE files with firefox

User Help for Mozilla Firefox
sean068
Guest
 

Post Posted April 1st, 2006, 12:09 am

I clicked on an ed2k:\\ link in Firefox and was then prompted that an external app needs to be opened to handle the link, so I clicked OK and emule loaded and the download was added to it. Now when I try to download an EXE file with Firefox I get the following error messages:

file.exe.part could not be saved, because the source file could not be read

and

file.exe.part could not be saved, because an unknown error occurred

Also, now windows explorer wants to act as a server and access the internet. the port it's using to try to connect is 6346 which is gnutella related. I had limewire (don't know if that did something) which I've uninstalled completely and uninstalled Java completely. It seems like windows explorer is acting like a gnutella client.

I've uninstalled and reinstalled both Firefox and Emule, cleared all temp, internet cache files, etc. and scanned for adware, trojans and virus and found nothing.
I can download EXEs no problem with IE but not with Firefox. I can download other file types with Firefox but not EXEs.

How can I restore dowloads of EXEs with Firefox?

I'm using Windows XP SP2 Home Edition and Firefox 1.5.0.1

Guest
Guest
 

Post Posted April 1st, 2006, 12:14 pm

Try uninstalling and reinstalling firefox.

Maybe also read about profile folder in the knowledge base: you could try deleting it after saving a backup of the things you want (like bookmarks).

sereptis
 
Posts: 16
Joined: December 26th, 2005, 10:28 pm

Post Posted April 1st, 2006, 12:18 pm

Try going into Options/Downloads/View & Edit Actions and see if .exe is in there. I used to have a problem where I couldn't direct download .avi's and it was because VLC had hijacked it.

dickvl

User avatar
 
Posts: 51514
Joined: July 18th, 2005, 3:25 am

Post Posted April 1st, 2006, 4:16 pm


Guest
Guest
 

Post Posted April 1st, 2006, 8:35 pm

Hi,
I've tried uninstalling Firefox and deleting the Mozilla folders from \Application Data and Local Settings\Application Data then reinstalled and that hasn't helped.

I've also tried using the mimeTypes extension to add exe extension with mimetype application/x-msdownload and that hasn't helped.

I checked Options/Downloads/View & Edit Actions and .exe is not there. Should it be?

Guest
Guest
 

Post Posted April 1st, 2006, 10:00 pm

I don't think exeshould be in download actions ...

You may want to try editing the registry. If you don't have limewire installed, I would ty finding all keys that are associated with it, and deleting them. You could back up the registry before trying that.

Do you have any other p2p program installed (which ones)? I know one p2p program (shareaza) has an optional browser thing that allows certain mime types to be downloaded by that program (its selectable in Shareaza's web settings, and off by default). I don't really know if it works in mozilla though.
There are also many similar programs (download managers), like 'getright'. Maybe you installed one?

Have you tried running firefox in safe mode (choose safe mode from firefox's start menu entry)?

sean068
Guest
 

Post Posted April 2nd, 2006, 12:31 am

I've gotten rid of Limewire and all traces of it. I've read about the shareaza BHO http://www.file.net/process/razawebhook.dll.html and figure it may be something similar. I've never had shareaza so I know that's not the problem.
The only p2p program I have is emule. This problem began when I clicked an ed2k:\\ link within Firefox and firefox sent it to emule which is what's supposed to happen. Now when I click ANY link that ends in exe, I get the error messages. Somehow firefox has confused .exe with the edonkey/emule .part file type. I know I may have to edit the registry, but I don't know what I'm looking for. I know it may be some BHO related problem because I got a "changed program" alert from ZoneAlarm for both firefox and IE. I've also installed Mozilla 1.7.12 and the problem happens with it too. It doesn't happen with IE and not with Netscape (an older version - 4.04)
I have the Free Download Manager, but I installed that recently, way after the problem began.

dickvl

User avatar
 
Posts: 51514
Joined: July 18th, 2005, 3:25 am

Post Posted April 2nd, 2006, 7:10 am

You can search the registry for ed2k (or emule or the foldername of the appl.) and check the .exe or exefile entry in HKEY_CLASSES_ROOT.

sean068
Guest
 

Post Posted April 10th, 2006, 10:10 pm

I restored from an image file I made before I clicked the ed2k link and found the problem was a windows update that was installed.
It's one (or both) of the follwing:

Update for Windows XP (KB898461)
This update installs a permanent copy of Package Installer for Windows to enable software updates to have a significantly smaller download size. The Package Installer facilitates the install of software updates for Microsoft Windows operating systems and other Microsoft products. After you install this update, you may have to restart your system.

Update for Windows XP (KB910437)
Install this update to prevent or resolve an issue in which Windows Update and Automatic Updates can no longer download updates after an Access Violation error occurs when using the Automatic Updates
service. After you install this item, you may have to restart your computer.

It may be another one of the updates (there were 16) since uninstalling these 2 affects some of the others. I'm surprised no one else has this problem. My solution is to leave the updates on my system and just use Free Download Manager or IE to download exe files. Maybe Mozilla will find and fix this issue in a future release. The .part file extension is actually a Firefox incomplete download file extension.

sean068
Guest
 

Post Posted May 22nd, 2006, 8:45 pm

Just to update this for anyone who may be reading this and has a similar problem. It turns out that the problem was not a Windows update but the Win32.polipos virus. I used Dr. Web's CureIt: http://download.drweb.com/drweb+antivir ... +services/
and that has fixed the problems. My Firefox is back to normal and I can download files again and Windows Explorer no longer tries to access the internet.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 12 guests