MozillaZine

Odd redirection from Google

User Help for Mozilla Firefox
Wavy
Guest
 

Post Posted December 23rd, 2003, 1:38 pm

I did a Google search from a multi-engine search page on my local network. The local HTTP domain name is simply SOCNET (resolved through HOSTS file). Instead of getting the expected Google search results, I was redirected to:

http://www.socnetcentral.com/vb/

I tried again and again to repeat this, but kept getting the expected Google page. Then, about an hour later, it happened again. Looking through my firewall logs, I see that both redirections were through one Google server, but I can't repeat it by using that server's IP address in place of 'groups.google.com'.

It's hard to accept that being redirected to socnetcentral.com has nothing to do with http://socnet being the HTTP_REFERER, but I'm at a loss as to why it would happen. It has never happened when using MSIE. Any ideas?

Wavy

R4F

User avatar
 
Posts: 999
Joined: December 7th, 2003, 12:13 pm
Location: Netherlands

Post Posted December 23rd, 2003, 2:47 pm

I assume Google is doing an 'I'm feeling lucky' search and takes you to the first page in the results. That's the default behaviour. You can click Help site link in my sig to learn how to turn it off.
[size=9:0df8c2550c]Firefox Help | Nederlands
Thunderbird Help | Nederlands[/size:0df8c2550c]

laszlo

User avatar
 
Posts: 5198
Joined: November 4th, 2002, 6:13 pm
Location: .de

Post Posted December 23rd, 2003, 3:17 pm

This feature jumps in if you enter something into the location bar that doesn't resolve or that does resolve but can't be connected (which seems to be the case with your problem). Latter is questionable and is discussed here for example:

http://bugzilla.mozilla.org/show_bug.cgi?id=184433
"I'll be dead after I die. I was dead before I was born. Life is a break from death." - Hlynur, 101 Reykjavík

Wavy
Guest
 

Post Posted December 23rd, 2003, 4:10 pm

Thanks for the suggestions, but I'm not seeing how they apply. Maybe I wasn't clear about what's happening... The local search page takes the query from a form, URL-encodes it, then redirects to groups.google.com/groups, with query appended. In this particular case, the entire URL redirected to is
http://groups.google.com/groups?q=%22port+7323%22
This should give me the google results page for newsgroup messages (not web pages) containing the phrase "port 7323", and it usually does. But the first search, and just one of many subsequent searches using the exact same process and query each time (trying to get it to happen again), I was rediredirected to a web page without ever seeing the Google results page. My firewall logs show a hit on Google followed immediately by the hit on the socnetcentral.com message forum.

Of course, just because this has never happened before and I just started using Firebird for searches doesn't mean Firebird is responsible. Just wondering if it might be.

laszlo

User avatar
 
Posts: 5198
Joined: November 4th, 2002, 6:13 pm
Location: .de

Post Posted December 23rd, 2003, 4:24 pm

To clear this up: Firebird uses the "I'm feeling lucky" search on Google. If you enter "socnet" it takes you to "www.socnetcentral.com/vb/" when socnet doesn't resolve and/or can't be connected. If I enter "socnet", it does the same.

If you don't want to see it again, open "about:config" and set "keyword.enabled" to false.

Guest
Guest
 

Post Posted December 23rd, 2003, 5:41 pm

Ah, now I get it. It is my local socnet page that is timing out and causing Mozilla to inquire of Google. My query never gets processed. THANKS lazlo!

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 11 guests