MozillaZine

iFrame doesn't display

User Help for Mozilla Firefox
v4
Guest
 

Post Posted December 26th, 2003, 10:32 pm

I cannot view the content of any iFrames on my website using Firebird 0.7 because I have the height of the iFrame set to 100%. If I set the height to an actual number rather than a percentage, it works fine. How can I fix this so I can see the content in my iFrame? Site = http://www.v4images.com

v4
Guest
 

Post Posted December 28th, 2003, 12:07 pm

Is there no way? Am I just going to have to start viewing it with IE???

Pike

User avatar
 
Posts: 2293
Joined: August 10th, 2003, 12:12 pm
Location: UK

Post Posted December 28th, 2003, 5:17 pm

Give the body and html elements a height as well would be my guess, but I can't find any pages on your site that use an iframe so I don't know.

laszlo

User avatar
 
Posts: 5198
Joined: November 4th, 2002, 6:13 pm
Location: .de

Post Posted December 28th, 2003, 6:35 pm

The iframe is in the rightmost column ;)

The paragraph in here seems useless to me:
Code: Select all
<td colspan="2" valign="top"><p><img ... ><br>
<IFRAME ...></IFRAME></p>

Two working alternatives:
Code: Select all
<td colspan="2" valign="top"><img ... ><br>
<IFRAME ...></IFRAME>
or:
Code: Select all
<td colspan="2" valign="top"><p style="height:100%"><img ... ><br>
<IFRAME ...></IFRAME></p>

dandan
 
Posts: 3
Joined: December 28th, 2003, 6:23 pm

Post Posted December 28th, 2003, 6:45 pm

I have use iframe on my application. Its working fine in both ie and mozilla :)

Pike

User avatar
 
Posts: 2293
Joined: August 10th, 2003, 12:12 pm
Location: UK

Post Posted December 28th, 2003, 6:52 pm

Oops, must be blind :-)

v4
Guest
 

Post Posted December 28th, 2003, 7:56 pm

removing the <p> and </p> tags solved the problem, thank very much laszlo :)

Guest
Guest
 

Post Posted December 28th, 2003, 7:57 pm

*thanks

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 5 guests