MozillaZine

NoScript

User Help for Mozilla Firefox
frienD
Guest
 

Post Posted October 1st, 2006, 8:15 pm

Hello there, I have a problem. I hope you guys/gals can help me out. I recently installed NoScript extension on Firefox(Latest version) and everything is working fine, but I can't seem to access my email account at "Hushmail.com"

They use Java, and I did allow hushmail.com as a trusted site and I added it to my list in NoScript. Before when I didn't have NoScript, I could access my email account at with no problems but now that I got this new extension, I can't access it.

Here is what I normally would do, I would go onto the email website(hushmail) and I type in my email address, hit enter then a java application window comes up(for a few seconds), after that it's suppose to display "Please enter password" but nothing appears this time. Here is a snapshot of how it looks like:

Pic1 will show you the java application engine:
http://img105.imageshack.us/img105/6691/pic1md7.jpg

Pic2 is suppose to display a box where I type in my password. But as you can see, it's blank:
http://img105.imageshack.us/img105/6861/pic2cn5.jpg

So how do I fix this? I'm thinking I should disable NoScript? I would disable it, but I don't know how.

One of the bad things about this is in situations like this, I can't report my problem to hushmail support team because I have a free account and they only help people with "Premium accounts" which sucks. If I give out my report, they will most likely ignore it, or tell me to uninstall the extension. I've dealt with them before, and they were a** holes.

Daifne
Moderator

User avatar
 
Posts: 122999
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted October 1st, 2006, 11:16 pm

Moving to Firefox Support where you will be much more likely to get an answer.

greenknight

User avatar
 
Posts: 6181
Joined: December 13th, 2004, 2:28 am
Location: In the shadow of Mount St. Helens

Post Posted October 2nd, 2006, 2:55 am

Disabling an extension is very simple; go to Tools -> Extensions, right-click on the extension, click "Uninstall", then restart Firefox.

<edit>oops, I meant click disable, not uninstall. Duh <end>

If, by "latest version" you mean you've installed Firefox 2 RC1, then it's Tools -> Add-ons -> Extensions tab.
Last edited by greenknight on October 3rd, 2006, 3:56 am, edited 1 time in total.
Win 10 Home x64, Linux Mint 17.3 MATE x64, AMD A4 5300 APU 3.6 GHz, ADATA XPG DDR3 1600 8GB, ATI Radeon HD 5450. Firefox 57.0, Developer Edition 58.0b4(Win only), Nightly 59.0a1x64 (Win), Nightly 56.0a1 (Linux AMD64) .

frienD
Guest
 

Post Posted October 2nd, 2006, 11:21 am

^ Yes that is one way to disable it, but is there another way? Because I don't want to keep on uninstalling and reinstalling NoScript everytime I access my email(too much of a hassle)

Is there another way?

InCommunicative
 
Posts: 75
Joined: September 17th, 2006, 9:28 am

Post Posted October 2nd, 2006, 11:53 am

Try to allow the domain of your mail-server, like "google.com" instead of "www.google.com" and also check what pages does it redirect you to, if you could acsses them with NS, try without and then add these links to trusted.

frienD
Guest
 

Post Posted October 2nd, 2006, 11:58 am

I tried that and no luck. I even tried the following

https://mailserver8.hushmail.com/hushmail/index.php

but it could be added to the list. This is weird.

mike_lee
Guest
 

Post Posted October 2nd, 2006, 1:42 pm

frienD wrote:I tried that and no luck. I even tried the following

https://mailserver8.hushmail.com/hushmail/index.php

but it could be added to the list. This is weird.


Internet explorer, I can't see any video with firefox, so cnn.com, youtube etc I have to use IE - but at least get IE7. It seems odd though, did you allow globally and try it? There is another extension "splitlink" that will break yahoo if enabled (I never go on MSN)

frienD
Guest
 

Post Posted October 2nd, 2006, 3:01 pm

Thanks for mentioning that. Yes I just tried that and no luck.

greenknight

User avatar
 
Posts: 6181
Joined: December 13th, 2004, 2:28 am
Location: In the shadow of Mount St. Helens

Post Posted October 3rd, 2006, 3:57 am

"Uninstall" was a typo, I meant to say "click disable". Sorry about that, I was tired.
Win 10 Home x64, Linux Mint 17.3 MATE x64, AMD A4 5300 APU 3.6 GHz, ADATA XPG DDR3 1600 8GB, ATI Radeon HD 5450. Firefox 57.0, Developer Edition 58.0b4(Win only), Nightly 59.0a1x64 (Win), Nightly 56.0a1 (Linux AMD64) .

frienD
Guest
 

Post Posted October 3rd, 2006, 6:58 pm

I finally know what is causing this whole situtation. As I suspected, it is usually my other extensions that get in the way. So the problem lies with "HaH(Hit a Hint extension)"

*Hit a Hint is a mouseless browsing tool. Basically you only use your keyboard to surf the net*

I kept all of my extensions including "NoScript" and uninstalled "Hit a Hint" then I tried to access my email account, and it worked. Just to make sure, I installed Hit a Hint again and tried to access my account but failed. So from my experience and testing, I found that it was Hit a Hint that was causing this.

I don't know if there's a bug in that extension, but as of now I'm not using it. So if anyone can report this to the creator, that would be nice I guess. I would report it to him/her but I don't know where to begin.

*By the way, I DO need Hit a Hint, it's a great tool to have. I haven't touched my mouse for a couple of months now. So if the author or creator can fix that problem, that will be wonderful.

wrf
 
Posts: 9
Joined: February 1st, 2005, 9:17 pm

Post Posted March 8th, 2007, 1:17 pm

I've been using noscript, which is excellent, for some time, and built up a few hundred entries in my whitelist. So I decided to delete entries that I wasn't going to visit again. I selected the white list and hit delete. Eight (8) CPU minutes later I killed firefox, and trying deleting entries a few at a time. Deleting each entry took several CPU seconds. How can this possibly take so long? This makes me wonder if noscript is running slowly all the time.

Deleting the whitelist bu editing prefs.js worked fine.

Thanks.

Guest
Guest
 

Post Posted February 16th, 2009, 9:52 am

I have installed noscript and everything was working fine but suddenly the noscript status bar icon disappeared. I tried un-installing & re-installing both firefox and noscript but no luck. Any suggestions?

LIMPET235
Moderator

User avatar
 
Posts: 37588
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 16th, 2009, 9:59 am

Please start a new thread as this old one needs to retire.
Locking.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-56.0.1/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting.
(Always choose the "Custom" Install.)

steviex
Moderator

User avatar
 
Posts: 28902
Joined: August 12th, 2006, 8:27 am
Location: Middle England

Post Posted February 16th, 2009, 10:06 am

The best thing to do is post in THIS TOPIC.... viewtopic.php?f=48&t=1070305

This is the thread that the Extension author maintains for NoScript.
Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -Albert Einstein

Please DO NOT PM me for support... Lets keep it on the board, so we can all learn.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Tony-E and 18 guests