MozillaZine

back and forward button

User Help for Mozilla Firefox
Guest
Guest
 

Post Posted December 14th, 2007, 8:08 am

.bat wrote:expirienced the same problem here and this is what I found out so far:

the back and forward buttons are disabled TILL you open a new tab. Once you set the focus on the new tab, and go back to the first one there will all of a sudden be an enabled back / forward button. At least this works for me.

However its god damn annoying, would be nice if anyone has a solution to this.

Solution to what? That is what is supposed to happen. What would be the point of having Back/Forward enabled, if there is nothing to go back or forward to?

mrand
 
Posts: 12
Joined: March 30th, 2003, 8:50 pm
Location: Dallas

Post Posted December 14th, 2007, 8:46 am

Anonymous wrote:
.bat wrote:expirienced the same problem here and this is what I found out so far:

the back and forward buttons are disabled TILL you open a new tab. Once you set the focus on the new tab, and go back to the first one there will all of a sudden be an enabled back / forward button. At least this works for me.

However its god damn annoying, would be nice if anyone has a solution to this.

Solution to what? That is what is supposed to happen. What would be the point of having Back/Forward enabled, if there is nothing to go back or forward to?

I think you're missing the point: the back, reload, and stop buttons all remain grayed out, even after navigating from one page to another by clicking on links. In other words, you can only go "forward" by clicking on URL's, and you can't ever go "back."

Marc

dickvl

User avatar
 
Posts: 52261
Joined: July 18th, 2005, 3:25 am

Post Posted December 14th, 2007, 12:50 pm

Did you try to start Firefox in -safe-mode to check if your problem is caused by an extension or theme (try the default theme)?
If starting in Safe-mode works then disable your extensions (Tools > Add-ons > Extensions or use the option in the Safe-mode window) and re-enable them one by one until you find which one is causing it.
Close and restart Firefox after each change.

mrand
 
Posts: 12
Joined: March 30th, 2003, 8:50 pm
Location: Dallas

Post Posted December 14th, 2007, 2:10 pm

dickvl wrote:Did you try to start Firefox in -safe-mode to check if your problem is caused by an extension or theme (try the default theme)?
If starting in Safe-mode works then disable your extensions (Tools > Add-ons > Extensions or use the option in the Safe-mode window) and re-enable them one by one until you find which one is causing it.
Close and restart Firefox after each change.


Yes. My post on the previous page of the thread has the details:

mrand wrote:Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

Running FF3b2, I'm seeing the same problem even in safe mode. In fact, not only do forward and backward and stop buttons not work, but the throbber on the tab runs endlessly. I have to remove my old profile in order for everything to work as expected. Never installed any different themes, so that can't be it. Opening a new tab doesn't fix it either.

I couldn't find a bug report - anyone know of one?

Marc

dickvl

User avatar
 
Posts: 52261
Joined: July 18th, 2005, 3:25 am

Post Posted December 14th, 2007, 3:15 pm

In this case it is better to use a new profile for 3.0 beta versions because extensions and themes are not updated for that new version and can cause problems.
As long as Fx 3 is in the (beta) test phase then nothing is guaranteed to work and to avoid confusion with a broken profile it is better to use a fresh profile.
Then also you won't have problems if you need to go back to Firefox 2 or want to use it alongside of Firefox 3.
You always need to check issues with a clean profile to make sure that it is not caused by your current profile, it is the first step in testing software.

pattis1
Guest
 

Post Posted December 14th, 2007, 5:11 pm

I have been reading the forum in hopes to find out why I don't have the navigation bar
at all. No back and forth button, no stop button, no nothing! I have the file, edit, view etc.
then the next line is getting started/ latest headlines. Thats it. How can I fix this?
On my other computer that I downloaded a replica of mozilla just recently, everything
works perfectly. They are identical computers, same dsl server. I don't get it.
I would really like to fix this, because the whole reason for changing was to
get away from the yahoo browser, due to its loss of speed and efficency.
Please help. I have tried the fixes previous to this post on the forum.
Anything new to try?
Help

pattis1
Guest
 

Post Posted December 14th, 2007, 5:25 pm

Sorry guys, but I fixed the navigation bar. *sidenote; computer that didn't have
navigation bar wasn't mine. Went to view and turned on "navigation bar"
Everything works fine now.

Dorian3
Guest
 

Post Posted December 14th, 2007, 5:28 pm

If you already tried making a new profile, it is very unusual that you would have a problem like this.
New profile:
http://www.mozilla.org/support/firefox/profile

If that does not fix it, check for malware/viruses and/or do a clean uninstall of Firefox (deleting the program files mozilla firefox directory before reinstalling).

CentosRoot
Guest
 

Post Posted December 21st, 2007, 9:47 am

I'm having a issue with the firefox 3 beta Back Button getting disabled intermittently while browsing. No fancy extensions or themes in use.

I re-installed the Firefox completely. Even deleted my profiles.

I'm frustrated with Firefox 3. Switching to Opera 9.5, which is faster and more stable than Firefox 3x

I have been using Firefox 2, but that is damn slow and not worthy of being called a browser.

dickvl

User avatar
 
Posts: 52261
Joined: July 18th, 2005, 3:25 am

Post Posted December 21st, 2007, 1:39 pm

Firefox 3 (latest Minefield nightly) works stable for me.
Did you use a clean profile, without any add-ons and themes installed and especially no 'forced' extensions?
That is very important if you decide to test beta software.

Do you have Breakpad GUIDs?

malliz
Folder@Home

User avatar
 
Posts: 43193
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted December 21st, 2007, 2:57 pm

CentosRoot wrote:I'm having a issue with the firefox 3 beta Back Button getting disabled intermittently while browsing. No fancy extensions or themes in use.

Are you using any extensions?
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

lyndiloo
Guest
 

Post Posted January 16th, 2008, 11:15 am

since i upgraded the back and forward buttons have never worked. i uninstalled and reinstalled - still grayed out! i am not a specialist or an IT tech, so really have no idea what to do next. can this problem be solved? Please help!

At7be
Guest
 

Post Posted January 16th, 2008, 11:48 am

If you are not a tech expert, you should not run Firefox 3 until it is officially released.

If you are asking about Firefox 2, making a new profile should fix the problem.
http://www.mozilla.org/support/firefox/profile

Guest
Guest
 

Post Posted January 30th, 2008, 9:32 pm

i have the same problem with firefox 2.0.0.11

rabbai007
Guest
 

Post Posted July 16th, 2008, 8:55 am

I had the same problem with Mozilla 3.0 on linux. When I started if from applications, its didn't start up with the back and forward tab buttons functioning. Well wat i simply did was change the permission for the .mozilla/ directory in my home folder from root to the intended user. U might check this folders permission and it says it belongs to the user but the essential folder is the extension folder inside it which would belong to root. what u need to do is as root or

sudo chown -R <normaluser>:<normaluser group> ~/.mozilla/

This would solve the prblem. Restart Mozilla and u are ok.


Worked for me..........

Return to Firefox Support


Who is online

Users browsing this forum: Happy112 and 15 guests