MozillaZine

Hyperlinks open in IE instead of Firefox

User Help for Mozilla Firefox
martinlest
 
Posts: 38
Joined: August 8th, 2004, 3:16 am

Post Posted March 3rd, 2007, 3:55 am

When I open a web page using a hyperlink (usually originating in a Word document, though not always), it opens in Internet Explorer, which I rarely otherwise use. I have Firefox set as default browser and HTM, HTML, XHT & XHTML files are all set in Folder Options to open in Firefox.

How do I change my settings to that hyperlinks automatically open the webpage in Firefox instead? Maybe it's a setting within the hyperlink hosting application (e.g. MS Word etc. ???).

Thanks,

Martin

Guest
Guest
 

Post Posted March 3rd, 2007, 4:03 am

Maybe Word/etc. have been hardcoded to always open links in IE?

martinlest
 
Posts: 38
Joined: August 8th, 2004, 3:16 am

Post Posted March 3rd, 2007, 4:15 am

OK, one clue. When I receive an e-mail which contains a hyperlink where the mouse pointer automatically changes to a 'hand' shape when you hover the pointer over it, the link will open fine in Firefox. However, any link where one needs to press Ctrl+Enter to open the relevant webpage opens in IE.

Also, if I copy a link from an e-mail which opens in the first way, above, without the need for the Ctrl key, and paste it into a Word document, it then needs the Ctrl key to activate it and opens up now in IE.

Does this provide a clue? I don't know enough about the difference between the two types of link to work this out myself!

Not sure if Word is hardcoded to open links in IE. May well be. Can't see any option to choose the browser (Tools/Options/General. Web Options tab??) ..

M.

Guest
Guest
 

Post Posted March 3rd, 2007, 9:38 am

im having the same problem, when i try to open a hyperlink from say AIM or something of that nature, it will open it in IE7, not firefox.

martinlest
 
Posts: 38
Joined: August 8th, 2004, 3:16 am

Post Posted March 8th, 2007, 1:46 pm

Great response here guys! I'm impressed ...

Found the solution elsewhere. Go to Control Panel/Add-Remove programs/Set Program Access and then select Mozilla from within the custom option. Hope that helps someone.

M. :-)

Changed user name
Guest
 

Post Posted May 9th, 2009, 1:44 pm

martinlest wrote:Great response here guys! I'm impressed ...

Found the solution elsewhere. Go to Control Panel/Add-Remove programs/Set Program Access and then select Mozilla from within the custom option. Hope that helps someone.

M. :-)
dosent work
Last edited by Dartman on May 9th, 2009, 6:34 pm, edited 1 time in total.
Reason: changed user name

Dartman
Moderator

User avatar
 
Posts: 11957
Joined: February 9th, 2006, 9:43 pm

Post Posted May 9th, 2009, 6:36 pm

You are replying to a thread from 2007. When you start a new thread, make sure you choose a appropriate user name. The one you chose was not. (I changed your user name)
Alcohol and Calculus don't mix. Never drink and derive.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 16 guests