MozillaZine

Firefox reads PNG pictures as GIF and doesn't display them

User Help for Mozilla Firefox
TittiinNY
 
Posts: 5
Joined: May 6th, 2007, 8:07 pm

Post Posted May 6th, 2007, 8:09 pm

I've updated to 2.0.0.3 and since then when I try to load a page with a PNG image, I can't see the PNG image.

I've checked the MIMEs and there is the right association with Quicktime.

If I go to Page Info and click on the link for that png picture, it tells me that it's a GIF picture with dimension of 1px by 1px, and that explains why I can't see it, but I haven't figured out how to fix it.

Any help would be appreciated.

old LoudNoise
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 6th, 2007, 8:16 pm

Why are PNGs associated with Quicktime?

malliz
Folder@Home

User avatar
 
Posts: 42098
Joined: December 7th, 2002, 4:34 am
Location: Aus

Post Posted May 6th, 2007, 8:17 pm

Try a new profile and test it before you migrate or re-install anything on it

http://kb.mozillazine.org/Creating_a_ne ... on_Windows
And
http://kb.mozillazine.org/Migrating_set ... ew_profile
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

malliz
Folder@Home

User avatar
 
Posts: 42098
Joined: December 7th, 2002, 4:34 am
Location: Aus

Post Posted May 6th, 2007, 8:18 pm

LoudNoise wrote:Why are PNGs associated with Quicktime?

Good question
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

TittiinNY
 
Posts: 5
Joined: May 6th, 2007, 8:07 pm

Post Posted May 6th, 2007, 8:19 pm

LoudNoise wrote:Why are PNGs associated with Quicktime?


It seems that it's the default association in Firefox. I reset all the plugs in according to the instruction and that's what it shows as default.

old LoudNoise
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 6th, 2007, 8:27 pm

It seems that it's the default association in Firefox. I reset all the plugs in according to the instruction and that's what it shows as default.


Doubtful. Assuming you don't have much time invested in your profile I would suggest you follow malliz's links.

TittiinNY
 
Posts: 5
Joined: May 6th, 2007, 8:07 pm

Post Posted May 6th, 2007, 8:37 pm

LoudNoise wrote:
It seems that it's the default association in Firefox. I reset all the plugs in according to the instruction and that's what it shows as default.


Doubtful. Assuming you don't have much time invested in your profile I would suggest you follow malliz's links.



I've followed the instruction and created a brand new profile, but I have the same problem.

malliz
Folder@Home

User avatar
 
Posts: 42098
Joined: December 7th, 2002, 4:34 am
Location: Aus

Post Posted May 7th, 2007, 4:00 am

What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

Anonymosity
 
Posts: 8174
Joined: May 7th, 2007, 12:07 pm

Post Posted May 7th, 2007, 4:19 pm

It does not matter what application is associated with .png images, or .gif or .jpg. Firefox should display them anyway. In Windows, I have those images associated with Irfanview, and in MacOS, with JView.

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted May 7th, 2007, 4:51 pm

Page where this happens ?

TittiinNY
 
Posts: 5
Joined: May 6th, 2007, 8:07 pm

Post Posted May 7th, 2007, 5:10 pm

Littlemutt wrote:Page where this happens ?


http://img244.imageshack.us/img244/8342/banner2wt4.png
This would be one, but there are others.

On top of the page in the description area I get
banner2wt4.png (GIF Image, 1x1 pixels) - Mozilla Firefox

Guest
Guest
 

Post Posted May 7th, 2007, 5:50 pm

Close Firefox, go to the Quicktime MIME settings and uncheck PNG Image, click OK. Start Firefox and clear the cache:
Tools > Options > Advanced > Network > Clear Now

Firefox can view png images without the need of a plugin.

That image does display fine for me.

Guest
Guest
 

Post Posted May 7th, 2007, 5:54 pm

Anonymosity wrote:It does not matter what application is associated with .png images, or .gif or .jpg. Firefox should display them anyway. In Windows, I have those images associated with Irfanview, and in MacOS, with JView.

Quicktime MIME settings are different than file associations. If PNG is enabled in the QT browser settings, it could interfere with Firefox's native PNG support.

TittiinNY
 
Posts: 5
Joined: May 6th, 2007, 8:07 pm

Post Posted May 7th, 2007, 5:57 pm

Anonymous wrote:Close Firefox, go to the Quicktime MIME settings and uncheck PNG Image, click OK. Start Firefox and clear the cache:
Tools > Options > Advanced > Network > Clear Now

Firefox can view png images without the need of a plugin.

That image does display fine for me.


I did that and it didn't work.

I'm so ready to give up and just accept that I can't see some pictures. lol

Guest
Guest
 

Post Posted May 7th, 2007, 6:10 pm

Enter about:plugins in the address bar. See if PNG is listed under any of the Quicktime plugins. If it is, then the plugin is still in the Firefox plugin folder. Follow the steps here to remove those and then reset your MIME settings, ensuring that PNG is not enabled.

http://kb.mozillazine.org/Quicktime#Res ... er_plugins

Also, if PNG is still listed in your Firefox file types options (manage), remove that association.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 19 guests