MozillaZine

Red Dots on loading images

User Help for Mozilla Firefox
Guest
Guest
 

Post Posted May 21st, 2007, 9:14 pm

This happens on my OS X and Windows machines. It looks like they changed the loading image placeholder to this red dot in the newer versions of firefox. Until they change it back turning them off via the about:config page seems like a pretty good solution.

jfreyre
 
Posts: 6
Joined: May 22nd, 2007, 12:40 am
Location: Cuernavaca, Mexico

Post Posted May 22nd, 2007, 1:05 am

It seems like the problem resides in the profile. In fact, there must be some settings that become corrupted disallowing to Firefox to find the "res" directory. I carried out some experiments and I came to this conclusion. By the way my OS is Windows XP SP1 with Firefox 2.0.0.3

1) I run Firefox in safe mode. The red dots are still there. So this implies that the problem is not related with plugins or themes.

2) I created a new clean profile. When I run Firefox with the original profile I still get the red dots. But when I run Firefox with the new profile I get the correct image placeholders.

3) I renamed the files loading-image.gif and broken-image.gif located in the "res" directory. I run Firefox with the new clean profile and I get the red dots! So this implies that the red dots are displayed by Firefox when it can't find the correct "res".

4) It seems like this problem has been reported previously, check https://bugzilla.mozilla.org/show_bug.cgi?id=272534

I hope this information allows you to get insights about the nature of the problem and its possible fix.
Last edited by jfreyre on May 22nd, 2007, 4:02 pm, edited 1 time in total.

Black_Monkey
 
Posts: 1
Joined: April 10th, 2007, 10:57 am

Post Posted May 22nd, 2007, 3:00 am

Yeah, this has been annoying me for a while now. My loading-image.gif, in the 'res' folder, is the one in Reflective's screenshot, the usual image that's been used for ages, but for some reason it shows the red dot instead of this image. Images load up fine and all, it's just that before they're loaded, I want my normal loading-image.gif, not the red dot. I have Adblock Plus and Filterset.G.Updater, and this is using Firefox 2.0.0.3 on Linux. Has anyone found any way to get the normal image back?

red_dots
Guest
 

Post Posted May 22nd, 2007, 10:09 am

The red dots started showing up for me a few days ago.

They are incredibly annoying. I re-installed FF, but to no avail. My loading-image.gif, in the 'res' folder is fine, but it keeps showing the red dot.

I'm using FF 2.0.0.3 on fully up-to-date WinXP. I have no themes installed. I don't have ad-block, but I do have Firebug.

Hopefully there is a fix to get the regular placeholders back.

fruity
Guest
 

Post Posted May 22nd, 2007, 1:53 pm

I have the same thing as all of you. Same version tried everything to fix it, not fixing....

Do you think this is a new bug in firefox or did they just make a new placeholder or something

jfreyre
 
Posts: 6
Joined: May 22nd, 2007, 12:40 am
Location: Cuernavaca, Mexico

Post Posted May 22nd, 2007, 10:14 pm

I devised a solution that worked for me. This solution bring me back the correct placeholders. Now, the red dots have gone.

Please try the solution and give your feedback. Remember to backup your profile directory!!

1) Run Firefox using the profile manager: "Firefox.exe -ProfileManager".
2) Create a new clean profile, name it "temp" for example. Select your default profile and start Firefox.
3) Close Firefox.
4) Find your profiles folder, it may be located in "C:\Documents and Settings\[your username]\Application Data\Mozilla\Firefox\Profiles".
5) Into this folder you will find a folder for each Firefox profile. Find the default profile folder, it could be called something like "[something].default".
6) Rename the 'localstore.rdf' file (located in the default profile folder) to 'localstore.rdf_original'.
7) Go to the recently created "temp" profile folder.
8) Copy the 'localstore.rdf' file (from the clean profile) to the default profile folder.
9) Run Firefox, your plugins will be disabled but don't worry. Now go to https://bugzilla.mozilla.org/attachment.cgi?id=167513 You must see the correct broken image placeholder, and no red dots.
10) Close Firefox.
11) Find your default profile folder. Delete the 'localstore.rdf' file.
12) Rename 'localstore.rdf_original' to 'localstore.rdf'.
13) Run Firefox using the profile manager and delete the "temp" profile.

Now Firefox must display the correct image placeholders and the red dots must be gone,
Good luck!!

skogul_rd
Guest
 

Post Posted May 23rd, 2007, 3:59 am

Hi jfreyre, thanks for your solution. I followed the steps, but replacing the localstore.rdf file didn't work for me (although I'm using Mac OS X). I ended up switching over permanently to the new profile, (imported my old bookmarks over as well). I might have to re-enter some saved passwords, but it's worth it to not see those red dots!

allan_daiku
Guest
 

Post Posted May 23rd, 2007, 8:53 am

Well, here's what I discovered. I tried creating a new profile, and after closing FF, the red dots came back once I opened it up again. I tried jfreyre's RDF file solution, and had no luck. So far, the ONLY thing that's worked for me is NOT using the personalized Google homepage (the one with the themes--I was using the one with the Japanese fox). So far (and this, of course, may change) if I don't sign in to the personalized Google homepage, no red dots. I'll keep you posted, but does anyone have any idea how this could possibly be tied in?

jfreyre
 
Posts: 6
Joined: May 22nd, 2007, 12:40 am
Location: Cuernavaca, Mexico

Post Posted May 23rd, 2007, 9:16 am

I'm sorry to hear that solution not worked for you. It's very important to follow all the steps in the correct order. In fact, I have to do twice the procedure to get results.

As allan_daiku says there is a relation between Google and the red dots. I have no problems with Google personalized homepage, but after I was using picassa I got the red dot back. Solution: I closed Firefox and the correct image placeholders came back.

Also it's possible that the problem could be related with Google toolbar, do you have Google toolbar installed?

Thanks for your feedback!

allan_daiku
Guest
 

Post Posted May 23rd, 2007, 9:26 am

I do have Google toolbar installed, and so far, so good, no red dots. I should add I have FF on my computer at work, with basically all the same add-ons and settings, except for the personalized Google homepage. I've never had the 'red dot' problem at work.

The personalized Google homepage is great, and I hope someone at Google hears about this problem and fixes it, because I'd like to go back to using it again.

fruity
Guest
 

Post Posted May 23rd, 2007, 1:51 pm

This is true it is the google homepage that is the problem. The red dots do not show up anymore if google is not your homepage. If someone could send a bug report to google or post it somewhere. Post the link here and im sure everyone here will support the bug report.

jfreyre
 
Posts: 6
Joined: May 22nd, 2007, 12:40 am
Location: Cuernavaca, Mexico

Post Posted May 23rd, 2007, 7:04 pm

allan_daiku is right, I have confirmed that iGoogle homepage cause the problem. But, red dots only appear if iGoogle is configured in Firefox as the default homepage and, as consecuence, it's displayed when you run Firefox. If you run Firefox using another default homepage then go to to iGoogle homepage red dots doesn't appear! So, a workaround is not to set iGoogle as your default homepage.

I agree with fruity that a bug report must be send to Google. Please support us sending a bug report:
http://www.google.com/support/bin/reque ... t_type=gph

carlosoctavio

User avatar
 
Posts: 12
Joined: March 19th, 2005, 1:39 pm

Post Posted May 24th, 2007, 3:46 pm

Well i did what Fruity and allan daiku said, removed the igoogle as home, and also uninstalled the addon "VideoDownloader" and the red dots are gone , and im using FIreHawke3d as theme, no problem with that.

I dont know if its videodownloader or not whats causing the problem, but its working nice for me now, and the red dots gone, so thanks to all for the tips and ideas :)

Greetings from Argentina.

jfreyre
 
Posts: 6
Joined: May 22nd, 2007, 12:40 am
Location: Cuernavaca, Mexico

Post Posted May 24th, 2007, 7:26 pm

Hi carlosoctavio, I've VideoDownloader installed and I'm free of red dots. In fact I'm still using iGoogle but not like my default homepage.

carlosoctavio

User avatar
 
Posts: 12
Joined: March 19th, 2005, 1:39 pm

Post Posted May 24th, 2007, 7:38 pm

Oh hi jfreyre ... its weird, i dont know why but the red dots are not there anymore but now the image is not loading faster than before ...
I had previous version in spanish, uninstalled it and installed the english version in same folder ... and now i have web developer addon also installed (still there, i didnt uninstall it)... maybe its because i didnt do a new and fresh install , after uninstallation of spanish version ?

And also, i was editing the config about the network.http.pipelining.maxrequests and that things to make it faster (it was working fine with the spanish lang).
Here is a screenshot when i load a page: instead the red dots appears :
Image

Look at right (behind masoportunidades.com logo).
I have 2,5 mb of speed (aprox, i know) ... but as i remember it never happened to me , so im lost with this.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 16 guests