MozillaZine

Change the Color of the Loading screen in Firefox?

User Help for Mozilla Firefox
helpmyeyes
Guest
 

Post Posted July 29th, 2007, 3:53 pm

Is there a way to change the color of the loading screen in firefox?

I seem to remember using a theme which rendered the loading page black instead of white.

When I click a link it throws up a white loading screen. Because I have a slow speed Internet I'm left waiting for a while looking at a bright white screen. I have an extension called stylish but cant seem to find a suitable script I can find one to do the "about:blank" but nothing for the loading screen?

Is there something I could put in my Chrome file to change it to black?

Thanks for any help or tips.

Image

Micha the not so Old
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted July 29th, 2007, 4:14 pm

Type a search term into the Knowledge Base Search box over there ---> and see what you can find, that looks suitable. You can always reinstall Firefox if it goes wrong.

helpmyeyes
Guest
 

Post Posted July 29th, 2007, 4:27 pm

Thanks for the fast reply, I've searched over there with keywords like "firefox color" "firefox loading" and in the end just "firefox" I gone though them can seem to see anything suitable. Should I be looking for loading screen? What would you call it?

I thought it would be a popular tweak.

Ive been looking here >>> http://userstyles.org/styles/search/firefox+

dickvl

User avatar
 
Posts: 51502
Joined: July 18th, 2005, 3:25 am

Post Posted July 29th, 2007, 5:04 pm

Try (userContent.css):
@-moz-document url-prefix(about:blank) {*{background-color:#f0f0f0;}}

You can also look at the default colors in: Tools > Options > Content : Fonts & Colors: Colors

helpmyeyes
Guest
 

Post Posted July 30th, 2007, 6:51 am

Thanks for the reply, Tried what you say. Doesn't seem to work for me. We are taking about that white screen that pops up just before a page has the time to render/load. I will have another try. Seems like a strange way to have to change it. With all the tweaks for FF I though this would be an easy thing to achieve.

I can go here >>> http://userstyles.org/styles/search/firefox+

and find all sorts of scripts to darken the "about:blank" & Google just nothing for that loadpage if thats even whats its called.

Anonymosity
 
Posts: 8166
Joined: May 7th, 2007, 12:07 pm

Post Posted July 30th, 2007, 1:00 pm

This is what I use in my userContent.css file:
Code: Select all
BODY {background-color: lightblue;}

It changes the default background to light blue instead of white, so if nobody has bothered to set a background colour, that is what it will be.

Old Bozz
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted July 30th, 2007, 1:43 pm

Well here is what I use.

...in userChrome.css

Code: Select all
/* Blank background before clicked link page loads....
see userContent.css for blank tab and initial Firefox startup blank
before homepage loads */
tabbrowser tabpanels {
background-color: rgb(220, 220, 220) !important;
}


...in userContent.css

Code: Select all
/* Background for blank tab and Firefox startup blank page
before homepage loads...
see userChrome.css for background before clicked link page loads */
@-moz-document  url(about:blank) {
html { background-color: rgb(220, 220, 220) !important; }}
/* added dickvls just because */
@-moz-document url-prefix(about:blank) {
* { background-color: rgb(220, 220, 220); }}

.

helpmyeyes
Guest
 

Post Posted July 30th, 2007, 4:53 pm

Thanks for the replys, But I think I left out a major part of the description of my problem. I'm middle clicking on my mouse to open a link in a new tab. It's at this point I'm seeing the white screen. I think the fact I left that out is the reason the above tips don't work.

@Bozz does that config work when you middle click links?

Thing is I middle click all the time so see that bright white screen to often.

This is the only thing that bugs me with my current FF setup, If someone can help I'll be very happy.

dickvl

User avatar
 
Posts: 51502
Joined: July 18th, 2005, 3:25 am

Post Posted July 30th, 2007, 5:45 pm

Make sure that you put userContent.css in the correct folder (chrome folder).
See: Where is my profile folder? (KB)

You can use the Chrome Edit Plus extension:
Chrome Edit Plus - http://webdesigns.ms11.net/chromeditp.html

helpmyeyes
Guest
 

Post Posted July 30th, 2007, 6:15 pm

Thanks for the tips dickvl for Chrome Edit Plus I've installed that extension now so I'm sure that the info is going in the right place. The code that Bozz gave is working when I turn firefox on. As I wait for my homepage to load I now see a black screen, I changed >>>

[rgb(220, 220, 220) for rgb(0, 0, 0)]

I also have a Black "about:blank" with bozz code. But when I middle click a link it still shows a white page for a few seconds before the page loads.

dickvl

User avatar
 
Posts: 51502
Joined: July 18th, 2005, 3:25 am

Post Posted July 30th, 2007, 6:32 pm

Try to change the default background: Tools > Options > Content : Fonts & Colors: Colors

Prefs for more finetuning:
http://kb.mozillazine.org/Browser.displ ... ound_color (#FFFFFF)
browser.display.foreground_color (#000000)

helpmyeyes
Guest
 

Post Posted July 30th, 2007, 7:34 pm

Any changes that I make to >>>

S1

Image

Have a negative effect on the link/website I'm middle clicking on, With no change to the loading screen color. So I put them back to default like in S1.

To be 100% clear I'll run you thought what I'm doing with some screenshots.

I'm in FF with one page open, I then middle click a bookmark & this happens (The problem S2)>>>

S2

Image

after sometime the website with render like this >>>

S3

Image

Thats fine the web site looks fine. Its the bit before. The "loading screen" that I have a problem with.

I want it to look like this (I edited this in paint to show you what I like to happen)>>>

S4

Image

like I say any changes made in Tools > Options > Content : Fonts & Colors: Colors have negative effect with no effect on loading screen color.

Guest
Guest
 

Post Posted July 30th, 2007, 7:42 pm

userChrome.css:
Code: Select all
 browser { background-color: #000 !important; }

helpmyeyes
Guest
 

Post Posted July 30th, 2007, 8:13 pm

Thanks guest I just tried your bit of code with nothing else and it works!

Many thanks to everyone who helped out, My browser is now perfect :)

anotheranonymousdood
Guest
 

Post Posted February 21st, 2009, 2:50 pm

Guest wrote:userChrome.css:
Code: Select all
 browser { background-color: #000 !important; }


Thanks, this worked for me too ; goodbye to being blasted with white light during night-time web browsing!

Return to Firefox Support


Who is online

Users browsing this forum: Agozer, Google [Bot] and 14 guests