MozillaZine

Firefox wont open asx files

User Help for Mozilla Firefox
Zap250
Guest
 

Post Posted November 7th, 2007, 10:55 am

I am trying to open an asx file: http://www.nasa.gov/55644main_NASATV_Windows.asx
The problem is, all I get is a blank page.
I can copy the URL and paste it into Windows Media Player or VLC Player and view the live video, no problem.
But when I try to open it in Firefox it just gives me a blank page, it doesnt transfer the file to the external program.
I tried to change the associations in Tools > Options > Content > Manage, but it just ignores that.
So I can't open any links to asx files with Firefox, rather I have to copy and paste the URL into my media player which is really tedious.
I'm running Firefox 2.0.0.9 on Windows XP SP2.

m1scha.m

User avatar
 
Posts: 1476
Joined: October 18th, 2007, 5:04 pm

Post Posted November 7th, 2007, 4:42 pm

Works for me, and I am using 2.0.0.9 on XP 64 bit. It opens in Media Player for me. Take a look here and see if it helps: http://forums.mozillazine.org/viewtopic.php?t=540679

couldabeen

User avatar
 
Posts: 6702
Joined: September 9th, 2003, 11:24 am
Location: I'm Right Here

Post Posted November 7th, 2007, 6:03 pm

Works here with WinXP SP2. Opens in Media Player.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10pre) Gecko/20071107 BonEcho/2.0.0.10pre ID:2007110703
Free Your Mind, And Your A$$ Will Follow - Funkadelic, 1970

Alice

User avatar
 
Posts: 2613
Joined: April 23rd, 2003, 11:47 am

Post Posted November 7th, 2007, 6:23 pm

You can test your Windows Media Player plugin here:
http://plugindoc.mozdev.org/testpages/wmp9.html

Also, you mentioned you have the VLC player installed. Its npvlc.dll plugin may be conflicting with the WMP plugin. Installing the new WMP Firefox plugin should override the VLC plugin, since the new plugin will be installed to the Firefox plugins folder. Otherwise, you may want to exit Firefox completely, them remove npvlc.dll from the Firefox plugins folder or other location where it may have been installed, so that Firefox can use the standard WMP plugin (npdsplay.dll) which, in most cases, is present on Windows XP systems.

More help here:
http://kb.mozillazine.org/Windows_Media_Player
http://kb.mozillazine.org/Opening_files_using_plugins
http://kb.mozillazine.org/File_types_an ... ad_actions
Alice Wyman

Alice

User avatar
 
Posts: 2613
Joined: April 23rd, 2003, 11:47 am

Post Posted November 7th, 2007, 7:19 pm

P.S.
You said, "I tried to change the associations in Tools > Options > Content > Manage, but it just ignores that". There should have been three ASX entries (for different MIME types). Maybe you didn't change all three entries. What is your system default player for .asx files, by the way? Double-click a saved .asx file (you could right-click the .asx link you gave above and save it to your hard drive). What program opens?

If you have Windows Media Player as the default player for .asx files and if your Windows Media Player plugin is working, you should change the Download Actions for all three ASX entries back to "Use this Plugin (Windows Media Player Dynamic Link Library). Alternately, use about:config, find the preference plugin.disable_full_page_plugin_for_types , right-click and select "Reset". See this discussion for details.
Alice Wyman

Zap250
Guest
 

Post Posted November 7th, 2007, 9:09 pm

Thanks Alice. I'm still having trouble. I tried installing the WMP plugin from http://port25.technet.com/pages/windows ... nload.aspx but it didn't solve the problem so I removed it. There actually were three entries for ASX files in the Options > Content > Manage screen. After fiddling around with those options and not getting anywhere, I removed all three. As you can guess, that didn't help. ASX files on my computer open with VLC by default. I had also reset plugin.disable_full_page_plugin_for_types. When I look in the plugins folder there is no npvlc.dll or npdsplay.dll. It doesn't really matter to me which program opens the ASX file (I have a slight preference for VLC but I'll be happy if it opens at all).

Zap250
Guest
 

Post Posted November 7th, 2007, 9:11 pm

BTW, when I went to the site http://plugindoc.mozdev.org/testpages/wmp9.html I was greeted with the error message "Can not create DirectShow Player"

Zap250
Guest
 

Post Posted November 7th, 2007, 9:30 pm

I was able to locate the npdsplay.dll file from the WMP installation folder and copied it into the plugins folder but it hasn't changed a thing.

Zap250
 
Posts: 4
Joined: November 7th, 2007, 10:02 pm

Post Posted November 7th, 2007, 10:10 pm

Ok the three ASX entries are back again, and they seem to be set up correctly but it hasn't changed anything :-/

Image

Alice

User avatar
 
Posts: 2613
Joined: April 23rd, 2003, 11:47 am

Post Posted November 8th, 2007, 6:25 am

ASX files on my computer open with VLC by default.

When you have the Windows Media Player plugin set to handle file downloads for the Windows Media filetypes, the standard WMP plugin passes off the file to the system default player (the new WMP plugin may or may not do the same, depending on file type, if I remember right). This is obviously not happening in your case... I saw a similar issue when WinAmp was set to handle wmv files:
http://kb.mozillazine.org/Opening_files ... yer_plugin
Windows Media Player plugin

The standard Windows Media Player plugin (file name "npdsplay.dll"), when loaded from a direct link, will not appear in the page and display the file like other plugins - it will just appear as a blank page, download the whole file, and then hand it off automatically to the default media player for that file type. In other words, if WinAmp or Real Player is the default media player for .wma (Windows Media Audio) or .wmv (Windows Media Video) files, then direct links to those files will result in WinAmp or Real Player opening, even if the Windows Media Player plugin is installed and listed as handling those types of files in about:plugins.

If WinAmp or Real Player opens direct links to .wma or .wmv files and you receive an error message or the file doesn't play, either restore the Windows Media Player program as the default player for those types or change your Firefox options for Download Actions so that downloaded .wma or .wmv files are set to open in the default application instead of in the Windows Media Player plugin [3][4].


Since you say that setting the download action for the three asx files to the VLC player didn't work, then you may want to reset Windows Media Player as the system default player for asx files and see if that helps. On WMP 10 (which I have on my Windows XP SP2 system) you open the application menu from the down arrow in the WMP menu bar, then select Tools > Options and click the File Types tab, then select the box for Windows Media file (asf) which includes the asx extension. You may also need to deselect asx files in your VLC player options if you have that player set to reclaim file types that are changed, I don't know (I don't use the VLC player). Once asx files are again associated with WMP player, see if you can open asx links from Firefox.

If you prefer to keep ASX files associated with VLC then something else to try would be to set those three ASX entries to open in the VLC player by using the second option in the Change Action dialog, "Open them with this application", and then use the Browse... button to select the VLC player's executable ("<VLC>.exe") file.

As a last resort, you could reset all Download Actions by exiting Firefox completely, then deleting (or renaming) the MimeTypes.rdf file in the Firefox profile folder. Be sure you delete or rename the file in the Firefox profile folder, for example, C:\Documents and Settings\Alice\Application Data\Mozilla\Firefox\Profiles\bb01pzj0.default. (There is also a MimeTypes.rdf file in the Firefox program folder, which you should not touch).

When I look in the plugins folder there is no npvlc.dll or npdsplay.dll.
The standard WMP plugin npdsplay.dll wouldn't be in the Firefox plugins folder; only the new WMP plugin (np-mswmp.dll ) is placed there (C:\Program Files\Mozilla Firefox\plugins by default). I would remove the npdsplay.dll file you copied to the Firefox plugins folder. The VLC plugin npvlc.dll used to be installed there, but current versions may place it in a central location now. Try a Windows search for npvlc.dll and see if it turns up and let me know if and where you find it. You can temporarily rename it Xnpvlc.dll to disable it.

P.S. I just noticed that you also said,
BTW, when I went to the site http://plugindoc.mozdev.org/testpages/wmp9.html I was greeted with the error message "Can not create DirectShow Player"
Did you try that test page with the new WMP plugin (np-mswmp.dll) installed in the Firefox plugins folder? If not then reinstall the new plugin and try again. If that WMP test page or the other test links at http://kb.mozillazine.org/Windows_Media_Player#Testing give you the same error even with the new WMP plugin, it could be a symptom of a problem with the Windows Media Player program itself. See:
http://kb.mozillazine.org/Windows_Media ... _Player.22
Alice Wyman

Zap250
 
Posts: 4
Joined: November 7th, 2007, 10:02 pm

Post Posted November 8th, 2007, 12:24 pm

Well I tried once again changing the three ASX file types entries in Firefox to open with VLC, which didn't help and actually caused those three entries to disappear.
Next I took your advice, went into the Options menu in Windows Media Player and set it as the default for ASF files. And now I can open ASX links in Firefox! Strangely enough those three entries for ASX are still missing. But it's working now, so I can't complain. Thanks again :)

Oh, that page http://plugindoc.mozdev.org/testpages/wmp9.html still gives me the same error, but my main problem has been solved so I'll just leave well enough alone for now...

Alice

User avatar
 
Posts: 2613
Joined: April 23rd, 2003, 11:47 am

Post Posted November 8th, 2007, 5:30 pm

On the the "Cannot create DirectShow" error on the embedded WMP test page, do you get the same error with the new Firefox plugin? If yes, then you might want to try reinstalling (or upgrading) Windows Media Player, You can also check this forum thread (linked from the WMP KB article I posted earlier) for other ideas or you could start a new topic.

In any case, I'm glad that your original problem was fixed by setting Windows Media Player as the system default for Windows Media (asf) files.
Alice Wyman

quentes
Guest
 

Post Posted December 20th, 2009, 3:03 pm

I had the same problem. Go to Tools (for the Germans it is Extras) -> Add-ons and disable the VLC Multimedia Plugin and the Windows Media Player Plug-in Dynamic Link Library. Of course you also have to go to Tools -> Options -> Applications (Extras -> Einstellungen -> Anwendungen for the Germans) and associate asx files to VLC. Now if you klick the link VLC opens and plays the stream. If you want to save the stream to file I recommend VLC version 0.8.6 using the streaming wizard in the file menu.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 10 guests