MozillaZine

latest Firefox update brings up Ask.com for any search

User Help for Mozilla Firefox
the-edmeister

User avatar
 
Posts: 32221
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted April 23rd, 2008, 10:45 pm

Road Runner is your problem, more than likely.
http://slashdot.org/article.pl?sid=08/02/26/1741253
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

Guest
Guest
 

Post Posted April 27th, 2008, 4:56 pm

I'm having a very similar problem, except that when I click on a search result, it goes to

www.cbcfind.com/*search topic*

I have version 2.0.0.14, and the ISP is comcast.net. I'm running Windows XP.

I just want to know how to get rid of this PITA. My virus scans don't pick it up.

Thanks, doc

Finklshtein
Guest
 

Post Posted June 7th, 2008, 1:18 pm

Your server made a deal with Ask.com and in return Ask.com redirects the server request. To solve, you first need to get a bunch of angry customers together and force your ISP to ADMIT they made the deal with ask.com. The all of the angry customers have to talk to the business department, as the tech dept will just avoid admitting the problem and try to put the blame on YOU. Your ISP needs to understand that being taken to a URL you did not request is an unfair business practice. Of course, you could just get a new ISP. Cable ISPs all over the nation began this practice in '08 and it's just tje latest stupid internet thing; they're going to sit there and see how people react while they cross their fingers that the new way to squeeze profit lasts awhile. Get people together and complain/threaten. It's a carp business strategy that screws the customer. Cable companies - what's new, eh?

s2_saha
Guest
 

Post Posted July 11th, 2008, 2:25 am

Anonymous wrote:Service Pack 2 I might add.
Directory Listing Denied----this show on web page whenever i have trie dto some webpages...like http://WWW.mail.nic.in

Guest
Guest
 

Post Posted October 2nd, 2008, 12:11 am

I'd like to comment why does it direct to the ask.com website even though I was able to use the site yesterday? It SOOO annoying. Please help!

1uqbgqcd
Guest
 

Post Posted October 28th, 2008, 6:56 am

hi fink - sorry mate but thats a load of shyte. The ISP has nothing to do with it. Just to make sure, I downloaded the google chrome browser and tried since I have the same problem. No ask search came up. Methinks its something to do with the browser and I'll figure it out shortly.

Grumpus

User avatar
 
Posts: 12229
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted October 28th, 2008, 7:10 am

I was having issues with the "AskJeeves" IP trying to access through the http port from time to time. I don't know whether it was trying to update the search engine or other but I blocked the IP range since I don't use Ask or AskJeeves for searches.
Mostly it seemed to be coming through Verizon Business IP in Hearndon Virginia.
The IP for Ask Jeeves is:
AskJeeves, Inc. UU-65-214-36 (NET-65-214-36-0-1)
65.214.36.0 - 65.214.39.255
The IP for the Prinmary is:
MCI Communications Services, Inc. d/b/a Verizon Business UUNET65 (NET-65-192-0-0-1)
65.192.0.0 - 65.223.255.255

However, even if you block these ranges there still may be some form of "site masking" which sends a signal which tries to get back to "Ask Jeeves" You need to find the incoming IP but that may be a site you need or want so you might not be able to fully block the range in and out.
It is really annoying and somewhat arrogant on the part of Verizon.
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

graysworld
 
Posts: 1
Joined: November 8th, 2008, 10:52 pm

Post Posted November 8th, 2008, 10:59 pm

I have the same problem. I have tried removing cookies, reinstalling, all without doing anything I still get redirected. Will I have to start using another browser? Please help me it is driving me nuts what a cheek high jacking peoples personal preferences

Graeme

arosieworld
Guest
 

Post Posted November 12th, 2008, 1:38 pm

I am having the same problem I have tried everything. My Internet Provider is WOW. I hate Ask and I want google back. I found a Ask toolbar in my add/remove files. its erased now but still no help.

roo1234
Guest
 

Post Posted November 13th, 2008, 7:30 pm

I have the same problem -- it is random, but consistent and redirects to ask.com Most Visited

slade1987
Guest
 

Post Posted November 18th, 2008, 7:29 am

any one figured out how to get ride of it yet??

FishyDave
Guest
 

Post Posted November 18th, 2008, 10:29 am

I have had exactly this problem, I think after installing some free FLI to MP4 transcoder software. It seems that it enables Firefox's 'keyword' functionality (if it isn't already enabled) and then hijacks the default setting (which does a Google search.)

To fix, put 'about:config' in the address bar to enter Firefox's configuration page (I don't think you can get at this from any of the menus.) Look out for The 'keyword.URL' setting, and change it back to one of the recommendations shown on this page http://kb.mozillazine.org/Keyword.URL

The first one worked for me. I now get a Google result instead of an Ask one if the webpage fails to load. If you don't want this functionality at all, then look for the 'keyword.enabled' setting and set it to 'false.'

Bruce.
Guest
 

Post Posted November 22nd, 2008, 1:41 pm

There are more than just the keyword.URL configuration keys that should be modified. in the about:config console, type "ask" to filter out the keys that have been modified by the ask.com toolbar. Also, easiest is just to right-click on the key and choose reset.

Guest
Guest
 

Post Posted November 22nd, 2008, 4:31 pm

I have a semi-similar problem. When I use my search bar [google, yahoo, any of them] it works fine and take me to the list of searches, HOWEVER, when I click on the link I want, a new tab is opened with a completely unrelated site. It will -not- open the link I want. I have to copy and paste the link into the URL bar to get it to work. Im using Firefox 3 if Im not mistaken.

Guest
Guest
 

Post Posted November 24th, 2008, 11:51 am

Search brings up Ask.com instead of Google

The answer is in the Advanced Firefox Settings.

My “right click” search [terms] was fine last night. It opened just fine in a new tab and searched via Google.
But this morning it went to Ask.com instead of Google.

So I did what I always do when I have a computer problem. I try to fix it myself and when I can’t, I call for my hubby [company computer guy – literally]!

I have pictures (PNGs) to go with the explanation of what to do so it’s easier to follow.

We did the usual routine checking of “tool options” [found nothing].
We then went to our control panel. We found and removed the “Ask Toolbar” from our Remove and Add Programs. Still, nothing.

Next we opened a new browser window, and into the address bar we typed, “about:config”
In short, once the list was brought up, we searched for anything with ASK [that refered to the ask.com site] or ask.com, removed it [modify] AND replaced it with Google.

Problem solved!

Directions:
Upon opening the list, you’ll see: Preference Name, Status, Type and Value.
Under “Preference Name”, search for: Keyword.URL
Under “Value” it will say, http://toolbar.ask.com/toolbarv/askRedi ... t=&gc=1&q=
Change that by right clicking on it and choosing “Modify”, and changing it to:
http://www.google.com/search?ie=UTF-8&oe=utf-8&q=

Before Pic: http://kd8cmv.us/change-aboutconfig_keyword1_found.png
After Modified: http://kd8cmv.us/change-aboutconfig_key ... hanged.png

Next, in the filter: type in “ask” and look for anything that says ask.com to bring up a smaller, more refined list.

Under “Preference Name” look for “extensions.snipit.chromeURL”.
It will show: http://toolbar.ask.com/toolbarv/askRedi ... t=&gc=1&q={sear...
Highlight it, and click “Reset”. This will erase the “Value”. Leave it blank. If it doesn’t, then click “Modify” to remove it manually, click “ok”.
(*note, after closing your about.config window, it will be totally removed from the list)

Before and After: http://kd8cmv.us/change-aboutconfig_key ... emoved.png

Next, in the filter, type in “browser” and under the “Preference Name” look for:
“Browser.search.defaultenginename”
For the “Value”, it will show ASK, “Modify” it so it says: Google

Pic: http://kd8cmv.us/change-aboutconfig_key ... odifed.png

Then under “Preference Name” find: “browser.search.order.1” and “Modify” it from ASK to Google

Pic: http://kd8cmv.us/change-aboutconfig_keyword8_modify.png

Finally, find: “browser.search.selectedEngine” and “Modify” it from ASK to Google

Pic: http://kd8cmv.us/change-aboutconfig_keyword9_modify.png

I hope this helps everyone.

KC8YCZ and KD8CMV

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 9 guests