MozillaZine


Firefox 3 logging out of sites even though I hit Remember Me

User Help for Mozilla Firefox
india3
Guest
 

Post Posted June 21st, 2008, 8:55 pm


barlow28
 
Posts: 14
Joined: January 29th, 2004, 8:27 pm
Location: Massachusetts

Post Posted June 22nd, 2008, 8:06 am

I uninstalled Tor Button and thus far I haven't had the problem yet... but it may be because I've now made a habit of just X'ing Firefox out instead of restarting.

Dave0
Guest
 

Post Posted June 22nd, 2008, 8:08 am

Hmmm, I just experimented with a workaround:

For all sites that you need to log into frequently,
1) go to tools/options/cookies. Choose Accept cookies/accept third party cookies and choose Keep Until: Ask me everytime
2) go to a website. When the warning box opens saying the site "wants to modify an existing cookie," choose allow and checkmark "use my choice for all cookies from this site". Log in and choose 'remember me'
3) Do this for all sites you log into often, then go back to tools/options and reset cookies to Keep until: they expire so you don't have to set cookies for every single website.
4) close firefox, and reopen. The sites should remember you now.

It's working for me (so far), I haven't had to relog into any sites this morning and I've quit/opened FF3 multiple times. Try it out and see if it works for you.

good luck!

erinreid
Guest
 

Post Posted June 23rd, 2008, 3:11 am

Well, I finally managed to solve my problem. I had this problem since Firefox 2, and it did not improve with FF3.

I shut down my browser and deleted both my cookies.txt and cookies.sqllite files, then restarted the browser. Worked like a charm. Apparently the files had gotten corrupted somehow, and session information was not being saved correctly. It took a complete purge to start again from scratch. (Note that cookies.txt is not used in FF3, but if you have one leftover from the upgrade, delete it too.)

Good luck, hope that helps.

- Erin

shortyuk87
Guest
 

Post Posted June 23rd, 2008, 12:57 pm

So do both of the above solutions work "permanently"?

shortyuk87
Guest
 

Post Posted June 23rd, 2008, 2:42 pm

I tried the workaround and it didn't work. And I couldn't find the cookies.sqllite file so I couldn't try that. Back to Firefox 2 again!

erinreid
Guest
 

Post Posted June 24th, 2008, 3:47 am

Yes, my fix is a permanent one, everything has been kosher for 48 hours and that's much longer than it's ever been before. The files are in Desktop/[User]/AppData/Roaming/Mozilla/Firefox/Profiles/[randomchars].default. Oh, and there's only one "l" in "cookies.sqlite", my apologies.

- Erin

Random_Dude
 
Posts: 1
Joined: June 24th, 2008, 5:27 am

Post Posted June 24th, 2008, 5:31 am

Just signed up to say thank you Erin!

Thought I would have to just put up with this problem, been using it since the first RC and had this problem.
And finally sorted it out today after hours of google-ing and asking friends.

You had the answer all along :P

Thanks alot.

Ryan.

shortyuk87
Guest
 

Post Posted June 24th, 2008, 11:23 pm

I still don't know how to find those files. Can you tell me where to look on my computer, because I think what you wrote is the path on your computer.

Iravanan

User avatar
 
Posts: 354
Joined: September 14th, 2005, 1:44 am
Location: Chennai - TAMILNADU - INDIA.

Post Posted June 25th, 2008, 1:12 am

»»Iravanan««… (‹ An End User ›);
•» Obviously my first language is not English but தமிழ்: (Tamil).«•
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Iron/0.2.152.0 Safari/14369976.525

shortyuk87
Guest
 

Post Posted June 25th, 2008, 8:36 am

YES, it worked. Thank you erinreid for the solution, and Iravanan for the help to find the files.

stainless-steve
Guest
 

Post Posted June 26th, 2008, 8:40 am

Hiya.
I had a similar problem whereby sites would say " please get your browser to except cookies " I had firefox 3 set up to allow cookies for all sites and it has been driving me mad.
I just REALISED THAT i HAD TRIED OUT THE NEW STEALTH MODE a few days ago,so just removed the tick from the checkbox and BINGO everything now works as it should.
HOPE THIS HELPS ONE OR TWO OF YOU WHO MIGHT HAVE DONE THE SAME THING.

cuki cuckoo
Guest
 

Post Posted June 26th, 2008, 8:54 am

Dave0 wrote:Hmmm, I just experimented with a workaround:

For all sites that you need to log into frequently,
1) go to tools/options/cookies. Choose Accept cookies/accept third party cookies and choose Keep Until: Ask me everytime
2) go to a website. When the warning box opens saying the site "wants to modify an existing cookie," choose allow and checkmark "use my choice for all cookies from this site". Log in and choose 'remember me'
3) Do this for all sites you log into often, then go back to tools/options and reset cookies to Keep until: they expire so you don't have to set cookies for every single website.
4) close firefox, and reopen. The sites should remember you now.
i don't call that a workaround
i call that finally learning how to use cookies properly (that's me a few days ago)

(step 3) I set it to Keep until [i close firefox]

sicgoe

User avatar
 
Posts: 14
Joined: October 25th, 2004, 7:20 am
Location: Goettingen, Planet Earth

Post Posted June 27th, 2008, 2:34 am

Hey,
stainless-steve wrote:I just REALISED THAT i HAD TRIED OUT THE NEW STEALTH MODE a few days ago,so just removed the tick from the checkbox and BINGO everything now works as it should.

Haven't heard of that mode, where to find that checkbox?

Thx

- Ulli -

Guest
Guest
 

Post Posted June 27th, 2008, 4:58 am

I've reverted back to version 2. Version 3 on vista ultimate with no plugins will lose cookies upon reloading. Tried uninstalling, manually deleting files. Nothing works.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 7 guests