MozillaZine

Firefox window resizing to full screen at launch

User Help for Mozilla Firefox
Phos....
 
Posts: 45
Joined: January 8th, 2005, 11:15 am

Post Posted June 21st, 2008, 10:52 am

This still indicates that there should be a way to tweak JUST the setting for the size of the browser window when it's opened.

I'm going to keep looking, but thanks for providing instructions for the wholesale reset, 2UD...

Phos....
 
Posts: 45
Joined: January 8th, 2005, 11:15 am

Post Posted June 22nd, 2008, 6:48 am

Well, I tried editing the file that controls browser window size and toolbar configuration at:
../Users/user_name/Library/Application Support/Firefox/Profiles/1234abcd.default/localstore.rdf

...but it didn't work for me. Maybe I just didn't edit the right part(s). So I ditched and reset it when I launched Firefox in "Safe Mode", as 2UD suggested, above. Yep, it killed a few of my toolbar prefs, but I keep them pretty minimal, so it wasn't a big deal. It did what I wanted primarily, and that was to stop browser windows from opening at full screen maximum.

A positive side-effect of the toolbar prefs reset was that it forced me to have a fresh look through the add-ons directory, which resulted in my finding a really good search bar, far better than Firefox's native search field.
Web Search Pro. This alone was worth the hassle.

Thanks to everyone here who kept this thread alive by participating, and to 2UD for ultimately providing the solution.

Egidio

User avatar
 
Posts: 2220
Joined: October 19th, 2007, 5:58 am
Location: Just a Mac user in Austin, TX

Post Posted June 22nd, 2008, 9:06 am

This is a very odd behavior. Something else is interfering with the window size at opening. It could be a corrupted plist file, an extension or something else. The way all browsers work on a Mac is that the window opens with the last size you had it. So, if you resize your browser window to the size you want and then close the browser, the next time you open a browser window, it will appear on the same location and with the same size as the last open window you had when you closed the browser.

Have you tried creating a new profile to see if things work normally?

.
Egídio
Mac OS X [10.6.4]

Phos....
 
Posts: 45
Joined: January 8th, 2005, 11:15 am

Post Posted June 22nd, 2008, 9:33 am

If you'll read the last half-dozen or so posts, Egidio, you'll see that we have already talked about the solution.

As for what causes the problem in the first place? That hasn't been figured out yet.

Egidio

User avatar
 
Posts: 2220
Joined: October 19th, 2007, 5:58 am
Location: Just a Mac user in Austin, TX

Post Posted June 22nd, 2008, 1:06 pm

I read all of the notes and do not see one addressing the creation of a new profile. I did see the one about the plist.

The only differences I see in your system is your OS version and the monitor.

.
Egídio
Mac OS X [10.6.4]

1potato
Guest
 

Post Posted June 23rd, 2008, 11:09 am

The following worked for me. See also SparkCollector's posts above.
On Mac OS Leopard 10.5.3:

0) Close Firefox 3.0

1) Go to the directory
~/Library/Application Support/Firefox/Profiles/blablabla.default

2) Copy the file localstore.rdf to my-safe-copy-of-localstore.rdf

3) Edit the file localstore.rdf. Find the place where the size of the "main-window"
is set. In my case, it was:

<RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"
width="1140"
height="963"
screenX="355"
screenY="22"
sizemode="normal" />

4) Remove the setting of "sizemode" so that it now reads:

<RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"
width="1140"
height="963"
screenX="355"
screenY="22" />

5) Relaunch Firefox 3.0

Phos....
 
Posts: 45
Joined: January 8th, 2005, 11:15 am

Post Posted June 23rd, 2008, 12:29 pm

Good on ya, 1potato! I'll be giving that a try, just for my own edification.

You'll have to forgive some of what I write. I'm a graphic artist who—while also a big fan of the left-brain pursuits—hasn't found the time to dig deeply into coding-n-stuff. I like it, and understand what I DO know about it, but my brain is predominantly wired for making pretty pictures.

:) :) :)

Egidio

User avatar
 
Posts: 2220
Joined: October 19th, 2007, 5:58 am
Location: Just a Mac user in Austin, TX

Post Posted June 23rd, 2008, 12:36 pm

SparkCollector wrote:... hasn't found the time to dig deeply into coding-n-stuff. I like it, and understand what I DO know about it, but my brain is predominantly wired for making pretty pictures.

:) :) :)



Heck, and after all, you're a Mac user! We're spoiled for not having to go deep into these coding-n-stuff. :lol:
Egídio
Mac OS X [10.6.4]

Phos....
 
Posts: 45
Joined: January 8th, 2005, 11:15 am

Post Posted June 23rd, 2008, 1:01 pm

Egidio wrote:Heck, and after all, you're a Mac user! We're spoiled for not having to go deep into these coding-n-stuff. :lol:


It sure would help me out to be more conversant with coding syntax in general, seeing as how I just agreed to build a giant website for a friend of mine. 8-[

Good thing I'm an info junkie, a strong researcher and a fast learner!

:mrgreen:

Avain
Guest
 

Post Posted August 2nd, 2008, 4:21 am

Y wrote:
2UD1YSNK wrote:I searched the web for this and found going into Firefox Safe Mode by choosing "option" when launching firefox and the choosing "Reset Toolbars and Controls" it fixed the resizing problem for me but also reset the toolbar which is a drag... I can't remember how I had the toolbar setup - doh!


Okay that works. Thanks a lot.

For other people, here is how it works (this is for mac os x only):

> Quit Firefox.
> Press option (alt) when launching FF3
> Choose "Reset Toolbars and controls" (caution don't click the others or you coud loose stuffs).
> Fix the size of window you want
> Relaunch Firefox, it opens the size you decided!


This solution worked for me, thanks very much to the folks who found and posted the fix :)

shmeeb
Guest
 

Post Posted October 28th, 2008, 1:11 pm

2UD1YSNK wrote:I searched the web for this and found going into Firefox Safe Mode by choosing "option" when launching firefox and the choosing "Reset Toolbars and Controls" it fixed the resizing problem for me but also reset the toolbar which is a drag... I can't remember how I had the toolbar setup - doh!



Thanks for this. It solved the problem for me. The question is....How the heck did I do it in the first place?

Guest
Guest
 

Post Posted November 3rd, 2008, 10:18 am

Anonymous wrote:
2UD1YSNK wrote:I searched the web for this and found going into Firefox Safe Mode by choosing "option" when launching firefox and the choosing "Reset Toolbars and Controls" it fixed the resizing problem for me but also reset the toolbar which is a drag... I can't remember how I had the toolbar setup - doh!


Okay that works. Thanks a lot.

For other people, here is how it works (this is for mac os x only):

> Quit Firefox.
> Press option (alt) when launching FF3
> Choose "Reset Toolbars and controls" (caution don't click the others or you coud loose stuffs).
> Fix the size of window you want
> Relaunch Firefox, it opens the size you decided!
Here's a late reply to this. I was trying to get my full screen FF to scale down too. Here 's what I did...
Go to menu WINDOW > ZOOM
This should stretch to fill the screen.
Do WINDOW > ZOOM again.
Resize the window to what you want by using the bottom-right-corner sizer.
Quit and restart FF to see if it worked.

Be nice if FF put a checkmark next to the ZOOM menu item when you're zoomed in.

Guest
Guest
 

Post Posted November 3rd, 2008, 10:20 am

[quoted txt deleted. not pertinent.]

GeroZ
 
Posts: 5
Joined: February 23rd, 2004, 2:34 am

Post Posted December 12th, 2008, 4:25 am

Y wrote:For other people, here is how it works (this is for mac os x only):

> Quit Firefox.
> Press option (alt) when launching FF3
> Choose "Reset Toolbars and controls" (caution don't click the others or you coud loose stuffs).
> Fix the size of window you want
> Relaunch Firefox, it opens the size you decided!


Yes - this really worked! On two Macs, that is.

I think, the first one developed this mis-behaviour from one day to another, I think after updating to FF 3.0.4. On the other one it might have been the same, or it might have been there before, deriving from migrating a Windows' FF's profile that was supposed to start in max size.

Anyway - this is a great relief, however I had to re-position the AdBlock Plus icon back in the button bar. Which is a small drawback compared to the pain I had to endure until today.

Thanks a lot, guys!

memymac
Guest
 

Post Posted January 20th, 2009, 7:47 am

Anonymous wrote:
2UD1YSNK wrote:I searched the web for this and found going into Firefox Safe Mode by choosing "option" when launching firefox and the choosing "Reset Toolbars and Controls" it fixed the resizing problem for me but also reset the toolbar which is a drag... I can't remember how I had the toolbar setup - doh!


Okay that works. Thanks a lot.

For other people, here is how it works (this is for mac os x only):

> Quit Firefox.
> Press option (alt) when launching FF3
> Choose "Reset Toolbars and controls" (caution don't click the others or you coud loose stuffs).
> Fix the size of window you want
> Relaunch Firefox, it opens the size you decided!
Awesome! That worked.. I was searching google for this and found tons of people complaining about how to cause full screen mode.. Sadly I wanted the inverse, hard to google for the inverse of something. :)

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot], L.A.R. Grizzly and 7 guests