MozillaZine


Macintosh won't sleep

User Help for Mozilla Firefox
Egidio

User avatar
 
Posts: 2220
Joined: October 19th, 2007, 5:58 am
Location: Just a Mac user in Austin, TX

Post Posted August 13th, 2008, 4:29 am

Very likely the problem is with the add-ons. You can also try to see if there are any extensions or themes that could be interfering with FF optimal performance. You can run FF without those extensions and themes by running it on Safe Mode. Note that there are two alternatives there. If the first does not work, try the second. First quit FF. Then open Terminal (Applications > Utilities > Terminal) and right after the prompt, just past the command line from the knowledge base article above. If you find out that FF performance improves and the problem you had is not present running Safe Mode, then you know one of the extensions or themes installed is causing the problems.

.
Egídio
Mac OS X [10.6.4]

frog_pilot
Guest
 

Post Posted August 13th, 2008, 1:12 pm

Egidio, many thanks for the safe mode hint. I will give it a shot. The suspend problem was caused by the TrackMeNot extension. With tmn deactivated my mac goes asleep as scheduled.

Egidio

User avatar
 
Posts: 2220
Joined: October 19th, 2007, 5:58 am
Location: Just a Mac user in Austin, TX

Post Posted August 13th, 2008, 7:09 pm

You're welcome. Well, since you've already found out the extension causing the problem, the Safe Mode is irrelevant now.
Egídio
Mac OS X [10.6.4]

sypie
Guest
 

Post Posted August 31st, 2008, 10:51 pm

Hello,

Also tested with the Sleep of my Mac and FireFox. Turned down all the extensions and plugins but the sleep never comes. Is there a solution for this issue or is it up to the programmers that they made a "not completely bug-free program"?

RobertJ
Moderator

User avatar
 
Posts: 10880
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted September 1st, 2008, 6:06 am

As a temporary work around you might try this

Bug Comment 53 wrote:------- Comment #53 From Rolf 2008-08-29 13:59:40 PDT -------

(In reply to comment #52)
> (In reply to comment #51)
> Also (as I said), I got different results depending on how long I set the
> computer to wait before putting the display to sleep and putting the computer
> to sleep.
Are you able to reproduce _those_ results?

Yes, I can reproduce them. Firefox running in the foreground.

Screen to black in minutes / Mac to sleep in minutes
8 / 10: Mac sleeps
10 / 15: Mac sleeps (my usual settings)

15 / 20: Sleep is delayed or killed (I only waited half an hour to observe it)
20 / 25: Sleep is delayed or killed (I only waited half an hour to observe it)



.
FF 92.0 - TB 78.13 - Mac OSX 10.13.6

klmnt
Guest
 

Post Posted November 2nd, 2008, 9:59 am

It a widespread bug of FF as it seems. I have the same issues after upgrading to the latest 2.x FF (2.0.0.17) and it bugs me a lot. However it seems no one at FF cares about it.
PC does not go to sleep with FF is running. No matter what web site etc.

RobertJ
Moderator

User avatar
 
Posts: 10880
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted November 2nd, 2008, 10:44 am

klmnt wrote: However it seems no one at FF cares about it.
PC does not go to sleep with FF is running. No matter what web site etc.


It is a reported bug and is being worked on. In the meantime the work around is to set your Screen to black and Mac to sleep settings as shown in green above (in the energy saver preferences pane).

All that have used those settings have reported success.

.
FF 92.0 - TB 78.13 - Mac OSX 10.13.6

solved
Guest
 

Post Posted December 7th, 2008, 7:24 am


Guest
Guest
 

Post Posted March 29th, 2009, 5:57 pm

There's a bug in Firefox's database that covers this. They don't seem to be taking it seriously.

https://bugzilla.mozilla.org/show_bug.cgi?id=479001

Guest
Guest
 

Post Posted November 22nd, 2009, 11:10 am

wasDigi wrote:Hi,

After install Firefox 3 my Macintosh (Intel 10.5.3) won't go to sleep when the program is running! What can I do? Can someone has the same problem??

Thank's,
André

I’m having the same problem. It also happens with Camino 2.0. With me the Mac goes to sleep 30+ seconds after selecting sleep from the Apple menu.

RobertJ
Moderator

User avatar
 
Posts: 10880
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted November 22nd, 2009, 11:54 am

From my post above this seems to solve the problem

Bug Comment 53 wrote:
------- Comment #53 From Rolf 2008-08-29 13:59:40 PDT ------- wrote:

Set Mac sleep settings to:

Screen to black in minutes / Mac to sleep in minutes
8 / 10: Mac sleeps
10 / 15: Mac sleeps (my usual settings)


My wife has her setting to 10/15 and has no problem on her G4 with 10.5.8 and FF 3.5.5

EDIT: If this doesn't fix the problem start a new thread (I'm locking this one since it's over 1 year old and there may be new information).
FF 92.0 - TB 78.13 - Mac OSX 10.13.6

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 8 guests