MozillaZine

Firefox prevented this page from automatically redirecting t

User Help for Mozilla Firefox
lurks_a_lot
 
Posts: 23
Joined: May 3rd, 2006, 8:08 am

Post Posted July 13th, 2008, 7:50 am

I have Firefox 3 on a new Vista laptop. I get the above message whenever I open a new tab and type a url in the address bar. When I click the Allow box the page opens, but it is very annoying. I have searched options but cannot find a way of getting rid of that message.
Also how do I stop the dropdown menu appearing when I start to type in the address bar?
Should appreciate any help. Many thanks. :?

kindofabuzz

User avatar
 
Posts: 3859
Joined: July 20th, 2003, 1:13 am
Location: Memphis, TN

Post Posted July 13th, 2008, 7:55 am

Advanced, General tab, Accessibility, "Warn me when web sites redirect or try to reload the page". Do you have that
checked?
Collapse unwanted MozillaZine forum sections ** Give a man a fish and he will eat for a day; teach a man to fish and he will eat for a lifetime; give a man religion and he will die praying for a fish.

lurks_a_lot
 
Posts: 23
Joined: May 3rd, 2006, 8:08 am

Post Posted July 13th, 2008, 8:11 am

kindofabuzz wrote:Advanced, General tab, Accessibility, "Warn me when web sites redirect or try to reload the page". Do you have that
checked?

Brilliant - thats sorted it. Thank you so much =D> =D> =D>

Guest
Guest
 

Post Posted July 13th, 2008, 10:01 am

Thank you so much! I just couldn't find it!...?

VanillaMozilla
 
Posts: 13799
Joined: November 7th, 2005, 11:26 am

Post Posted July 13th, 2008, 11:56 am

Are you sure about this? If you get a warning, turning it off does not solve the problem.

Oddly, that was unchecked on my system too, but turning it on does not cause warnings to pop up. As it turns out, I'm not 100% sure of what that warning is about, but don't you think it would be a good idea to find out?

kindofabuzz

User avatar
 
Posts: 3859
Joined: July 20th, 2003, 1:13 am
Location: Memphis, TN

Post Posted July 13th, 2008, 12:07 pm

Taken from http://www.tweakguides.com/Firefox_5.html "

Warn me when web sites try to redirect or reload the page: New to Firefox 3, this option has been added to prevent sites which try to automatically redirect or reload the page without your permission. If that happens, a prompt will appear at the top of the screen indicating what has occurred and asks you whether you wish to allow this behavior or not. It is worth ticking this option to maintain greater control over your browsing, but it may get annoying as it also comes up on legitimate sites which reload/redirect. Note that if you manually want to force refresh a web page at any time, press CTRL+F5.


edit: for instance, after I turned mine back on, I posted this. And you know how after you post something, it auto takes you back to your message? well with the option on, it stopped it from redirecting me back, and popped up the warning. It would be safer browsing leaving it on, but would get very annoying after awhile. there are no whitelists for it i don't think. well at least no option in the warning popup.
Collapse unwanted MozillaZine forum sections ** Give a man a fish and he will eat for a day; teach a man to fish and he will eat for a lifetime; give a man religion and he will die praying for a fish.

VanillaMozilla
 
Posts: 13799
Joined: November 7th, 2005, 11:26 am

Post Posted July 13th, 2008, 1:31 pm

OK, no wonder it's disabled by default. The warning sounds more important than it seems to be. On the other hand, the OP wrote "whenever I open a new tab and type a url in the address bar" (emphasis added). To me that means all the time, but I couldn't get it to happen at all. If it really is all or most of the time, I still smell a rat.

lurks_a_lot
 
Posts: 23
Joined: May 3rd, 2006, 8:08 am

Post Posted July 14th, 2008, 7:34 am

I'm the OP and have been interested in the discussion. I turned the feature back on just to test it out and have not received the message once when opening new sites. Yesterday I installed Vista SP1 on my new laptop and wonder if this has anything to do with it. Anyway, I think it is a useful layer of protection which I will keep on for the present.
Thanks to all for discussion. :wink:

jeffz8user
Guest
 

Post Posted July 15th, 2008, 4:42 pm

Firefox 3 was giving me this message when I accessed my own Website (which I built with iWeb) so I decided to investigate. The home page of my Website was called home.html but I found that I also had a page called index.html which contained only a simple redirection (refresh) to the home.html page. I believe that a Website can contain an entry page called either home or index so I removed the index.html page and now the Website works fine, going directly to the home.html page and no longer causing the "Firefox prevented..." message.

lurks_a_lot
 
Posts: 23
Joined: May 3rd, 2006, 8:08 am

Post Posted July 16th, 2008, 8:17 am

lurks_a_lot wrote:I'm the OP and have been interested in the discussion. I turned the feature back on just to test it out and have not received the message once when opening new sites. Yesterday I installed Vista SP1 on my new laptop and wonder if this has anything to do with it. Anyway, I think it is a useful layer of protection which I will keep on for the present.
Thanks to all for discussion. :wink:


Well its off again because It started turning up again on nearly page :x

JarC
Guest
 

Post Posted August 10th, 2008, 4:33 am

Well, I think it's a dumb setting...why treat autorefresh and redirects the same? they ain't

gobigreenwood
Guest
 

Post Posted August 22nd, 2008, 6:02 am

Dear OP,

A suggestion...

How about separating the warnings.
Isn't Re-loading the same-url different than redirecting to a different-url ?

This feature is very annoying whenever a page is simply reloading (and I have to deal with it more than 50 times daily - a real pain if the page is simply reloading the same url)

but I desire to have notifications whenever a page is actually redirecting...

Regards!

Rooker
Guest
 

Post Posted August 22nd, 2008, 11:46 am

I'm glad they added this feature. It used to annoy the pure hell out of me having a bunch of news sites in the background while I read something else and they all constantly refreshed for absolutely no reason.

I'm surprised they STILL do this. Seems like a fraudulent way to milk money from advertisers by generating fake page views.

ankhatmac
Guest
 

Post Posted September 11th, 2008, 9:17 am

Arrrrrrghhhhhh -- so it's a feature, not a bug?
I was hoping for a way to whitelist this for the one site where it happens over and over, my webmail provider's Inbox page.
No?
No.
Drat.

dickvl

User avatar
 
Posts: 51410
Joined: July 18th, 2005, 3:25 am

Post Posted September 11th, 2008, 7:30 pm

It is one of the accessibility features of Firefox:
Accessibility.blockautorefresh (MozillaZine KB)

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot], RobertJ and 30 guests