MozillaZine

Multiple windows from outside links (Thunderbird, etc)

User Help for Mozilla Firefox
CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 17th, 2004, 7:50 am

Anonymous wrote:I tried using the reg edit file, but links from other programs such as eprompter, copernic still open in a different window, not the same tab/window that I have opened.


These .reg files do not fix this, just the multiple windows and error problems. This may have been a change in the new build (to not reuse active windows). I do remember some debate as to whether or not reusing windows was desirable. If you check out the bug on bugtraq, I'm sure someone will answer it there.

Also, there is an extension that lets you select how Firefox handles links from external programs. Can't recall what it is at the moment, though. It even allows you to have it open them in a new tab.

MDesigner
 
Posts: 123
Joined: January 28th, 2003, 4:10 pm

Post Posted June 17th, 2004, 8:33 am

This fix works great for WinXP, but what about Win2000? When I do Start->Run, and type a URL, Firefox opens but I also get an error. Also, when I click links from emails, Firefox opens, but Outlook tries to save the link to disk.

There is no "HyperText Transfer Protocol" entry in the file types for Win2K. At least not for my installation.. (my computer may be messed up).

CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 17th, 2004, 9:21 am

MDesigner wrote:This fix works great for WinXP, but what about Win2000? When I do Start->Run, and type a URL, Firefox opens but I also get an error. Also, when I click links from emails, Firefox opens, but Outlook tries to save the link to disk.

There is no "HyperText Transfer Protocol" entry in the file types for Win2K. At least not for my installation.. (my computer may be messed up).


Which fix are you talking about? The manual fix, or the .REG file?

Kaleva

User avatar
 
Posts: 57
Joined: December 26th, 2003, 1:02 pm
Location: Los Angeles, CA

Post Posted June 17th, 2004, 12:46 pm

CritterNYC wrote:Looks like their may be a problem with the way Firefox registers itself to handle urls in Windows or an issue with DDE messaging. A workaround for now...


I was experiencing the same/similar problem after installing 0.9 on Windows XP, with Firefox as my default browser. Shortcuts on the desktop, or from the Start -> Favorites menu, opened in Firefox, then windows reported an error "Windows cannot find [URL]".

The workaround solved it for now, thanks CritterNYC.

FeliceMente

User avatar
 
Posts: 82
Joined: June 18th, 2004, 5:23 am
Location: Italy

Post Posted June 18th, 2004, 2:11 pm

CritterNYC wrote:7. Clear the DDE message box (which should contain "%1")


Unckecking the "Use DDE" checkbox is simpler, and gives the same result.

tevetorbes

User avatar
 
Posts: 585
Joined: March 28th, 2003, 9:58 pm

Post Posted June 18th, 2004, 4:07 pm

Are there any threads pertaining to linux and this behavior? Because I am having similar problems, but not on windows.

Point me in the right direction, if there is one, somebody! Thanks :)

melriffe
 
Posts: 6
Joined: June 18th, 2004, 1:31 pm

Post Posted June 18th, 2004, 4:47 pm

I just wanted to say thanks for the information posted here. I was experiencing the same problems until I got the solution here. Thanks, again...

-Mel

Halcyon
 
Posts: 8
Joined: November 22nd, 2003, 4:50 pm

Post Posted June 18th, 2004, 9:04 pm

Thanks a lot, Critter!
You saved my day / weekend!

zekester
Guest
 

Post Posted June 20th, 2004, 9:37 pm

>Rather than remove "%1",,-1,0,,,,
>I just unticked the - "Use DDE" Box for the "URL:HyperText Transfer Protocol". That seems to do the job. >All ok for now.

I tried this workaround, it worked for me as well.
Lo0oks like this is the fix - at least for the moment.

Metrox
Guest
 

Post Posted June 20th, 2004, 11:04 pm

I've had the same problem, and none of the solutions proposed here helped. But when I upgraded my Thunderbird to .7 the problem went away - strange, but nice!!

dineshpandian
 
Posts: 1
Joined: June 21st, 2004, 3:30 am

Post Posted June 21st, 2004, 3:32 am

whoa~ had the same problem ..
problem arised soon after upgrading from 0.9 rc to 0.9 final.
thought i had messed up some settings and even did a reformat of my laptop.
problem still persisted..thank google i found you guys!
clearing the dde box solved it. thanks guys!

bran

User avatar
 
Posts: 15
Joined: June 17th, 2004, 7:33 pm
Location: Canada

Post Posted June 22nd, 2004, 8:10 am

CritterNYC wrote:Looks like their may be a problem with the way Firefox registers itself to handle urls in Windows or an issue with DDE messaging. A workaround for now:

1. Open Explorer
2. Select Tools and then Folder Options
3. Select the File Types tab
4. Select Extension: (NONE), File Type: HyperText Transfer Protocol
5. Click Advanced toward the bottom of the window
6. In the Edit File Type window, select open and click Edit
7. Clear the DDE message box (which should contain "%1")
8. Click OK, Click OK
9. Repeat for File Type: HyperText Transfer Protocol with Privacy


Do you know of a fix for Win98SE besides installing XP?
.
bran

"The Universe is run by the complex interweaving of three elements: energy, matter and enlightened self-interest."

Xac
Guest
 

Post Posted June 22nd, 2004, 8:26 am

the DDE support in 0.9 is broken
URL types simply opened in a new window (or tab if you have that extension thingy)

prior versions open the links in the last active window/tab

ps. I prefer the old theme :P

Guest
Guest
 

Post Posted June 23rd, 2004, 11:57 am

Same problems here, same solution fixed it. Thanks.

CritterNYC
 
Posts: 970
Joined: August 27th, 2003, 12:27 am
Location: Astoria, NY

Post Posted June 23rd, 2004, 10:31 pm

bran wrote:Do you know of a fix for Win98SE besides installing XP?


Did you try the .REG file?
http://johnhaller.com/jh/mozilla/firefox_bug_246078.asp

Return to Firefox Support


Who is online

Users browsing this forum: AlbertRoss, Google [Bot], Google Adsense [Bot] and 28 guests