MozillaZine

Facebook says cookies not enabled while trying to login

User Help for Mozilla Firefox
facelift1
Guest
 

Post Posted October 3rd, 2008, 9:02 am

Hi,
Yesterday, I noticed that when I try to login to Facebook, it reports an error and says that my browser is not set to allow cookies. I know that it is though. I double checked.
If I try to log in a second time, it always works...

The ONLY thing I have done differently yesterday was try to update my windows xp with microsoft update. When I went there, it's page said it needed me to download something before I could get the updates..so I did. And everything worked OK...until I tried going onto facebook.

Is there a simple fix for this? Or is it a bug that has to be worked out?

Any help would be very appreciated!

Kelly

allisaw
Guest
 

Post Posted October 3rd, 2008, 9:47 am

when you startup Firefox
before you go to Facebook, click Tools
options
Privacy tab
[ show cookies ]
    ( do you see any Facebook cookies ? )

facelift
 
Posts: 1
Joined: October 3rd, 2008, 8:55 am

Post Posted October 3rd, 2008, 10:26 am

Hi,

No, it does not show any facebook cookies. No folder at all for Facebook.

Any ideas?

famos amos
Guest
 

Post Posted October 3rd, 2008, 11:16 am

. . . .
Firefox 3 cookies
  1. Set cookies settings to
    Cookies
      Keep until: [ ask me every time ]
  2. Visit all your sites for which you want to set Allow type cookies;
    for each site, select
      [] Use my choice for all cookies from this site, and
      [ Allow ]
  3. After you have set ALL your Allow type cookies, reset cookies settings to
    Cookies
      Keep until: [ I close Firefox ]


In Privacy Data [ Settings ], uncheck [ . .] Cookies.

facelift1
Guest
 

Post Posted October 3rd, 2008, 11:47 am

Very weird,

I tried doing exactly what you said, and when I did #2 (visit all the sites to allow cookies, I did that for them all except when I tried Facebook, that option didn't even come up...There was nothing to check to allow it.
It just came up with the saying "your browser is not set for cookies and to enable them. When I try to log into facebook the second time, like always, it will then let me login....

Very strange.

try this
Guest
 

Post Posted October 3rd, 2008, 12:17 pm

Tools
options
Privacy tab
[ Exceptions ] button
Address of web site:
[ facebook.com ]
    [ Allow ]
    [Close]

( remember to unCheck cookies in Clear Private Data )

facelift1
Guest
 

Post Posted October 3rd, 2008, 1:17 pm

No, that doesn't work either. It should. I made sure to uncheck the cookies from clear private data when ending my session but obviously they are still being deleted.

Could the windows update from microsoft have done something that it shouldn't have?
I remember now that it wanted activex installed so that I could get the xp updates. I've always been able to get them with firefox before though.

Thank you everyone so far for all your help.
This one is puzzling.

Guest
Guest
 

Post Posted October 4th, 2008, 10:02 am

I'm having the same trouble, except trying twice didn't help. The only thing is to accept each cookie as asked (time consuming), until it stops asking and lets me in, then log out. Then I reset to accept all cookies, and then it worked normall. But when I rebooted FF, same thing. I'll be doing IE for FB from now on. Didn't have the problem at all.

--Dan

ergo
Guest
 

Post Posted October 4th, 2008, 10:49 am

if I go to facebook with FF3 it says I need to enable Javascript (it is enabled).
if I go to facebook with FF2 there is no malarkey

mzfuser
Folder@Home
 
Posts: 1886
Joined: August 15th, 2004, 10:21 pm

Post Posted October 4th, 2008, 12:43 pm

To those having problems with cookies, try deleting the cookies.sqlite file from your Firefox profile.

smschafer
Guest
 

Post Posted October 16th, 2008, 6:25 am

What, that totally worked.

squirrelcage
Guest
 

Post Posted November 8th, 2008, 1:27 pm

I am about at my wits end. I have experienced the same problems listed above with both Firefox and IE7. Incompatible web browser. But yet it works with NETSCAPE. Someone please help this uninformed amature gain access to FB!!

LoudNoise
Moderator

User avatar
 
Posts: 38575
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted November 8th, 2008, 1:34 pm

Squirrelcage- You are not showing a user agent so facebook is confused. For firefox:

In the address bar, type about:config
Filter for general.useragent
Single right click on each result, click on Reset.
Post wrangler
Notice: If you have a comment on moderation, please post here viewtopic.php?f=11&t=2706389 and don't private message a mod. I don't reply to private messages unless I have previously requested them

dickvl

User avatar
 
Posts: 51410
Joined: July 18th, 2005, 3:25 am

Post Posted November 8th, 2008, 1:51 pm

What is your user agent?
You check what websites see http://gemal.dk/browserspy/basic.html
You can compare that with the user agent as shown at bottom of the Help > About window.

ducks09
Guest
 

Post Posted September 3rd, 2009, 4:20 am

Try updating Java.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 25 guests