MozillaZine

Can't open Firefox under Sandboxie

User Help for Mozilla Firefox
estesjr
 
Posts: 11
Joined: June 5th, 2006, 12:24 pm

Post Posted November 16th, 2008, 10:18 pm

ON ONE USER ACCOUNT ONLY, I can't run Firefox under Sandboxie. I get an XULRunner Error: "Platform version '1.9.0.4' is not compatible with minVersion >= 1.9.0.1 maxVersion <= 1.9.0.1." On all other user accounts, Firefox runs perfectly under Sandboxie. I have uninstalled and reinstalled Sandboxie, but it doesn't help. I have tried to modify the Firefox "application.ini file where it says: "[Gecko]MinVersion=1.9.0MaxVersion=1.9.0.4[XRE]"
And that, of course, didn't help because Firefox runs under Sandboxie on other user desktops using this same file. I reinstalled Firefox version 3.0.3 over version 3.0.4, and it didn't help. Before I completely remove and reinstall Firefox, I hope someone may have a solution so that I don't have to do this and have to set up Firefox again on all user accounts. Thank you.
John Estes

Anonymous2044
Guest
 

Post Posted March 14th, 2009, 5:12 pm

I am having a similar problem.It all happened yesterday when I manually deleted a Microsoft Steady State installation.I tried toying around a while with some user profile restrictions ,and they appeared as customized.I am sure that I hit the no restrictions button;also I went into the MMC and disabled some steady state services.Later I turned them on to try to enable WDP but it would appear as off in the SS UI, even though I rebooted to turn on SS.I also got a problem trying to uninstall it which is why i manually deleted the service keys, folders, and changed a GUID key.The reason why I had to change the GUID's "Lower Filter\VFC" was because I ended up with exclamation marks in my generic volume drives.In addition to this,I had to manually go to a software restrictions policy key and delete it and just leave one backed up because I could not run any defrag programs.I researched I found this was because the cache file SS creates, I understood something like "disk would then not need defragmention".But anyway, i am having the same problem as you not only with firefox, but with some other programs.The weird thing in my case is that some programs do launch like IE MSPaint notepad etc;. I would apreciate any suggestion as to a soultion thanks.

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted March 14th, 2009, 5:15 pm

See this thread: viewtopic.php?f=38&t=1134005&hilit=sandboxie
there was mention about an update to Sandboxie that as I recall fixed the problem...

Anonymous2044
Guest
 

Post Posted March 14th, 2009, 6:39 pm

Thanks for the help, but I read the thread,I have Firefox 3.0.0.7, I have sandboxie 3.34, and it all used to work wonderfully together, until the windows steadystate policies refused to completly revert automatically.

I also tried to reinstall StdyState but, it could not reinstall.Therefore I will try to keep it off my system, because it really screws around with ACL's on certain folders is my guess.Maybe I need to reboot into safemode and right click firefox's folder and take ownership of it or something?

Maybe there are some other registry entries to prevent one process to prevent one process from starting another?

steviex
Moderator

User avatar
 
Posts: 28902
Joined: August 12th, 2006, 8:27 am
Location: Middle England

Post Posted March 14th, 2009, 6:50 pm

Have you been to the Steadystate Support site ? http://www.microsoft.com/windows/produc ... fault.mspx

If it is a problem with a remnant of their software, or a configuration that is still wrong, they should be able to give you advice on how to remove all traces of their program, and tell you how to revert your system back to the state it was before you installed their software...

As this is not really a Firefox problem, it should really be in the Tech Forum. However, you need to be registered to post there.
Please register, and I will move this thread over..
Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -Albert Einstein

Please DO NOT PM me for support... Lets keep it on the board, so we can all learn.

Anonymous2044
Guest
 

Post Posted March 14th, 2009, 7:33 pm

OK guys... I got firefox to launch. It was a sandboxie settings issue.

I found that if I right click the yellow sandboxie icon in the system tray, click "Show Window" at the top of the dialouge box, click "sandbox", highlight "defaultbox" , manuveur to the right and click "sandbox settings", then click the plus sign on the left in the treeview, and scroll down to the third option that reads "Drop Rights" then uncheck the green checkmark , next to and on the left of where it says "Drop rights from Adminstrators and Power Users groups" I could then launch the Firefox v3.0.7 browser. This solved my
problem of not being able to launch firefox in sandboxie. I hope it helps anyone that has been having the same issue. Thanks alot , and BEST OF LUCK!!! for everyone that left me some suggestions!! ; )

Return to Firefox Support


Who is online

Users browsing this forum: Daifne, dfoulkes, Diane Vigil, Google [Bot], Google Adsense [Bot], LIMPET235 and 28 guests