MozillaZine

Firefox won't clear history

User Help for Mozilla Firefox
gosc
Guest
 

Post Posted August 18th, 2009, 4:22 am

Same problem here. Location bar is set to history. History was deleted. There is nothing in "show all history", but is still in location bar. Fix it finally.

yadayada56vincent
Guest
 

Post Posted August 31st, 2009, 3:12 pm

This worked for me with FFox 3.5.2. Open Tools > Options and select Privacy Tab. Set "Firefox will" to never remember history, then set "when using location bar, suggest" set to history. Click the "clear all history" link and then Close All Instances of Firefox! I reopened and after my "home page" loaded I did the following: set to Use custom settings for history, uncheck anything you don't like, (I unchecked third party cookies and remember search and form history), I finally verified that it would only remember history, not bookmarks in the address bar. Did the Ok and it worked.

localdog
Guest
 

Post Posted September 21st, 2009, 9:04 am

yadayada56vincent wrote:This worked for me with FFox 3.5.2. Open Tools > Options and select Privacy Tab. Set "Firefox will" to never remember history, then set "when using location bar, suggest" set to history. Click the "clear all history" link and then Close All Instances of Firefox! I reopened and after my "home page" loaded I did the following: set to Use custom settings for history, uncheck anything you don't like, (I unchecked third party cookies and remember search and form history), I finally verified that it would only remember history, not bookmarks in the address bar. Did the Ok and it worked.


That sounds like the hard way of doing something that should be very easy. Over a year and they still haven't fixed this problem? Ridiculous. When I hit the "clear recent history" button (and yes, I clear everything) I expect it to clear the recent history. Fix this already, don't make me have to dump FF and go back to *ugh* IE...

ralphk2004
 
Posts: 2
Joined: October 21st, 2009, 5:48 am

Post Posted October 21st, 2009, 6:05 am

Sorry for being late, I discovered this thread only now.

The solution for this is a little complex, but it is managable: Firefox stores the URL history in an embedded SQLite database (see http://www.sqlite.org/ for more information). The database file containing the URL history is located in the Firefox profile, its name is places.sqlite. This database can be managed using a tool named sqlite3 (see http://www.sqlite.org/sqlite.html for downloads and documentation). It can be downloaded as source code or precompiled for various platforms.

After getting sqlite3 to work, go to the command line (teminal on Linux, "Command Prompt" on Windows"), navigate to the profile directory of Firefox and issue the following commands (example from Windows):

C:\Documents and Settings\myuser\Application Data\Mozilla\Firefox\Profiles\dnvv1b03.default>D:\install\SQLite\sqlite3 places.sqlite
SQLite version 3.6.19
Enter ".help" for instructions
Enter SQL statements terminated with a ";"
sqlite> delete from moz_places;
sqlite> ^C

(The last command is Ctrl-C) And you are done. Two warnings: First, this is final, the previous contents can't be recovered. So if you want to be able to get the history back, you can make a copy of the file places.sqlite. Second, you should be sure that you are in the right Firefox profile, as Firefox allows to create several profiles under the same operating system user account.

Hope this helps!

Kind regards,
Ralph

ralphk2004
 
Posts: 2
Joined: October 21st, 2009, 5:48 am

Post Posted October 22nd, 2009, 8:14 am

Unwanted side effect: The bookmarks are still there, but trying to add a new one reveals that the structure seems to be gone. So I can't organise my bookmarks, as the "organise bookmarks" dialog is empty. Forget my previous post, that side effect isn't worth it.

Does anyone of the Firefox developers consider cleaning the URL history as an unnecessary luxury? Or what is the reason that version 3 is out for so long with this problem not getting fixed?

Kind regards,
Ralph

Anonymosity
 
Posts: 8162
Joined: May 7th, 2007, 12:07 pm

Post Posted October 23rd, 2009, 11:46 am

Ralphk, if you switch to Firefox 3.5.*, you will find that the setup for the location bar works much better. If you want to limit it to history only, it will do that. If you want the manual entries in the address bar to clear, all you need to do is clear the history.

dickvl

User avatar
 
Posts: 51469
Joined: July 18th, 2005, 3:25 am

Post Posted October 23rd, 2009, 2:49 pm


peacenucca
Guest
 

Post Posted December 1st, 2009, 10:15 pm

go to the tool bar history(where you type websites in)
run your mouse over what you want deleted but dont click on it obviously just make sure its highlighted and press...

shift+windows+delete for pc

shift+apple+delete for mac

a viola problem solved

Sirtemp
Guest
 

Post Posted December 28th, 2009, 1:10 pm

Just downloaded 3.6, and even with this download I cannot delete 'web history', if I have this listed: posting.php?mode=reply&f=38&t=956855 and theirs a STAR afterwords no matter what the I do, I open the top browser link and the thing is still there... I've been using software since 1993... so the question needs to be asked: Why the are you programmers to as to not allow someone to DELETE where you have been?



Oh, and by the way, I've gone over every post regarding how to delete, smash, this software to delete and it doesn't WORK!
Last edited by LoudNoise on December 28th, 2009, 2:20 pm, edited 2 times in total.
Reason: Language edits.

LoudNoise
Moderator

User avatar
 
Posts: 38888
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted December 28th, 2009, 2:23 pm

Watch the language if you wish to hang around. If the star is gold it means that it is a bookmark and not history. Also, you are using an old version of Firefox. You should at least update to the current 3.0.x (.20 I think) version.
Post wrangler
"If you lock this, the Pentium IIs win." - anonymous

dickvl

User avatar
 
Posts: 51469
Joined: July 18th, 2005, 3:25 am

Post Posted December 28th, 2009, 4:30 pm

Firefox 3.0.16 is the most recent Firefox 3.0.x version (2.0.0.20 was the latest Fx 2 version), so S. is up to date for that branch.

If a website is bookmarked (has a yellow star) then you can click the yellow star in the location bar to open the 'Edit This Bookmark' dialog and click the remove button to delete that bookmark or move it to another folder if you wish to keep it.

See also:
http://support.mozilla.com/kb/Clearing+ ... ar+history
http://support.mozilla.com/kb/Cannot+cl ... ar+history

LoudNoise
Moderator

User avatar
 
Posts: 38888
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted December 28th, 2009, 4:32 pm

Thanks dickvl.
Post wrangler
"If you lock this, the Pentium IIs win." - anonymous

A user :/
Guest
 

Post Posted December 30th, 2009, 5:16 pm

LoudNoise wrote:Thanks dickvl.
LoudNoise, no offence but you misunderstand. We aren't stupid, we no the difference between a bookmark and history. The problem here is that 'clear recent history' or going to the history tab or sidebar, selcting all and clicking delte does nothing whatsoever

peaceforce
Guest
 

Post Posted January 1st, 2010, 7:55 am

Do this it worked for me :)

To not show bookmarks in the Smart Location Bar (Address Bar) drop down, you need to make an 'about:config' change as follows:
Type: about:config
in you address bar and click 'ok' to the warning to be careful
Now scroll down to the following exact entry:

browser.urlbar.maxRichResults to 0 in about:config and then restart the browser.

dickvl

User avatar
 
Posts: 51469
Joined: July 18th, 2005, 3:25 am

Post Posted January 1st, 2010, 11:00 am

That only hides the location bar drop down list.
The list will reappear as soon as you set that pref to a positive value (setting the location bar behavior to nothing would be the proper way in 3.5).

See also http://kb.mozillazine.org/Locked_or_dam ... ces.sqlite

Return to Firefox Support


Who is online

Users browsing this forum: Alexa [Bot], Bing [Bot], Google Adsense [Bot], redwolfe_98 and 19 guests