MozillaZine

firefox does not connect to internet properly

User Help for Mozilla Firefox
toolman_fixit
 
Posts: 36
Joined: November 27th, 2006, 11:51 am

Post Posted December 4th, 2008, 10:05 pm

i have internet explorer as a backup and it works fine. in firefox under tools - options/advanced/network/connection/settings. Manual proxy setting is checked and i can not access the internet. I can un check and check no proxy or auto check proxys for this network and i can then access the internet BUT whenever i close firefox and try to go back into firefox to access the internet the same thing happens - it resets itself to manual proxy everytime and i then can not access the internet unless i go through the whole thing again. how do i get it to stay on no proxy or auto detect ???????????????????????????

toolman_fixit
 
Posts: 36
Joined: November 27th, 2006, 11:51 am

Post Posted December 4th, 2008, 10:06 pm

using firefox 3 - 3.04

the-edmeister

User avatar
 
Posts: 31116
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted December 5th, 2008, 1:27 am

You might have a preference that is resetting the manual proxy. Hotel connections sometimes make that change by way of a user.js file which will reset your settings every time Firefox is started.
http://kb.mozillazine.org/User.js_file
http://kb.mozillazine.org/Profile_folde ... ile_folder


.
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

toolman_fixit
 
Posts: 36
Joined: November 27th, 2006, 11:51 am

Post Posted December 5th, 2008, 9:23 pm

i went into user.js file and it basically said you should not edit it from there but to edit it from " about:config " but all i can do there is wipe out the proxy address and port number. i can not change the check in the box from manual proxy to no proxy in about config. this is really starting to be bullshit because i never changed anything. i tried to update a flash player. downloaded the flash player update to my desktop and double clicked on it - it disappeared and nothing happened. but from then on i have had this connection problem and whenever i uncheck manual proxy and check no proxy i can get on the net but it is a hassle to have to do it everytime.

dickvl

User avatar
 
Posts: 51502
Joined: July 18th, 2005, 3:25 am

Post Posted December 6th, 2008, 12:26 am

You can ignore that warning. That warning should only apply to prefs.js and not to user.js. You can edit user.js or delete or rename user.js to user.js.sav if the proxy lines are the only lines in user.js.
Settings stored in user.js will override settings that were stored the previous time in prefs.js and thast is why you can't permanently change them on the about:config page.

See Preferences not saved (MozillaZine KB)

toolman_fixit
 
Posts: 36
Joined: November 27th, 2006, 11:51 am

Post Posted December 7th, 2008, 7:50 pm

this is a joke , why doesn't firefox have someone that actually works for mozilla answer questions about it instead of just users answering questions. xxx if you have a problem with internet explorer someone from microsoft answers your question and you get it fixed right away. it has been a week now still with no answers. i went into the default file and there is nothing there to make the box for "NO PROXYS" stay checked. it is always the same xxx with firefox , you have to rely on other users or you are xxx. no professional support at all. might as well switch back to explorer at least it works properly and there is professional support.

Daifne
Moderator

User avatar
 
Posts: 122757
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted December 7th, 2008, 8:02 pm

Can't count, can you? It's been four days, not seven.

Now, that language is not allowed here, since this is a family forum, and really was not necessary to make your point. I have edited it out. Please do not do it again or you won't be allowed to come here again.

Do you want to pay for Firefox? If they charged then maybe they could "outsource" the help. Hmmm. Outsource Firefox support to some third world country like Microsoft does... That would be just wonderful... Not.
“If you make people think they're thinking, they'll love you; but if you really make them think, they'll hate you.” ― Harlan Ellison
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

VanillaMozilla
 
Posts: 13802
Joined: November 7th, 2005, 11:26 am

Post Posted December 7th, 2008, 9:23 pm

You wrote that file, or something you installed wrote that file. Maybe spyware. Now you can delete the file. The ed-meister and Dickvl gave you the right advice in a day, not a week. For free. Next time you can pay us for the answer. Bye now.

Return to Firefox Support


Who is online

Users browsing this forum: dfoulkes, Google Adsense [Bot] and 24 guests