MozillaZine


How to Open odt Attachment

User Help for Mozilla Thunderbird
marcpare4
 
Posts: 2
Joined: February 21st, 2011, 6:41 am

Post Posted September 28th, 2022, 12:08 am

How does one go about adding the .odt file extension to the list of extensions recognized as attachments by TB? The .odt extension does not appear in the list where I can choose within TB to open with LibreOffice. In fact, none of the opensource LibreOffice extensions appear in the list of recognized attachment extensions in TB.

How would I go about adding any of the LibreOffice file extnesions? It would seem to me logical that there would be a way in the attachment section of the TB setup where one could add new filename extensions to the default list.

tanstaafl
Moderator

User avatar
 
Posts: 49588
Joined: July 30th, 2003, 5:06 pm

Post Posted September 28th, 2022, 1:15 am

They don't do it that way. They do just the opposite, where you get asked what utility to use when you try to open an attachment that it doesn't know how to open.

Right click on the attachment in a message and you should see a context menu with a "Open with" menu. You can use that to select a utility to view its contents and also check a checkbox to save that setting (adding it to the files & attachments section of tools -> settings).

If you already have .odt listed in the files & attachments section in tools -> settings than you can select the current choice in the Action column, click on the down arrow and use choose other to select a different utility. However, they don't let you directly add another Content-Type (.odt) to that table.

The list in the files & attachments section frequently doesn't list the file extension afterwards, it frequently has just a descriptive name . For example I have entries for OpenDocument Text and OpenOffice v1.1 spreadsheet in the Content-type column.

marcpare4
 
Posts: 2
Joined: February 21st, 2011, 6:41 am

Post Posted September 28th, 2022, 6:58 am

Strangely enough I only have "Open" and not "Open with". The choices offered are:
===
Open
Save as
Detach
Delete
===

I am using TB v.102.3.0 (64-bit) on Mageia Linux (TB is from the Mageia repository)

Marc

tanstaafl
Moderator

User avatar
 
Posts: 49588
Joined: July 30th, 2003, 5:06 pm

Post Posted September 28th, 2022, 8:22 am

It looks like they've changed things again recently and I forgot about it. I sent myself a message with a attachment with a .alf file extension (a license request for using Unity) . The Open menu choice has:

Open with : Applications\notepad++ (default)
Save File

[] Do this automatically for files like this from now on

When I select "Open with" the list box shows me the default choice plus "Other". That brings up a Choose Help Application window that lists 13 choices plus has Browse button to let you select the file for an executable.

As long as you know where the executables are stored you should be able to use Open with -> Other to select/add the helper utility. The main limitation is that the only command line argument is the complete path to the file you want to open, I'm not aware of any way to add additional command line arguments unless you edit the handlers.json file with a text editor.

Grumpus

User avatar
 
Posts: 13016
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted September 29th, 2022, 6:02 am

It may be the .odt file, being a text format, may open when just hitting open.
Doesn't matter what you say, it's wrong for a toaster to walk around the house and talk to you

tanstaafl
Moderator

User avatar
 
Posts: 49588
Joined: July 30th, 2003, 5:06 pm

Post Posted September 29th, 2022, 7:59 am

I sent myself a plain text message with a .odt file attachment. Opening the attachment using 102.3.0 brought up LibreOffice Writer. I then updated Thunderbird and confirmed it did the same thing using 102.3.1

As a sanity check I tried to open the attachment in the same message using a daily build (which had a different profile), Its profile only had entries for opening .pdf file attachments. The popup window defaulted to open with LibreOffice, I selected that radio button, and checked the checkbox to make it remember that. Worked fine.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 1 guest