MozillaZine

Thundebird server settings not staying as saved

User Help for Mozilla Thunderbird
laoan541
 
Posts: 2
Joined: July 24th, 2010, 2:02 pm

Post Posted July 24th, 2010, 2:16 pm

Hello all,

Thunderbird has developed an annoying glitch since my isp switched to using ssl. don't get me wrong, I am grateful they are now using TLS with SSL.

Problem is, every time Thunderbird starts I get an error message "The server does not support the selected authentication method. Please change the Authentication method in account settings..."

In Account Settings, Server settings, Authentication switches "normal password" (which works, and downloads my mail) back to "Any secure method (deprecated)".

I checked my friends pc who also has TB 3.1.1 and he doesn't even have "Any secure method (deprecated)" listed.

How do I rebuild my profile, do you think this would solve the problem?


Many thanks

tanstaafl
Moderator

User avatar
 
Posts: 45025
Joined: July 30th, 2003, 5:06 pm

Post Posted July 25th, 2010, 3:24 am

I don't have that entry in the "authentication method" list box in my copy of 3.0.6 , 3.1.1, or the latest nightly build. I've never seen it before.

What exactly does help -> about Thunderbird say you are using? I'm looking for something like Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.7) Gecko/20100713 Thunderbird/3.1.1

There are several threads about authentication problems with Comcast that have a similar error message. Who is your ISP?

sck18
Guest
 

Post Posted July 25th, 2010, 8:38 pm

I'm having the exact problem. Every time I close Thunderbird it resets to "any secure method (deprecated)" and errors out on checking mail until I change it to "password".

I'm running Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.7) Gecko/20100713 Thunderbird/3.1.1

tanstaafl
Moderator

User avatar
 
Posts: 45025
Joined: July 30th, 2003, 5:06 pm

Post Posted July 25th, 2010, 9:58 pm

The list box in my copy only has normal password, encrypted password, Kerberos / GSSAPI and NTLM as choices. What does yours have?

sck18
Guest
 

Post Posted July 26th, 2010, 4:38 am

All four options you've listed are in my box as well, and one more (Any Secured Method (Deprecated)) is at the bottom.

tanstaafl
Moderator

User avatar
 
Posts: 45025
Joined: July 30th, 2003, 5:06 pm

Post Posted July 26th, 2010, 1:17 pm

I found http://getsatisfaction.com/mozilla_mess ... n_settings where you have to figure out what server id your account uses, and then change mail.server.serverN.useSecAuth (where N is the server id) to false using the config editor.

The config editor is at tools -> options -> advanced -> general -> config editor. You can find the server id by typing your username in the edit field and then look for a mail.server.server setting that sets that username such as mail.server.server2.userName . In that case N = 2. So if this happened to me I would type mail.server.server2.useSecAuth in the edit field and then double click on the value to toggle it to false.

I suspect you might also be able to just type useSecAuth in the edit field and then toggle the value, since that setting doesn't exist by default. i.e. no need to search for the server id since that setting only exists in accounts with the problem you're running into.

You could also edit prefs.js directly like the thread did.

tanstaafl
Moderator

User avatar
 
Posts: 45025
Joined: July 30th, 2003, 5:06 pm

Post Posted July 26th, 2010, 1:28 pm

The closest bug report I could find was https://bugzilla.mozilla.org/show_bug.cgi?id=580270

Guest
Guest
 

Post Posted July 26th, 2010, 2:45 pm

Hello Tanstaafl,

Thanks for your interest in this problem - the bug report is indeed accurate here in this case.

I use Windows XP and edited the prefs.js file found in c:\documents and settings\my user\Application Data\Thunderbird\profiles\xyzmyprofile
and changed the value for useSecAuth from True to False:
Code: Select all
user_pref("mail.server.serverX.type", "pop3");
user_pref("mail.server.serverX.useSecAuth", False)


Now the account settings are saved and normal password is passed to the pop3 server. I also changed useSecAuth value to True for the smtp authentication part for sending mail as well.

This seems to fix the problem :D

Kudos to Allen Broughton:

Allen Brouhgton commented 13 days ago
I had to edit this line
user_pref("mail.server.server2.useSecAuth", true);
to
user_pref("mail.server.server2.useSecAuth", false);


Many thanks for your help
Laoan541

sck18
Guest
 

Post Posted July 26th, 2010, 8:52 pm

Using the string:
user_pref("mail.server.server2.useSecAuth", false);

worked for me - thanks!

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 8 guests