MozillaZine

Thunderbird keeps asking for password.

User Help for Mozilla Thunderbird
brucedimitroff
Guest
 

Post Posted March 14th, 2009, 1:47 am

can not get thunderbird to do anything for me it keeps asking for my password i keep entering and it will not work it shows that it is trying but ultimately nothing happens i have no idea why it will not respond when i use yahoo and send an email it just goes right out but thunderbird just sits there scrolling like it is trying but nothing works... and i am starting to repeat myself but it is very agitating .. every time i try to report a bug on various sites i click on their link and get loaded into thunderbird then i can never get message sent because of thunderbird !!! ARRRGGG!!!exasperation plusssssssssss!!PLEASE HELP!!!

steviex
Moderator

User avatar
 
Posts: 28902
Joined: August 12th, 2006, 8:27 am
Location: Middle England

Post Posted March 14th, 2009, 3:31 am

FIRST... Check that you have all your Mail settings correct......

Um, you really need to give us more information.....

When posting to a forum to request support it is helpful to detail what has already been tried so that folks won't post suggestions for the same unsuccessful "solutions".

* Which version of Thunderbird? Check Help>About for the version number.
* What operating system?
* What is the exact wording of the error message you are receiving?
* Do you have any extensions installed?
* What kind of mail - POP, IMAP?
* Is your mail service from an ISP, corporate e-mail system or Web-based?
* Are you using an antivirus and/or a firewall program? Which ones?
* Do you regularly compact your folders? Weekly or more often is strongly recommended. Check http://kb.mozillazine.org/Compacting_folders for more information on compacting folders.
* Without divulging your e-mail address or account name, what are your server settings, including server name and port number for:
+ Tools>Account Settings>*account*>Server Settings?
+ Tools>Account Settings>Outgoing Server (SMTP) (at the bottom of the list of accounts on the left)>*server*>Edit?
* Any recent changes in your computer or software configuration that might be relevant?
(including OS or Thunderbird updates, adding extensions or themes, etc. and any security program updates)

(Pinched from DanRaisch :) )
Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -Albert Einstein

Please DO NOT PM me for support... Lets keep it on the board, so we can all learn.

Beimborn
Guest
 

Post Posted March 24th, 2009, 10:07 am

steviex wrote:FIRST... Check that you have all your Mail settings correct......


* Which version of Thunderbird? Check Help>About for the version number.
* What operating system?
* What is the exact wording of the error message you are receiving?
* Do you have any extensions installed?
* What kind of mail - POP, IMAP?
* Is your mail service from an ISP, corporate e-mail system or Web-based?
* Are you using an antivirus and/or a firewall program? Which ones?
* Do you regularly compact your folders? Weekly or more often is strongly recommended. Check <!-- m --><a class="postlink" href="http://kb.mozillazine.org/Compacting_folders">http://kb.mozillazine.org/Compacting_folders</a><!-- m --> for more information on compacting folders.
* Without divulging your e-mail address or account name, what are your server settings, including server name and port number for:
+ Tools>Account Settings>*account*>Server Settings?
+ Tools>Account Settings>Outgoing Server (SMTP) (at the bottom of the list of accounts on the left)>*server*>Edit?
* Any recent changes in your computer or software configuration that might be relevant?
(including OS or Thunderbird updates, adding extensions or themes, etc. and any security program updates)

(Pinched from DanRaisch :) )



We have a password problem. Thunderbird (version 2.0.0.21) stopped working on March 12, 2009 for att.yahoo mail. It keeps asking for a password and returns "mail server pop.att.yahoo.mail responded invalid user password" We can use yahoo mail via the yahoo mail web site with the same password, so the password seems correct. I checked it under Thunderbird account optons and it is set correctly. I deleted and recreated the accounts but still it doesn't work.

there haven't been any changes in our system that we are aware of.

We use Windows XP, McAfee as our virus checker.
Incoming mail is pop.att.yahoo.com. port 995, SSL
outgoing server is smtp.att.yahoo.com port 465, SSL

Daifne
Moderator

User avatar
 
Posts: 122733
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted March 24th, 2009, 12:14 pm

Beimborn,
These connection problems have many different variables. Because of this, these topics can get very confused if more than one person is helped. Please start a new topic so we can help both of you better. Thanks.
JE SUIS CHARLIE
“If you make people think they're thinking, they'll love you; but if you really make them think, they'll hate you.” ― Harlan Ellison
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Some user
Guest
 

Post Posted March 30th, 2009, 2:39 pm

I had the same problem after setting a master password, removing all passwords and reentering them again. After editing the passwords in the privacy tab, it shows xmailbox:... where before I had mailbox:... So I investigated a little and edited the file signons.txt located in the thunderbird profile folder. I copied all xmailbox: data land pasted it in the same file. Then I renamed the new xmailbox to mailbox and entered the username below /username/ in front of the = (I tried to directly put the username under xmailbox but it didn't worked so had to create the mailbox...) Works fine now on all gmail and other sites with pop3, the only thing is that it won't open the "edit password" window, but signons.txt file format seems correct, anyway that's not very important the main thing is that it seems ok now.

BSlepkov
Guest
 

Post Posted August 24th, 2009, 2:34 pm

Want to get thunderbird to stop asking for the password? (Before starting I apologize if I seem to be repeating myself. Trying to cover wording variations for a google search. Way too many bogus suggestions out there regarding thunderbird constantly asking for a password.) I've tried to give detailed instructions mainly for the newbies, so sorry for the length.

After a lot of trial and error, (but not making any notes), I have succeeded at stopping t-bird from always asking for a password even on launching (starting up) and on three different computers all with:
* operating systems Linux Mint 7 (Gloria)
* Thunderbird 2.0.0.23
* gmail.com accounts
* two access sympatico.ca accounts using the same password used for the gmail account.

I think that getting to the solution is more a matter of a number of settings falling into place, than which version of Thunderbird or flavor of linux you might have. Someone might know just which of the settings really do matter, meanwhile, here's how to prevent thunderbird from always asking for an email account's password.

In thunderbird, select from menu:
Edit --> Preferences --> Advanced tab.
Click 'Config Editor...' button --- about:config window opens. In the Filter input at the top of window, enter 'password' and check the values of the following Preference Names. Note that to change incorrect values, double clicking on Preference Names of the boolean type toggles the value. Double clicking on a 'Preference Name' if no value is given at all will initiate a list from which to choose the value. Just don't ask me to explain why these settings work. Actually, I think some of the settings defy logic, however, the following settings do seem to work:
mail.password_protect_local_cache ... boolean ... false
mail.pop_password ... string ...
mail.remember_password ... boolean ... false
mail.server.server3.remember_password ... boolean ... true (server number may vary)
pref.privacy.disable_button.view_passwords ... boolean ... false
signon.expireMasterPassword ... boolean ... false

Next, in the filter box at top of about:config window, remove password and enter signon
mail.server.default.singleSignon ... boolean ... true
signon.expireMasterPassword ... boolean ... false
signon.rememberSignons ... boolean ... true

Next, replace signon in filter with login
mail.auth_login ... boolean ... true
mail.server.default.login_at_startup ... boolean ... false
mail.server.server2.login_at_startup ... boolean ... true
mail.server.server3.login_at_startup ... boolean ... true (the computer I'm using to prepare these instructions accesses two accounts)

Close the about:config window, but leave the Thunderbird Preferences window open for the next stage.

For the next step, we need to start over setting up the email accounts, so there are some things to consider in preventing thunderbird from always asking for a password. If you've been using email for sometime and want to safeguard any email folders you may have, I suppose you'll have to back up your email and folders. In my case, I was pretty well starting from scratch so can't really advise you from any experience on how to do that. I can say that the following process won't affect your address books. I suppose you could back up emails and folders by moving them into the 'Local Folders' especially if, like me, you want to keep your email account folders separate.

In the Preference window, select the Privacy tab.
Select the 'Passwords' tab.
Select 'Edit Saved Passwords' button.
(BTW, I've noticed that for some reason, the "Username" appearing for some 'Site's in the opening window, seem to be <not specified>. Go figure.)
Select 'Remove All' button.
Select 'Close' button.

Important Note! The Thunderbird Preferences window is still open. The "Use a master password to encrypt stored passwords" check box must be unchecked ... or blank. Again, don't ask me to explain it, just do it!

Now, finish the preferences by clicking on the 'Remove Master Password...' button. You will be asked for your 'thunderbird' password to remove it. Note that this is NOT the linux administration password. More than likely, it is the same password you've been using for your email account.
Click on 'Close'.

The next stage involves removing any and all existing email accounts. Here is where I could have used notes and observations to better direct you, alas ...

Still in thunderbird, select from menu:
Edit --> Account Settings...
Select each account (except Local Folders. Not sure what would happen if the 'Local Folders' was removed. Also, before you select the 'Remove Account' button, make note of whatever your settings are. You might need to refer to them.)
Click on 'Remove Account' button
Click on 'Outgoing Server (SMTP)' in left-hand window.
Remove every server shown (Don't forget to first make note of your existing settings for reference.)
Note! Be aware that for some unknown reason, Thunderbird doesn't offer you the option of removing the last remaining server and when you reestablish your accounts, as you will soon see, that server will be listed twice. Remember to remove one of duplicates.

Now close Account Settings, exit Thunderbird completely, wait a couple of minutes and relaunch. No password should be requested since no accounts currently exist, so now we set up the email account(s).

Select from the upper text menu:
Edit --> Account Settings...
You should only see Local Folders, Disk Space, Junk Settings and Outgoing Server (SMTP) at the left.
Clicking on 'Add Account...' opens up the Account Wizard with a listing of 5 kinds of accounts, including Gmail as well as Email account. Having a sympatico.ca and gmail.com account, I can tell you there are fewer steps to setting up Gmail. I am not going to go into step-by-step detail as far as setting up each type of account. Just a couple of points you might want to know and I will list what settings are working for me as I can email out from either account without being asked for passwords beyond the first time it is requested.
* Note that in entering a Gmail Address versus an Email Address, @gmail.com is automatically assigned. You just enter the part before the '@' sign.
* You should have noted the setting for 'Incoming Server' before you removed the account.
* If you want each email account to have its own set of folders, (inbox, draft, sent, etc) then remove the check from the "Use Global Inbox" checkbox.
* Some postings I've read regarding how to stop t-bird from asking for the password raise the issue of pop versus imap. Since some suggested changing POP to IMAP, and I have POP for both my accounts, I don't think it really makes a difference.
* In setting up the Incoming User Name, the wizard window only suggests what your user name might be. Any screw-up in setting this up can be corrected later. You may notice later as I did something like your.name@email.com@email.com in the Account Settings. You can change it without any problems.
* Setting up the Account Name I always experienced some buggy behaviour. This is intended to be the 'title' of your account, the one that appears in the Account Settings window to the left. You can also change this later. The Wizard defaults to the email address, in which case if you accept it, the Account Name will actually be set to something like: Email - your.name@email.com. If you want something like just Email as the account name, put it into the wizard input form and the next stage should take you to the end of setting up the account. On one occassion, I seemed to have gotten myself into a loop where I was never brought to the 'Congratulations!' window allowing me to verify my settings. I just escaped out of the Account Settings and started over. If you do just want Account Names to simply be 'Gmail' or 'Sympatico' as I just suggested above, then I recommend clicking on the 'Finish' Button and rather then step your way through all the Account Settings that should now appear under the account heading, close the Account Settings and reopen it. I say this because if you don't, and go through the various settings for the account, the wizard might seem to have ignored settings related to the account name you would rather have than the default. Trust me. It can get confusing. Closing and reopening the Account Settings fixes this bug.

Repeat the process for each account. (For newbies, I'll list certain settings that are working for me, following the instructions for the next stage)

The next phase initiates email retrieval from the accounts. If you exit Thunder and relaunch any time later, email retrieval will kick in if you have checked off 'check for new messages at startup' in the Server Settings for any of the accounts. Either way, the 'Password' window will open, detailing for which account the password is required. Before you enter the password, be sure that this the checkbox 'Use Password Manager to remember this password' IS checked. Now enter the password and hit return ... or whatever. You should be able to tell if everything is correct, by watching the status window at the very bottom left hand of the window. Otherwise, check your account settings.

Assuming you succeeded at downloading email, or at least accessing the email server, the next stage is to set the password for outbound email. You will need to do this for each account. And if you have more than one account, when you select 'Write', you should notice the From: input enables you to select from which account you are emailing. Send yourself a few test emails. The first time, for each account, you will be asked for your password, and for each, follow the same instructions given for retrieving email.

Now, instead of retrieving your email right away. Exit from T-bird and relaunch after waiting a couple of minutes. Provided that neither of us screwed up, You should rarely if at all, be asked for your password again.

Now for my pertinent settings:
Account Name: Gmail (since I only have one)
Server Settings:
Server Type: POP Mail Server
Server Name: pop.gmail.com Port: 995 Default: 99 (Note, this depend what you have chosen for the Security Settings that appear below.
Use secure connection 'SSL' should be selected. DO NOT CHECK 'use secure authentication'
Leave messages on server (check this box as you wish. It shouldn't affect the password as some posts seem to indicate. Same thing with regards to checking for new messages! That only matters if you haven't overcome the password issue in the first place.)

Account Name: Sympatico (since I only have one)
Server Settings:
Server Type: POP Mail Server
Server Name: pophm.sympatico.ca Port: 995 Default: 99
Use secure connection 'SSL' should be selected. DO NOT CHECK 'use secure authentication'

Outgoing Server (SMTP) - Note! One of your outgoing server will be set to default, but you can change which one is assigned the privilege.
Description: Gmail
Server Name: smtp.gmail.com
Port: 587
UserName: (whatever your email server would require. For Gmail, it's what appears to the left of the '@' sign. For my sympatico, you will see the user name is the full email address)
Secure Connection: TLS (Take note that it's not set to SSL!)

Description: Sympatico
Server Name: smtphm.sympatico.ca
Port: 25
User Name: (whatever your full sympatico email address is)
Secure Connection: TLS (if available)

Important note! If you see <not specified> in the User Name, select the account and click on edit. Select the 'Use name and password' checkbox under 'Security and Authentication' and then input your User Name into the form.

That's it! Hope this all helps.

dpahmeyer
Guest
 

Post Posted August 24th, 2009, 3:58 pm

I have a similar problem, but only one e-mail account. I have Thunderbird 2.0.0.23 and all of a sudden, it will not let us send e-mail without entering a password. I went through multiple steps with my ISP, Charter, and they verified the settings were correct but the problem persists. If we go onto Charter's webmail, we are not prompted to enter a password for sending e-mail. However, every time on Thunderbird, it is prompting us for a password. Is someone trying to steal our password? What is happening? Our OS is Vista.

SK.
Moderator

User avatar
 
Posts: 20750
Joined: October 18th, 2007, 1:28 pm
Location: Third Rock From The Sun

Post Posted August 24th, 2009, 4:01 pm

Folks, we have a lot going on in this thread - none of which seem to be addressing the primary problem (BSlepkov's lengthy and unnecessary tome notwithstanding).

If you have a problem, please start a new thread.

Locking.
John 3:16 and Philippians 4:13

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 11 guests