MozillaZine

Unable to send mail with attachments

User Help for Mozilla Thunderbird
Colin_Mac
Guest
 

Post Posted April 15th, 2009, 5:05 pm

Using Thunderbird version 2.0.0.21 (20090302), I can't send SMTP email with attachments. Email without attachments works fine. I can also send email with or without attachments from a different machine that it set up to use the same account but with IMAP.

The symptoms are that the email starts to go according to the progress bar, but stops when this reaches around 93%. The number varies inversely by attachment size; with a 74KB it stops at 93%, but with about 1MB of attachment it stops at 5%. When it hits this stage nothing happens for a while (around 45 seconds) then I get an error message.

The error message that Thunderbird displays is 'Sending of message failed. The message could not be sent because connecting to SMTP server ... failed. The server may be unavailable or is refusing SMTP connections. Please verify ...' etc.

I see the same behaviour whether using unsecured SMTP, TLS or SSL connections.

DanRaisch
Moderator

User avatar
 
Posts: 120784
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 15th, 2009, 5:51 pm

How recently have you compacted your folders? Compacting is something that needs to be done regularly in any email program. We recommend weekly, but many of us do it daily. When done often enough, it can be an extremely fast process. Not doing so can lead to problems like those you are experiencing. See this about how to and why it's so important: http://kb.mozillazine.org/Compacting_folders

If you haven't been doing that before, first back up your Thunderbird Profile -- http://kb.mozillazine.org/Profile_backup then compact all folders. If 'compacting' them (and leaving a long enough time for the process to complete) doesn't fully resolve the problem then do the following on each account:

Close Thunderbird. Find and delete all of the files with the .msf file extension in your profile folder/Mail http://kb.mozillazine.org/Profile_Folder#Thunderbird including your Local Folders, especially if you are using the global inbox. You must have "View hidden files and folders" on http://spywarewarrior.com/viewtopic.php?t=272 and you need to set "hide extensions for known file types" off (just below View Hidden) if you are using Windows. These are your mail summary files and do not hold any messages themselves. They will be rebuilt the next time you open each folder in Thunderbird. Compact all your folders when you have completed this.

To avoid this happening again, see the tips in these articles:
http://kb.mozillazine.org/Keep_it_worki ... derbird%29
http://kb.mozillazine.org/Performance_%28Thunderbird%29

Colin_Mac
Guest
 

Post Posted April 16th, 2009, 1:27 am

I have selected the option to have folders compressed automatically when it will save 100Kb. Also, having seen a similar response in a different thread, I compacted the folders to see if it would make a difference, but it didn't. I'll try removing the .msf files then re-compacting to see if it makes a difference.

DanRaisch
Moderator

User avatar
 
Posts: 120784
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 16th, 2009, 3:56 am

OK, and good luck.

makaiguy

User avatar
 
Posts: 16684
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted April 16th, 2009, 4:32 am

Do you have an antivirus program installed that scans your outgoing mail? Sometimes this can introduce enough of a delay into sending the messages that it messes up the program timing. Try reconfiguring the a-v program to NOT scan outbound mail.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 60.4.0 (32-bit) ║ Android 8.0/7.1.1: FF Mobile 64.0.1 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

Colin_Mac
Guest
 

Post Posted April 16th, 2009, 5:58 am

OK, I removed the .msf files, re-compacted the folders, but I still can't send emails with attachments.

I tried with and without antivirus running, but it had no effect. Also, the AV filter only runs on the unencrypted SMTP connection so the TLS / SSL connections aren't affected.

I tried a different SMTP server but the result is still the same.

For now I'll set up an additional account using IMAP rather than SMTP. That should allow me to send stuff OK, but it's not ideal.

Colin_Mac
Guest
 

Post Posted April 16th, 2009, 6:07 am

Except, of course, that an IMAP account still uses SMTP to send email. Argh.

This works OK on my laptop (running Vista) using the same SMTP server and the same internet connection. The problem is on the desktop PC, running XP. My guess is that there must be some dependency that Thunderbird has on some part of the OS, and on the XP box it just ain't working.

jstarks
Guest
 

Post Posted April 16th, 2009, 8:15 am

I am using Thunderbird for Mac: version 2.0.0.21 (20090302). I have not had problems in the past, but a server change at my office this weekend resulted in my not being able to include attachments with e-mail. Is the " delete .msf files" tip still used for Macs?

Thanks.

DanRaisch
Moderator

User avatar
 
Posts: 120784
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 16th, 2009, 9:44 am

jstarks, please start a new topic. You may have a totally different problem.

Minas_Tirith
Guest
 

Post Posted April 17th, 2009, 10:39 pm

I am facing exactly the same issue as Colin_Mac, and have tried out all the possible solutions mentioned here. This is on my laptop running XP and Kaspersky AV. Disabling Kaspersky didn't help either. I started facing this issue after having to re-format my machine/HDD and reinstall OS/Tbird. The only difference is that I had SYmantec AV running before the format and currently use Kaspersky.

tanstaafl
Moderator

User avatar
 
Posts: 44783
Joined: July 30th, 2003, 5:06 pm

Post Posted April 17th, 2009, 11:55 pm

I suggest you read Can not send large attachments

Have you tried increasing the connection timeout in Tools -> Options-> Advanced -> Network & Disk Space -> Connection? You don't always get a time-out error when a connection times out, sometimes its reported as a different error. This is another reason why its recommended you disable virus-scanning on messages you are sending.

Some other threads on the same problem:

viewtopic.php?f=39&t=647799 (problem fixed by firmware update on both ADSL and wireless router)

viewtopic.php?f=39&t=484179 (problem fixed by replacing CAT5 cable)

viewtopic.php?f=39&t=536896 (problem fixed by rebooting the router and modem) Notice that the problem occurred with very large message with 200 paragraphs and no attachment but not with a short message body with a 4KB attachment.

viewtopic.php?f=39&t=915155 (problem due to some settings changing, possibly during an upgrade. Resetting settings fixed the problem. Another user had same problem that was traced to using SpySweeper to scan outgoing messages.)

viewtopic.php?f=39&t=546927 (problem fixed by configuring "Do not scan e-mail messages including attachments" to 1MB in TrendMicro antivirus

viewtopic.php?f=39&t=570626 (problem due to using % in attachment filenames)

viewtopic.php?f=39&t=565747
viewtopic.php?f=39&t=39370
viewtopic.php?f=31&t=145427
(Same for all three. Only occurred for .doc attachments. Problem fixed by replacing "mimetypes.rdf" file)

viewtopic.php?f=39&t=642739 (problem with email provider)

Notice a pattern? Its usually due to either a hardware problem that doesn't show up when browsing , too short a connection timeout, or the user added some additional overhead when sending a message such as virus or spyware scanning.

I suggest either running a broadband speed test or downloading a several GB file using ftp to try to duplicate the problem without using Thunderbird.

Colin_Mac
Guest
 

Post Posted April 18th, 2009, 2:14 pm

WooHooo!!!! Sorted. And it's not a Thunderbird problem as such, but a problem that only arises when using Thunderbird. It also arises, bizarrely, when trying to access Flickr - I would go to http://www.flickr.com, provide my password to the Yahoo page and then the browser would stick on https://login.yahoo.com/config/login_verify2. This happened with Firefox and IE, so it wasn't a browser-specific issue. The login_verify2 page would have no content, and Firefox would just sit while IE would report that the page wasn't available. (I mention all this largely for the benefit of search engines and people with the same problem.)

The solution was to change the MTU in the router. It was 1500, I changed it to 1480 and suddenly stuff works.

The router is a Netgear DG834G. My Vista laptop, using the same router, doesn't have the same problem, therefore it isn't actually a problem in the router and therefore it must be a problem in the setup of XP SP2 + the assorted drivers that are in my desktop PC. Even so, reducing the MTU does the job so it's good enough for me. (I'm hoping that network speeds between my Vista laptop and the XP machine might also be improved.)

So for other folks reading this, you can try:
- upgrading your router firmware
- changing the MTU to something less than 1500, hopefully not too much less
- downgrading your router firmware
(or your problem may be nothing to do with your router.)

Minas_Tirith
Guest
 

Post Posted April 19th, 2009, 9:25 pm

Phew...what a relief! Changing the MTU to a lower value did the trick for me too. Thanks guys.

robpattison
Guest
 

Post Posted September 13th, 2012, 10:15 am

In Thunderbird; Go to tools/account settings? Server Settings

under Security Settings change Connection Security to "NONE"

Apparently an IMAP server does the virus scans and not the PC

DanRaisch
Moderator

User avatar
 
Posts: 120784
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted September 13th, 2012, 12:03 pm

robpattison wrote:under Security Settings change Connection Security to "NONE"

Apparently an IMAP server does the virus scans and not the PC


That setting has nothing to do with virus scans.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 3 guests