MozillaZine


images in html emails

User Help for Mozilla Thunderbird
captkirkstny
Guest
 

Post Posted April 15th, 2005, 10:06 pm

When I receive an email that is from sending a web page, the list of attachments is so large that the body of the message has no room to show. If I toggle between show attachments inline, then I can see the body for a second. Then the attachment list fills up the screen showing only the header and attachment list.

From work, I sent a page from TigerDirect to my home e-mail. when I open it at home, the list of attachments which is all the graphics from the page is huge.

I've tried all the documented solutions noted in previous posts.

captkirkstny
Guest
 

Post Posted April 15th, 2005, 10:09 pm

When I receive an email that is from sending a web page, the list of attachments is so large that the body of the message has no room to show. If I toggle between show attachments inline, then I can see the body for a second. Then the attachment list fills up the screen showing only the header and attachment list.

From work, I sent a page from TigerDirect to my home e-mail. when I open it at home, the list of attachments which is all the graphics from the page is huge.

I've tried all the documented solutions noted in previous posts.

dustboy
Guest
 

Post Posted April 23rd, 2005, 11:44 pm

captkirkstny wrote:I've tried all the documented solutions noted in previous posts.


so have I, and nothing have solve this problem. When I ran Thunderbird 1.0 i didn´t have this problem, it seems that it came with the upgrade?

Guest
Guest
 

Post Posted April 25th, 2005, 8:29 am

I have a few mails that would display images, and a few that wouldn't. Taking a closer look at the source, and experimenting with different ways of sending emails, it appears the difference is in the HTML. (Note: these have images embedded in the email, not linked)

TB CAN display image:
Content-Type: image/jpeg; name="screenshot.jpg"
Content-Transfer-Encoding: base64
Content-Disposition: inline; filename="screenshot.jpg"

TB CANNOT display image:
Content-type: application/octet-stream; name="screenshot.jpg"
Content-transfer-encoding: base64
Content-disposition: attachment; filename=name="screenshot.jpg"

I believe the second type of HTML is generated by some photo applications that can also email photos.

Outlook and Outlook Express can display both HTML.

So, either tell your friends to compose their email manually by using their email clients and either attaching or pasting the images (easier), or have Thunderbird develop inline viewing of contents that don't say "inline", but has a filename type of "jpg" or other image extensions (difficult).

Guest
Guest
 

Post Posted July 28th, 2005, 2:29 pm

This solved the issue for me. Thunderbird's Junk filter was tagging my mails a junk and "sanatising" the images.

Messages marked as Junk are normally "sanitized", meaning that they are displayed without any images or other HTML formatting. To change this behavior, go to "Tools -> Junk Mail Controls", click on the "Settings" tab, and uncheck the box for "When displaying HTML messages marked as Junk, sanitize the HTML".

Guest
Guest
 

Post Posted July 28th, 2005, 2:30 pm

Makes sure your Junk setting are set properly. This was my problem and now all images are recieved.

Messages marked as Junk are normally "sanitized", meaning that they are displayed without any images or other HTML formatting. To change this behavior, go to "Tools -> Junk Mail Controls", click on the "Settings" tab, and uncheck the box for "When displaying HTML messages marked as Junk, sanitize the HTML".

Guest
Guest
 

Post Posted September 22nd, 2005, 6:30 pm

bump how do you config your proxie's?

Guest
Guest
 

Post Posted September 22nd, 2005, 6:36 pm

also the view images button doesnt show up anymore how do i get it back?

henry88g
 
Posts: 4
Joined: October 31st, 2005, 3:26 am

Post Posted October 31st, 2005, 6:19 am

Anonymous wrote:also the view images button doesnt show up anymore how do i get it back?


Something like this started to happen to me only after I installed Thuderbird 1.07 (I was previously on 1.06)

I get daily email from a newspaper. For Thunderbird 1.06 I set options to block remote images in mail messages.
This meant that every day I clicked on the 'view images' button that appeared at the top of each such mail
message, and they appeared.

Until I installed 1.07. I changed nothing in the settings, but the view images button no longer makes the images
appear. Messages are not marked as junk. I don't have any proxies. Viewed as webmail on my ISP's
sight (using Firefox 1.5b2) all the images load. Using Firefox again, the images load properly when using
their individual URLs taken from Thunderbird via 'copy link location'.

I'm not particularly technical, and so when something changes unexpectedly, I tend to get worried.

Any ideas? Any nice trouble-shooting sequence for me to try?

henry88g
 
Posts: 4
Joined: October 31st, 2005, 3:26 am

Post Posted November 4th, 2005, 1:47 am

Panic over - it's my firewall. I must have denied internet access to remote images accidentally. Thanks to any of you who considered replying to my post. The matter is closed for me now.

a4ahmed1
 
Posts: 4
Joined: September 25th, 2005, 11:14 pm

Post Posted November 9th, 2005, 11:52 pm

Anonymous wrote:There is a little button in the right corner that says "show picture"

abacus66

User avatar
 
Posts: 1
Joined: December 15th, 2004, 10:43 pm

Post Posted December 21st, 2005, 12:19 am

kristinanoel wrote:It seems this is doesn't work as well as i thought it did.
it does work to show you the images, but then a couple of minutes later, i get a timed out message:
Connection to server timed out.

if i go back to automatic connection to the internet instead of manually setting proxies, i don't get timed out, but i don't get my images.

Does anyone know why that would happen?

thanks,
Kristina


I have the same problem??? What's wrong?

eddiejoe67
 
Posts: 30
Joined: May 1st, 2005, 3:40 pm

Post Posted September 4th, 2006, 7:30 am

I've tried everything here:

http://kb.mozillazine.org/Images_in_mes ... not_appear

Nothing has worked.

Some additional comments:

As for trying the manual proxy settings, I don't know what to set them to, eventhough I checked that box and tried it anyway.

Also, for some reason, if I try File:Save As or if I right click on the empty image box and try "Save As" or if I right click in the e-mail body and try "Save As" Thunderbird won't let me save anything.

The images are often, but not always, in a message that has been forwarded to me from the original receiver of the e-mail (in other words, I'm second in line from the original sender)

The content type in the original message is:
"multipart/mixed; boundary="part1_24a.7cdfd67.322b2e10_boundary"

I've also tried shutting off the "basic mail safe" in Zone Alarm-- didn't work. I have no ad filters installed.

Anyone have any ideas at all?

dtobias
 
Posts: 2098
Joined: November 9th, 2002, 3:35 pm
Location: Boca Raton, FL

Post Posted September 4th, 2006, 7:36 am

Anonymous wrote:TB CANNOT display image:
Content-type: application/octet-stream; name="screenshot.jpg"
Content-transfer-encoding: base64
Content-disposition: attachment; filename=name="screenshot.jpg"


Well, why <i>should</i> it? The sender here is telling the recipient that the data is not an inline image, but rather an attachment that is an unknown-format binary file (that's what "application/octet-stream" means). The proper thing for a recipient program to do is to make the file available for saving as an attachment, unless it suppresses it altogether as a virus risk.
Dan's Web Tips: http://webtips.dan.info/
Dan's Domain Site: http://domains.dan.info/
Dan's Mail Format Site: http://mailformat.dan.info/

eddiejoe67
 
Posts: 30
Joined: May 1st, 2005, 3:40 pm

Post Posted September 5th, 2006, 4:26 pm

See my post from 9/4/06 (two posts up). Any ideas?

Thanks.

Return to Thunderbird Support


Who is online

Users browsing this forum: tanstaafl and 3 guests