MozillaZine

Opening links *not* with Firefox (Linux) [SOLVED]

User Help for Mozilla Thunderbird
YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted January 5th, 2010, 11:14 pm

I currently use three different operating systems. On my desktop, I have openSUSE and Windows 7, and on my Eee PC, I have Fedora. When I use Linux, Opera is my primary browser, with Firefox as my secondary (for some Flash-related things that don't work right in Opera); on Windows, Firefox is my main.

I wish that, like Pidgin, Thunderbird had an option in the preferences to choose which browser opens links. I'm using Fedora with LXDE, and there is no config tool that can set a default browser as of yet. I couldn't find one in openSUSE (KDE 4) either.

I tried this (replacing /usr/bin/firefox with /usr/bin/opera) to no avail; Firefox was still being opened.

It's rather inconvenient to have remember to right click a link and copy the link's location, then paste it into a new tab in Opera.

EDIT: Solution is posted by sehiy.k further down on the page.
Last edited by YAOMTC on February 14th, 2010, 1:43 pm, edited 1 time in total.

charityalbumman

User avatar
 
Posts: 21
Joined: July 1st, 2009, 1:13 am
Location: UK

Post Posted January 5th, 2010, 11:18 pm

Why not change your default browser? i.e. Make the browser you wish the links to open in the default browser.
Peter Slater's Reaching for a Cure * Cancer Research UK Charity Fund Raiser *

YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted January 5th, 2010, 11:51 pm

charityalbumman wrote:Why not change your default browser? i.e. Make the browser you wish the links to open in the default browser.

YAOMTC wrote:I wish that, like Pidgin, Thunderbird had an option in the preferences to choose which browser opens links. I'm using Fedora with LXDE, and there is no config tool that can set a default browser as of yet. I couldn't find one in openSUSE (KDE 4) either.

charityalbumman

User avatar
 
Posts: 21
Joined: July 1st, 2009, 1:13 am
Location: UK

Post Posted January 5th, 2010, 11:58 pm

My bad lol sorry I mis-read that part.
Peter Slater's Reaching for a Cure * Cancer Research UK Charity Fund Raiser *

YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted January 7th, 2010, 5:41 pm

Moving it back up.

YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted January 16th, 2010, 11:01 pm

Again

tanstaafl
Moderator

User avatar
 
Posts: 44477
Joined: July 30th, 2003, 5:06 pm

Post Posted January 17th, 2010, 8:30 am

Did you try editing the startup script per http://kb.mozillazine.org/Setting_Your_ ... ora_Core_3 rather than setting network.protocol-handler ?

YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted January 19th, 2010, 2:54 am

tanstaafl wrote:Did you try editing the startup script per http://kb.mozillazine.org/Setting_Your_ ... ora_Core_3 rather than setting network.protocol-handler ?

I'm not sure how I could edit that to make Opera be used instead... Also that just looks like instructions on "If you want the URLs to open in a new tab instead of new window", am I wrong?

YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted January 22nd, 2010, 1:05 am

[BUMPitUP]

fdservices

User avatar
 
Posts: 128
Joined: January 26th, 2004, 6:37 am

Post Posted January 22nd, 2010, 2:59 am

The reference was to:
"If you are unable to launch Firefox (or another Mozilla browser) from URL links in a Thunderbird mail message, or if you want to change the browser that is launched, add the following lines to the user.js file, located in your Thunderbird profile folder (you may need to create the user.js file). Change the path of the Firefox executable, if yours is not /usr/bin/firefox. [9] [10]

user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.https", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.ftp", "/usr/bin/firefox");

Note: You can also use about:config to set these preferences. See Register protocol and network.protocol-handler.app.(protocol) for more information."

and also:
http://kb.mozillazine.org/Network.proto ... rotocol%29

Having said that I cannot get any link to open in any browser after upgrading to TB 3 on one of my machines so I can't really help.

Andrew

YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted January 22nd, 2010, 11:53 pm

Yeah, I tried that.

I wonder if this is even possible right now.

fdservices

User avatar
 
Posts: 128
Joined: January 26th, 2004, 6:37 am

Post Posted January 23rd, 2010, 12:14 am

I have a similar problem. I have two PCs and one works fine, the other refuses to open any browser when I click on a link. Both PCs have EXACTLY the same .profile and mail folder (I know because I copied them over.

On the PC that will not open the browser I get a message in the Error Console when I click on a link:

"Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalProtocolService.loadUrl]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://communicator/content/contentAreaClick.js :: openLinkExternally :: line 188" data: no]"

Can someone help with this please?

YAOMTC - do you get an error in the Error Console?

Andrew

sehiy.k
Guest
 

Post Posted February 4th, 2010, 2:59 am

I managed with this. Now I can open http links from thunderbird in opera.

You need install gconf-editor. Then launch it using the comand gconf-editor, navigate to /desktop/gnome/url-handlers/http/ and change the value into /usr/bin/opera "%s", and it works!!!

Before I tried many things, changing user.js according to http://kb.mozillazine.org/Default_brows ... rd_-_Linux, setting x-www-browser and other things, none worked, only this one with gconf-editor, though I use KDE4.

fdservices

User avatar
 
Posts: 128
Joined: January 26th, 2004, 6:37 am

Post Posted February 4th, 2010, 4:17 am

That is bizarre

Andrew

YAOMTC

User avatar
 
Posts: 28
Joined: November 24th, 2007, 4:15 pm

Post Posted February 14th, 2010, 1:42 pm

That solved it! Thanks a lot, sehiy.k! :D

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 12 guests