MozillaZine

TB 3.0 doesn't see imap folders made outside of TB

User Help for Mozilla Thunderbird
cm78
 
Posts: 4
Joined: January 17th, 2010, 7:53 am

Post Posted January 17th, 2010, 8:04 am

Hi folks,

I use cyrus imapd (cyrus-imapd-2.2.3-83.22) as an imap server and regularly transfer imap mailboxes using imapsync (imapsync,v 1.153) on linux.

imapsync is a great tool for massmigration of imap folders across imap-servers and with thunderbird 2.x I had no further problems.

Now with TB 3.0 I cannot see nor subscribe to any folders created by imapsync. Checking back with TB 2.x, I can see and subscribe to them. After this, they are accessible by TB 3.0. When I again unsubscribe those folders in TB 3.0 they are lost again for TB 3.0.

Anyone seeing the same? Any ideas?

cm78

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted January 17th, 2010, 8:51 am

My main email account uses a Cyrus v2.3.16-fmsvn IMAP server (Fastmail) and Thunderbird 3.0 shows any folder I create in webmail if I uncheck tools -> account settings -> server settings -> advanced -> show only subscribed folders. I have no problem subscribing to any folder created in webmail.

The imapsync man page mentions --subscribed and --subscribe command line arguments. Perhaps you need to use them with 3.0.

I've used IMAPSize (rather than imapsync) in the past though I haven't used it since upgrading to 3.0.

cm78
 
Posts: 4
Joined: January 17th, 2010, 7:53 am

Post Posted January 17th, 2010, 9:19 am

Thanks for your reply.

Using the --subscribe argument seems to be a workaround. :-)

Anyway, once unsubscribed, TB 3.0 doesn't show those folders again. So there must be another difference in imap-handling in TB 3.0 vs. TB 2.x.

IMAPSize is nice, too, but it's got some nasty bugs in it, especially when handling huge imap-mailboxes.

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted January 17th, 2010, 9:25 am

I suggest you file a bug report at https://bugzilla.mozilla.org/ . If you do that please post a link to it.

cm78
 
Posts: 4
Joined: January 17th, 2010, 7:53 am

Post Posted January 17th, 2010, 3:14 pm

It's something like https://bugzilla.mozilla.org/show_bug.cgi?id=529618

So I hope it's being worked on already. Pretty annoying bug, I might add.

Is it safe to downgrade to TB 2 with a TB profile already used by TB 3?

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted January 17th, 2010, 7:36 pm

Yes, though that might create a pseudo smart folders account that you can't delete except by editing prefs.js. Its not clear yet if that has any harmful sideffects. Some people don't get that account, some get it grayed out, and some have it enabled.

It did cause problems when I switched from a beta to 2.0.0.23 (gradually corrupted the index files) for along period of time. However I'm currently sharing a profile with 2.0.0.23, 3.0 and the latest 3.0 trunk build with no obvious problems though I don't run 2.0.0.23 much anymore.

If it causes problems see http://kb.mozillazine.org/Transferring_ ... hunderbird for how to transfer stuff to a new profile.

Your passwords are stored in a different file in 3.0 but it didn't delete the file used by 2.0.0.23 to store passwords, so unless you changed them that shouldn't be a problem. You may have to customize the toolbar again.

cm78
 
Posts: 4
Joined: January 17th, 2010, 7:53 am

Post Posted January 18th, 2010, 3:06 am

Thank you. Your've very helpful.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 12 guests