MozillaZine

Character encoding problem.

User Help for Mozilla Thunderbird
colchicum
 
Posts: 18
Joined: February 10th, 2008, 9:59 am
Location: Newfoundland

Post Posted October 4th, 2010, 4:12 pm

Some of the HTML messages I receive are displayed with the wrong character encoding. In particular UTF-8 is not detected and the display uses western (ISO-8859-1) so that an apostrophe comes out as ’. This can be put right in the drop down view menu, but why doesn't Thunderbird detect it? Charset=UTF-8 does appear in the message header.

dtobias
 
Posts: 2098
Joined: November 9th, 2002, 3:35 pm
Location: Boca Raton, FL

Post Posted October 7th, 2010, 12:09 pm

Maybe the headers are in incorrect syntax, or are contradicted by a meta tag giving a different encoding?
Dan's Web Tips: http://webtips.dan.info/
Dan's Domain Site: http://domains.dan.info/
Dan's Mail Format Site: http://mailformat.dan.info/

Zapp
 
Posts: 12
Joined: July 17th, 2008, 5:39 am

Post Posted February 18th, 2011, 2:16 pm

Finally my problem is solved. After living with this problem for months I ran across this solution
found at http://www.moorlandit.net . I would have NEVER figured this out on my own.
Regards, Zapp

Thunderbird Character Encoding

Jul.29, 2010 in Email

Recently I’ve been receiving email in Mozilla Thunderbird which display odd characters. Changing the character encoding of the individual message solved the problem but only for that message.
Auto detection of the character encoding was enabled but didn’t seem to be working – until I messed around with the settings and did this:
Go to Tools > Options > Advanced > Config Editor and make sure that mailnews.force_charset_override is set to false
Now right click on your Inbox and choose Edit > Folder Properties and make sure that the checkbox “Apply default to all messages in the folder…” is NOT checked.

http://www.moorlandit.net/index.php/201 ... coding-139

Daifne
Moderator

User avatar
 
Posts: 123034
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted February 19th, 2011, 9:14 pm

Moving to Thunderbird Support

LDJ
Guest
 

Post Posted November 25th, 2011, 9:06 am

Hello Zapp!

Thank you very much!
The issue with characters not being shown correctly, have annoyed me for as long as I remember, and it's almost unbelievable to see that the incoming msg's are now shown with the character encoding being automatically detected, and shown correctly :D

Kind Regards
LDJ

XSnowman
Guest
 

Post Posted December 18th, 2011, 9:48 am

Zapp wrote:Go to Tools > Options > Advanced > Config Editor and make sure that mailnews.force_charset_override is set to false
Now right click on your Inbox and choose Edit > Folder Properties and make sure that the checkbox “Apply default to all messages in the folder…” is NOT checked.


THANKS!!! :D
This fixed my encoding problem that has been persistant for more than a year... Updates never fixed it, but this tip did :)

pasatempo
Guest
 

Post Posted April 17th, 2012, 3:46 am

Thanx!!! finally it's fixed

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 7 guests