MozillaZine

HELP! The wrong date and time show on Thunderbird

User Help for Mozilla Thunderbird
Billy99
 
Posts: 19
Joined: October 12th, 2010, 1:08 am

Post Posted October 12th, 2010, 1:18 am

Hi
I sent a message on 12th October 7:31pm. I received a reply a short time afterwards.

The message I sent shows in my Thunderbird as 7:31pm (12th) which is correct. The reply I received shows as 11th Oct 11:54pm which is totally wrong. :(

I have BOTH the Date and the received columns showing on my Thunderbird. These both show IDENTICAL dates and times.

The person I sent the email to says their computer time and date setting are the correct. PS We both use the same ISP.
How do I fix this?
Thanks in advance
Billy99

DETAILS FOLLOW:================

MY SYSTEM:
Thunderbird 3.1
Windows 7 64 bit

THE ORIGINAL MESSAGE I SENT (FROM VIEW MENU)

From - Tue Oct 12 19:31:50 2010
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
X-Mozilla-Keys:
Message-ID: <4CB51A12.6010205@xtra.co.nz>
Disposition-Notification-To: ********@xtra.co.nz>
Date: Tue, 12 Oct 2010 19:31:46 -0700
From: ******@xtra.co.nz>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1
MIME-Version: 1.0
To: ********@xtra.co.nz>,
******
Subject: PhD Full Proposal --- the basics
Content-Type: multipart/alternative;
boundary="------------040207010506090402090101"

This is a multi-part message in MIME format.
--------------040207010506090402090101
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 8bit


THE REPLY I RECEIVED TO THE ORIGINAL MESSAGE
From - Tue Oct 12 19:54:49 2010
X-Account-Key: account10
X-UIDL: AFdgbHwAAQ1bTLQGEgaT6H+2wZA
X-Mozilla-Status: 0013
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:
X-Apparently-To: ******xtra.co.nz via 124.108.96.87; Mon, 11 Oct 2010 23:54:10 -0700
Received-SPF: none (mta105.tnz.mail.aue.yahoo.com: domain of ******@xtra.co.nz does not designate permitted sender hosts)
X-YMailISG: Nwql8gIcZArfaXdDc8pCmrf9KrFxY1weEK26h9yaNsQSDouM
YGIOKhNdQQQv3ToCtvTh3EUgqv6_5zw_llfXx2PdC3LN5XJUQ.vFEwgcTfX0
wnBF4uq_TeD07uqXxY8ViDf01gfwV7akioPvnqTaaZGUyHzQ3nvZzx22TV7_
WVgY4_6_SsnywfO.Jlwa2OCLnZPS5v9a.YhVdvrrTxL8TIWT54n4azVDq7Rj
RqzCmTLOtwzgSNwDzCT5ubYOTq4KyI.3zZ9oYapWfSJ8U9mqr4F3RbQuWF2j
LqZk6c3rDVYOQFdcqRU2bJULjHosYS9QIdenAQirhWV6_zupeFSkzhYD3qME
7p6QmAHMgLQIYlEws1R_UGcEw4A7OhZ2xwq_3y2Wj3ZriZYZ7HbiPYWrvqMO
q23B5xRsGHOrdXo8mvi102PiLkZtX9DFOEOQKSMbSonjy0vR9gySskd3iZOm
G.5MByYdmELQcdJSmSBR3CRqUbzbmTTsBKjBwj7WAWXcVGOf1i0t.jEViyPS
XGnZijZUrVLN9W7zeDSi7m_CJMnHR646hw--
X-Originating-IP: [124.108.96.113]
Authentication-Results: mta105.tnz.mail.aue.yahoo.com from=xtra.co.nz; domainkeys=neutral (no sig); from=xtra.co.nz; dkim=neutral

(no sig)
Received: from 124.108.96.113 (HELO rel106.mail.aue.yahoo.com) (124.108.96.113)
by mta105.tnz.mail.aue.yahoo.com with SMTP; Mon, 11 Oct 2010 23:54:10 -0700
Received: (qmail 77570 invoked by uid 1000); 12 Oct 2010 06:54:09 -0000
Received: from 124.108.96.75 by rel106.mail.aue.yahoo.com with SMTP; Mon, 11 Oct 2010 23:54:09 -0700
Received: (qmail 34793 invoked from network); 12 Oct 2010 06:54:09 -0000
Received: from ***********
by smtp106.tnz.mail.aue.yahoo.com with SMTP; 12 Oct 2010 17:54:09 +1100 EST
X-Yahoo-SMTP: LbFp9fiswBD0Z0o_XF1iGeafIm6AtDtRh6T80wfol_fWsG9sFw--
X-YMail-OSG: UtD29O0VM1kuBtB7FpwGo9RTj..ylbGe2iduUwj7joCKXq7
Z5hIK_7KSa8dnYSGB4KD_SWlY49kodE6U3i9LgOyEnF__TgtcvIj4QTDF_wq
NbpMmB.A.ArFUfajN_WdKFaWH8tRvpyqdKvFAEWRCekDMVs3_jQARIiSZQ9d
xcaiwBu2yc0kIvZn7x_ZpskY2zhETm_9MN12SF_vSgCX8ftIHXz.5rmlLLrM
BK6BNUHIhvOCb09rF4ePwFLXBXHVGo1ByXKW9KLjS
From: *********@xtra.co.nz>
To: ********@xtra.co.nz>
References: <4CB51A12.6010205@xtra.co.nz>
In-Reply-To: <4CB51A12.6010205@xtra.co.nz>
Subject: RE: PhD Full Proposal --- the basics
Date: Tue, 12 Oct 2010 19:54:11 +1300
Message-ID: <006c01cb69da$4695cac0$d3c16040$@co.nz>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_006D_01CB6A47.3D8F12C0"
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: Actp1yr4W2ZvHRSXQQqqTMxJ/JzI2QAAwjcQ
Content-Language: en-nz
X-EsetId: 9C08C220BFE92639C94C

This is a multi-part message in MIME format.

Guest
Guest
 

Post Posted October 12th, 2010, 6:12 am

Sure looks like you and your correspondent are in different time zones. Could that be the answer?

makaiguy

User avatar
 
Posts: 15640
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted October 12th, 2010, 7:48 am

The Date header on the two messages:

Billy99 wrote:THE ORIGINAL MESSAGE I SENT (FROM VIEW MENU)
Date: Tue, 12 Oct 2010 19:31:46 -0700


    Your system is identifying your computer as being set up for the timezone located 7 hours west of Greenwich Mean Time, hence the -0700 appended to the time stamp.

    The GMT for your message is 13 Oct 2010 02:31:46 (i.e. since you are located 7 hours "behind" GMT, the GMT was 7 hours later, which crosses over midnight and into the next day).

    GMT does not go on Daylight Savings time, so if you are in a part of the world that is currently on Daylight Savings Time, your claimed time zone would shift by an hour. For standard time, your computer indicates a time zone of US/Canadian Mountain Time, or US/Canadian Pacific Time if you are currently under Daylight Savings.

    With your email addresses indicating a New Zealand location (via the .nz suffix), I'm suspicious of your settings.

THE REPLY I RECEIVED TO THE ORIGINAL MESSAGE
Date: Tue, 12 Oct 2010 19:54:11 +1300


    Your correspondent's computer is set up for timezone located 13 hours east of Greenwich Mean Time.

    The GMT for your correspondent's message is 12 Oct 2010 06:54:11

    Most time zones only go up to 12 hours east of GMT, beyond which they cross the International Date Line and become GMT -12. But there are some exceptional areas where the International Date Line has been diverted eastward around that point to allow the date to be the same as for its neighbors to the immediate west, thus creating a GMT +13 hour time zone. This affects several small island groups in the South Pacific, most notably Tonga.

    So, unless your correspondent is really located on such an island affected by a shift in the International Date Line, then I'm suspicious of his settings too.

My guess is that one or both of you does not have your computer set to the correct time zone. Note that, even with an incorrect time zone, you can still make brute force changes to the date and time that will force the local date and time to appear correct. But the time and date relative to GMT will be off with the result that converting GMT-based time to your system's time will result in errors in date and time.

Further information in the Mozillazine Knowledge Base:

General information about the Time/Date settings on your system:
http://kb.mozillazine.org/Time_and_time_zone_settings

Time/Date displayed in Thunderbird:
http://kb.mozillazine.org/Date_display_format
Doug Wilson, "The Makai Guy"
Win7 Home Prem (64bit): FF 38.0.2, TB 31.6.0║ Android 4.2.2/4.4.2: FF 38.0, no TB available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

drivebull

User avatar
 
Posts: 2
Joined: November 11th, 2010, 5:10 pm

Post Posted November 11th, 2010, 6:16 pm

Billy99,
I think that fixing the "Received" column could be a solution for you. Worth to try.

As you said, the "Date and the "Received" columns show the same information, while they should be, in general, at least a bit different. I'm going to show you the solution that worked for me on Thunderbird 3.0.

Edit->Preferences->Advanced->Config Editor

Set the variable:
mailnews.use_received_date = true (boolean)

If you are using a POP3 account, that should suffice (I didn't verify this statement).

For a IMAP account, you should create (if missing) the string variable:
mailnews.customDBHeaders = Received (string)

If that variable is already present, append "Received" to the old value.

Then, restart Thunderbird and compact the folders to re-index the content.

In this way, the "Received" column will not be identical to the "Date" column anymore; now it shows the reception date on your mail server, that is generally considered to be a better choice.

I've been using Microsoft Outlook Express for so many years, 5 years ago I was wanting to migrate to Thunderbird but when I discovered the Date problem I had to give up.
Sometimes I checked it up again, hoping that such a severe bug could be fixed, but with no result. On forums dealing on this subject, many of the contributors were suggesting that sorting by the "Order Received" column was the "final solution" for the problem, but that was NOT a definitive solution, sometimes it worked but in some cases it didn't.

I thought it was such a shame that such a good piece of software could not perform a function that in every Webmail interface and in every other major Email Client (ex. Microsoft) was presented by default; that limitation was totally unacceptable for me. I was so surprised, I couldn't believe that the developers could treat such thing like a minor bug.

A few months ago I started to search again on this subject among Forums, and after soooo many tries I finally found this topic:
viewtopic.php?f=39&t=657717

There, you'll find two posts by bkennelly (first post on page 1: May 22nd, 2008, 9:32 pm - and second post on page 2: July 23rd, 2008, 9:23 pm) that explain very clearly this solution.
What a pity that such a precious information had to remain almost hidden for more than 2 years! I'm writing now because I want everybody to know this very simple solution. Please help me to spread this information!

That solution worked for me, so hopefully it should for you!

Note: I recently upgraded to Thunderbird 3.1 and everything is still fine.

Good luck! And let me know if it worked for you!

Guido Torelli - ITALY

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests